aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2004-02-27 10:54:06 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2004-02-27 10:54:06 +0000
commitb3d7e7b916bc152a83f41aeae8ecb8c68fb739d9 (patch)
tree9c6090aa1ffaa15f71441ca74687e1c12c1b8fa6 /benchmarks
parentc19547d909e0d36fc43f86eb78d9667fbf2396e4 (diff)
downloadports-b3d7e7b916bc152a83f41aeae8ecb8c68fb739d9.tar.gz
ports-b3d7e7b916bc152a83f41aeae8ecb8c68fb739d9.zip
Fix BROKEN by update to latest 2.8.0 version.
Utilize DATADIR, SIZEfy. Add -Wno-deprecated to CPPFLAGS for fix annoing warnings. Approved by: adrian (maintainer) informed.
Notes
Notes: svn path=/head/; revision=102282
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/polygraph/Makefile10
-rw-r--r--benchmarks/polygraph/distinfo3
-rw-r--r--benchmarks/polygraph/files/patch-src::loganalyzers::SideInfo.cc15
-rw-r--r--benchmarks/polygraph/files/patch-src::xparser::SynSym.h13
-rw-r--r--benchmarks/polygraph/pkg-plist72
-rw-r--r--benchmarks/polygraph31/Makefile10
-rw-r--r--benchmarks/polygraph31/distinfo3
-rw-r--r--benchmarks/polygraph31/files/patch-src::loganalyzers::SideInfo.cc15
-rw-r--r--benchmarks/polygraph31/files/patch-src::xparser::SynSym.h13
-rw-r--r--benchmarks/polygraph31/pkg-plist72
10 files changed, 128 insertions, 98 deletions
diff --git a/benchmarks/polygraph/Makefile b/benchmarks/polygraph/Makefile
index 36a0b2db86d8..881458b5ca5c 100644
--- a/benchmarks/polygraph/Makefile
+++ b/benchmarks/polygraph/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= polygraph
-PORTVERSION= 2.7.6
+PORTVERSION= 2.8.0
CATEGORIES= benchmarks www
MASTER_SITES= http://www.web-polygraph.org/downloads/srcs/
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
@@ -15,14 +15,10 @@ EXTRACT_SUFX= .tgz
MAINTAINER= adrian@FreeBSD.org
COMMENT= A benchmarking tool for Web proxies
-
IS_INTERACTIVE= yes
GNU_CONFIGURE= YES
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -Wno-deprecated"
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-.include <bsd.port.pre.mk>
-
-BROKEN= "Does not compile"
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/benchmarks/polygraph/distinfo b/benchmarks/polygraph/distinfo
index 27c58908daf8..dddc4b79c985 100644
--- a/benchmarks/polygraph/distinfo
+++ b/benchmarks/polygraph/distinfo
@@ -1 +1,2 @@
-MD5 (polygraph-2.7.6-src.tgz) = e23cbb26939217d3ad295bce64a2096d
+MD5 (polygraph-2.8.0-src.tgz) = e006ecd99637aa78c47d6b9b13774eaa
+SIZE (polygraph-2.8.0-src.tgz) = 710102
diff --git a/benchmarks/polygraph/files/patch-src::loganalyzers::SideInfo.cc b/benchmarks/polygraph/files/patch-src::loganalyzers::SideInfo.cc
new file mode 100644
index 000000000000..5b5f5adf8f4d
--- /dev/null
+++ b/benchmarks/polygraph/files/patch-src::loganalyzers::SideInfo.cc
@@ -0,0 +1,15 @@
+--- src/loganalyzers/SideInfo.cc.orig Thu Feb 26 16:55:36 2004
++++ src/loganalyzers/SideInfo.cc Thu Feb 26 16:56:05 2004
+@@ -1166,9 +1166,9 @@
+ XmlTag descr("description");
+
+ XmlTextTag<XmlParagraph> p1;
+- p1.buf() << "The 'Errors' table shows detected errors. For each
+- error type, the number of errors and their contribution towards
+- total error count are shown.";
++ p1.buf() << "The 'Errors' table shows detected errors. For each "
++ "error type, the number of errors and their contribution towards "
++ "total error count are shown.";
+ descr << p1;
+
+ blob << descr;
diff --git a/benchmarks/polygraph/files/patch-src::xparser::SynSym.h b/benchmarks/polygraph/files/patch-src::xparser::SynSym.h
new file mode 100644
index 000000000000..f13ebb464464
--- /dev/null
+++ b/benchmarks/polygraph/files/patch-src::xparser::SynSym.h
@@ -0,0 +1,13 @@
+--- src/xparser/SynSym.h.orig Thu Feb 26 18:21:19 2004
++++ src/xparser/SynSym.h Thu Feb 26 18:21:49 2004
+@@ -54,8 +54,8 @@
+ String theType;
+ };
+
+-#define SymCast(Type, var) ((Type&)((var).cast(Type##::TheType)))
+-#define ConstSymCast(Type, var) ((const Type&)((var).cast(Type##::TheType)))
++#define SymCast(Type, var) ((Type&)((var).cast(Type::TheType)))
++#define ConstSymCast(Type, var) ((const Type&)((var).cast(Type::TheType)))
+
+ inline ostream &operator <<(ostream &os, const SynSym &sym) { return sym.print(os); }
+
diff --git a/benchmarks/polygraph/pkg-plist b/benchmarks/polygraph/pkg-plist
index 4222a98d2d24..fe305ecb7c2c 100644
--- a/benchmarks/polygraph/pkg-plist
+++ b/benchmarks/polygraph/pkg-plist
@@ -5,7 +5,9 @@ bin/dns_cfg
bin/lr
bin/ltrace
bin/lx
+bin/pgl2acl
bin/pgl2eng
+bin/pgl2ldif
bin/pgl_test
bin/polyclt
bin/polymon
@@ -14,46 +16,34 @@ bin/polypxy
bin/polyrrd
bin/polysrv
bin/pop_test
+bin/reporter
bin/rng_test
+bin/tcp2xmld
bin/udp2tcpd
-share/polygraph/ReportGen/Globs.pm
-share/polygraph/ReportGen/Line.pm
-share/polygraph/ReportGen/ObjDbase.pm
-share/polygraph/ReportGen/ObjManip.pm
-share/polygraph/ReportGen/Opts.pm
-share/polygraph/ReportGen/Plot.pm
-share/polygraph/ReportGen/RepFormat.pm
-share/polygraph/ReportGen/label_results
-share/polygraph/ReportGen/make_card
-share/polygraph/ReportGen/make_report
-share/polygraph/ReportGen/plot_table
-share/polygraph/ReportGen/plot_traces
-share/polygraph/ReportGen/reportgen.cfg
-share/polygraph/workloads/datacomm-1.pg
-share/polygraph/workloads/downtime-2.pg
-share/polygraph/workloads/include/benches.pg
-share/polygraph/workloads/include/contents.pg
-share/polygraph/workloads/include/phases.pg
-share/polygraph/workloads/include/pipes.pg
-share/polygraph/workloads/include/polymix-3-guts.pg
-share/polygraph/workloads/include/polymix-4-guts.pg
-share/polygraph/workloads/include/webaxe-4-guts.pg
-share/polygraph/workloads/nolb-l4-4.pg
-share/polygraph/workloads/polyfill-2.pg
-share/polygraph/workloads/polymix-1.pg
-share/polygraph/workloads/polymix-2.pg
-share/polygraph/workloads/polymix-3.pg
-share/polygraph/workloads/polymix-4.pg
-share/polygraph/workloads/pxylb-4.pg
-share/polygraph/workloads/simple.pg
-share/polygraph/workloads/srvlb-l4-4.pg
-share/polygraph/workloads/srvlb-l7-4.pg
-share/polygraph/workloads/test_csm.pg
-share/polygraph/workloads/test_polypxy.pg
-share/polygraph/workloads/webaxe-1.pg
-share/polygraph/workloads/webaxe-3.pg
-share/polygraph/workloads/webaxe-4.pg
-@dirrm share/polygraph/workloads/include
-@dirrm share/polygraph/workloads
-@dirrm share/polygraph/ReportGen
-@dirrm share/polygraph
+%%DATADIR%%/workloads/datacomm-1.pg
+%%DATADIR%%/workloads/downtime-2.pg
+%%DATADIR%%/workloads/include/benches.pg
+%%DATADIR%%/workloads/include/contents.pg
+%%DATADIR%%/workloads/include/phases.pg
+%%DATADIR%%/workloads/include/pipes.pg
+%%DATADIR%%/workloads/include/polymix-3-guts.pg
+%%DATADIR%%/workloads/include/polymix-4-guts.pg
+%%DATADIR%%/workloads/include/webaxe-4-guts.pg
+%%DATADIR%%/workloads/nolb-l4-4.pg
+%%DATADIR%%/workloads/polyfill-2.pg
+%%DATADIR%%/workloads/polymix-1.pg
+%%DATADIR%%/workloads/polymix-2.pg
+%%DATADIR%%/workloads/polymix-3.pg
+%%DATADIR%%/workloads/polymix-4.pg
+%%DATADIR%%/workloads/pxylb-4.pg
+%%DATADIR%%/workloads/simple.pg
+%%DATADIR%%/workloads/srvlb-l4-4.pg
+%%DATADIR%%/workloads/srvlb-l7-4.pg
+%%DATADIR%%/workloads/test_csm.pg
+%%DATADIR%%/workloads/test_polypxy.pg
+%%DATADIR%%/workloads/webaxe-1.pg
+%%DATADIR%%/workloads/webaxe-3.pg
+%%DATADIR%%/workloads/webaxe-4.pg
+@dirrm %%DATADIR%%/workloads/include
+@dirrm %%DATADIR%%/workloads
+@dirrm %%DATADIR%%
diff --git a/benchmarks/polygraph31/Makefile b/benchmarks/polygraph31/Makefile
index 36a0b2db86d8..881458b5ca5c 100644
--- a/benchmarks/polygraph31/Makefile
+++ b/benchmarks/polygraph31/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= polygraph
-PORTVERSION= 2.7.6
+PORTVERSION= 2.8.0
CATEGORIES= benchmarks www
MASTER_SITES= http://www.web-polygraph.org/downloads/srcs/
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
@@ -15,14 +15,10 @@ EXTRACT_SUFX= .tgz
MAINTAINER= adrian@FreeBSD.org
COMMENT= A benchmarking tool for Web proxies
-
IS_INTERACTIVE= yes
GNU_CONFIGURE= YES
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -Wno-deprecated"
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-.include <bsd.port.pre.mk>
-
-BROKEN= "Does not compile"
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/benchmarks/polygraph31/distinfo b/benchmarks/polygraph31/distinfo
index 27c58908daf8..dddc4b79c985 100644
--- a/benchmarks/polygraph31/distinfo
+++ b/benchmarks/polygraph31/distinfo
@@ -1 +1,2 @@
-MD5 (polygraph-2.7.6-src.tgz) = e23cbb26939217d3ad295bce64a2096d
+MD5 (polygraph-2.8.0-src.tgz) = e006ecd99637aa78c47d6b9b13774eaa
+SIZE (polygraph-2.8.0-src.tgz) = 710102
diff --git a/benchmarks/polygraph31/files/patch-src::loganalyzers::SideInfo.cc b/benchmarks/polygraph31/files/patch-src::loganalyzers::SideInfo.cc
new file mode 100644
index 000000000000..5b5f5adf8f4d
--- /dev/null
+++ b/benchmarks/polygraph31/files/patch-src::loganalyzers::SideInfo.cc
@@ -0,0 +1,15 @@
+--- src/loganalyzers/SideInfo.cc.orig Thu Feb 26 16:55:36 2004
++++ src/loganalyzers/SideInfo.cc Thu Feb 26 16:56:05 2004
+@@ -1166,9 +1166,9 @@
+ XmlTag descr("description");
+
+ XmlTextTag<XmlParagraph> p1;
+- p1.buf() << "The 'Errors' table shows detected errors. For each
+- error type, the number of errors and their contribution towards
+- total error count are shown.";
++ p1.buf() << "The 'Errors' table shows detected errors. For each "
++ "error type, the number of errors and their contribution towards "
++ "total error count are shown.";
+ descr << p1;
+
+ blob << descr;
diff --git a/benchmarks/polygraph31/files/patch-src::xparser::SynSym.h b/benchmarks/polygraph31/files/patch-src::xparser::SynSym.h
new file mode 100644
index 000000000000..f13ebb464464
--- /dev/null
+++ b/benchmarks/polygraph31/files/patch-src::xparser::SynSym.h
@@ -0,0 +1,13 @@
+--- src/xparser/SynSym.h.orig Thu Feb 26 18:21:19 2004
++++ src/xparser/SynSym.h Thu Feb 26 18:21:49 2004
+@@ -54,8 +54,8 @@
+ String theType;
+ };
+
+-#define SymCast(Type, var) ((Type&)((var).cast(Type##::TheType)))
+-#define ConstSymCast(Type, var) ((const Type&)((var).cast(Type##::TheType)))
++#define SymCast(Type, var) ((Type&)((var).cast(Type::TheType)))
++#define ConstSymCast(Type, var) ((const Type&)((var).cast(Type::TheType)))
+
+ inline ostream &operator <<(ostream &os, const SynSym &sym) { return sym.print(os); }
+
diff --git a/benchmarks/polygraph31/pkg-plist b/benchmarks/polygraph31/pkg-plist
index 4222a98d2d24..fe305ecb7c2c 100644
--- a/benchmarks/polygraph31/pkg-plist
+++ b/benchmarks/polygraph31/pkg-plist
@@ -5,7 +5,9 @@ bin/dns_cfg
bin/lr
bin/ltrace
bin/lx
+bin/pgl2acl
bin/pgl2eng
+bin/pgl2ldif
bin/pgl_test
bin/polyclt
bin/polymon
@@ -14,46 +16,34 @@ bin/polypxy
bin/polyrrd
bin/polysrv
bin/pop_test
+bin/reporter
bin/rng_test
+bin/tcp2xmld
bin/udp2tcpd
-share/polygraph/ReportGen/Globs.pm
-share/polygraph/ReportGen/Line.pm
-share/polygraph/ReportGen/ObjDbase.pm
-share/polygraph/ReportGen/ObjManip.pm
-share/polygraph/ReportGen/Opts.pm
-share/polygraph/ReportGen/Plot.pm
-share/polygraph/ReportGen/RepFormat.pm
-share/polygraph/ReportGen/label_results
-share/polygraph/ReportGen/make_card
-share/polygraph/ReportGen/make_report
-share/polygraph/ReportGen/plot_table
-share/polygraph/ReportGen/plot_traces
-share/polygraph/ReportGen/reportgen.cfg
-share/polygraph/workloads/datacomm-1.pg
-share/polygraph/workloads/downtime-2.pg
-share/polygraph/workloads/include/benches.pg
-share/polygraph/workloads/include/contents.pg
-share/polygraph/workloads/include/phases.pg
-share/polygraph/workloads/include/pipes.pg
-share/polygraph/workloads/include/polymix-3-guts.pg
-share/polygraph/workloads/include/polymix-4-guts.pg
-share/polygraph/workloads/include/webaxe-4-guts.pg
-share/polygraph/workloads/nolb-l4-4.pg
-share/polygraph/workloads/polyfill-2.pg
-share/polygraph/workloads/polymix-1.pg
-share/polygraph/workloads/polymix-2.pg
-share/polygraph/workloads/polymix-3.pg
-share/polygraph/workloads/polymix-4.pg
-share/polygraph/workloads/pxylb-4.pg
-share/polygraph/workloads/simple.pg
-share/polygraph/workloads/srvlb-l4-4.pg
-share/polygraph/workloads/srvlb-l7-4.pg
-share/polygraph/workloads/test_csm.pg
-share/polygraph/workloads/test_polypxy.pg
-share/polygraph/workloads/webaxe-1.pg
-share/polygraph/workloads/webaxe-3.pg
-share/polygraph/workloads/webaxe-4.pg
-@dirrm share/polygraph/workloads/include
-@dirrm share/polygraph/workloads
-@dirrm share/polygraph/ReportGen
-@dirrm share/polygraph
+%%DATADIR%%/workloads/datacomm-1.pg
+%%DATADIR%%/workloads/downtime-2.pg
+%%DATADIR%%/workloads/include/benches.pg
+%%DATADIR%%/workloads/include/contents.pg
+%%DATADIR%%/workloads/include/phases.pg
+%%DATADIR%%/workloads/include/pipes.pg
+%%DATADIR%%/workloads/include/polymix-3-guts.pg
+%%DATADIR%%/workloads/include/polymix-4-guts.pg
+%%DATADIR%%/workloads/include/webaxe-4-guts.pg
+%%DATADIR%%/workloads/nolb-l4-4.pg
+%%DATADIR%%/workloads/polyfill-2.pg
+%%DATADIR%%/workloads/polymix-1.pg
+%%DATADIR%%/workloads/polymix-2.pg
+%%DATADIR%%/workloads/polymix-3.pg
+%%DATADIR%%/workloads/polymix-4.pg
+%%DATADIR%%/workloads/pxylb-4.pg
+%%DATADIR%%/workloads/simple.pg
+%%DATADIR%%/workloads/srvlb-l4-4.pg
+%%DATADIR%%/workloads/srvlb-l7-4.pg
+%%DATADIR%%/workloads/test_csm.pg
+%%DATADIR%%/workloads/test_polypxy.pg
+%%DATADIR%%/workloads/webaxe-1.pg
+%%DATADIR%%/workloads/webaxe-3.pg
+%%DATADIR%%/workloads/webaxe-4.pg
+@dirrm %%DATADIR%%/workloads/include
+@dirrm %%DATADIR%%/workloads
+@dirrm %%DATADIR%%