aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2022-01-10 14:20:12 +0000
committerStefan Eßer <se@FreeBSD.org>2022-01-10 15:15:39 +0000
commitbcaf25a8c8046b094f6b5ab5bc258333bc326ee1 (patch)
tree3930596b8cbea97540270b3d78ffb64373c89593 /benchmarks
parentf1661bdbbac2d08cc535e38e41d2bbd3fec025c4 (diff)
downloadports-bcaf25a8c8046b094f6b5ab5bc258333bc326ee1.tar.gz
ports-bcaf25a8c8046b094f6b5ab5bc258333bc326ee1.zip
Fix CONFLICTS entries of multiple ports
There have been lots of missing CONFLICTS_INSTALL entries, either because conflicting ports were added without updating existing ports, due to name changes of generated packages, due to mis-understanding the format and semantics of the conflicts entries, or just due to typoes in package names. This patch is the result of a comparison of all files contained in the official packages with each other. This comparison was based on packages built with default options and may therefore have missed further conflicts with optionally installed files. Where possible, version numbers in conflicts entries have been generalized, some times taking advantage of the fact that a port cannot conflict with itself (due to logic in bsd.port.mk that supresses the pattern match result in that case). A few ports that set the conflicts variables depending on complex conditions (e.g. port options), have been left unmodified, despite probably containing outdated package names. These changes should only affect the installation of locally built ports, not the package building with poudriere. They should give an early indication of the install conflict in cases where currently the pkg command aborts an installation when it detects that an existing file would be overwritten, Approved by: portmgr (implicit)
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/ali/Makefile2
-rw-r--r--benchmarks/fio/Makefile2
-rw-r--r--benchmarks/flamegraph/Makefile2
-rw-r--r--benchmarks/iozone/Makefile2
-rw-r--r--benchmarks/iozone21/Makefile2
-rw-r--r--benchmarks/rubygem-derailed_benchmarks/Makefile2
-rw-r--r--benchmarks/rubygem-gitlab-derailed_benchmarks/Makefile2
7 files changed, 13 insertions, 1 deletions
diff --git a/benchmarks/ali/Makefile b/benchmarks/ali/Makefile
index 7cc3209bdcbb..e165c7bc41dc 100644
--- a/benchmarks/ali/Makefile
+++ b/benchmarks/ali/Makefile
@@ -38,6 +38,8 @@ GH_TUPLE= davecgh:go-spew:v1.1.1:davecgh_go_spew/vendor/github.com/davecgh/go-sp
uber-go:atomic:v1.9.0:uber_go_atomic/vendor/go.uber.org/atomic \
uber-go:goleak:v1.1.12:uber_go_goleak/vendor/go.uber.org/goleak
+CONFLICTS_INSTALL= ja-mh mmh nmh
+
PLIST_FILES= bin/ali
.include <bsd.port.mk>
diff --git a/benchmarks/fio/Makefile b/benchmarks/fio/Makefile
index 06c393177ec6..9bc3086c054b 100644
--- a/benchmarks/fio/Makefile
+++ b/benchmarks/fio/Makefile
@@ -21,6 +21,8 @@ GNUPLOT_DESC= Support for plotting graphs
GNUPLOT_BUILD_DEPENDS= ${LOCALBASE}/bin/gnuplot:math/gnuplot
+CONFLICTS_INSTALL= py*-Fiona
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/fio ${STAGEDIR}${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/tools/fio_generate_plots ${STAGEDIR}${PREFIX}/bin
diff --git a/benchmarks/flamegraph/Makefile b/benchmarks/flamegraph/Makefile
index a8fda4958834..e781fcb0fd42 100644
--- a/benchmarks/flamegraph/Makefile
+++ b/benchmarks/flamegraph/Makefile
@@ -22,6 +22,8 @@ GH_TAGNAME= 810687f
NO_BUILD= yes
+CONFLICTS_INSTALL= p5-Devel-NYTProf
+
SHEBANG_FILES= *.php *.pl *.py *.sh
SOURCE_FILES= aix-perf.pl \
diff --git a/benchmarks/iozone/Makefile b/benchmarks/iozone/Makefile
index 22fe1205bc97..80ed9ef93023 100644
--- a/benchmarks/iozone/Makefile
+++ b/benchmarks/iozone/Makefile
@@ -19,6 +19,8 @@ MAKE_ARGS= ${MAKE_ENV}
ALL_TARGET= freebsd
MAKE_JOBS_UNSAFE= yes
+CONFLICTS_INSTALL= iozone21
+
PLIST_FILES= bin/iozone man/man1/iozone.1.gz
OPTIONS_DEFINE= SSH THREADS
diff --git a/benchmarks/iozone21/Makefile b/benchmarks/iozone21/Makefile
index 8bad1fd58ff0..bca0d4306882 100644
--- a/benchmarks/iozone21/Makefile
+++ b/benchmarks/iozone21/Makefile
@@ -10,7 +10,7 @@ PKGNAMESUFFIX= 21
MAINTAINER= ports@FreeBSD.org
COMMENT= Performance Test of Sequential File I/O (older version)
-CONFLICTS= iozone-3.*
+CONFLICTS_INSTALL= iozone
PLIST_FILES= bin/iozone \
man/man1/iozone.1.gz
diff --git a/benchmarks/rubygem-derailed_benchmarks/Makefile b/benchmarks/rubygem-derailed_benchmarks/Makefile
index f5ac7074ee91..929dd557c780 100644
--- a/benchmarks/rubygem-derailed_benchmarks/Makefile
+++ b/benchmarks/rubygem-derailed_benchmarks/Makefile
@@ -24,6 +24,8 @@ RUN_DEPENDS= rubygem-benchmark-ips>=2.0.0:benchmarks/rubygem-benchmark-ips \
USES= gem
USE_RUBY= yes
+CONFLICTS_INSTALL= rubygem-gitlab-derailed_benchmarks
+
NO_ARCH= yes
PLIST_FILES= bin/derailed
diff --git a/benchmarks/rubygem-gitlab-derailed_benchmarks/Makefile b/benchmarks/rubygem-gitlab-derailed_benchmarks/Makefile
index 10400cca98d2..f26f0d0f643a 100644
--- a/benchmarks/rubygem-gitlab-derailed_benchmarks/Makefile
+++ b/benchmarks/rubygem-gitlab-derailed_benchmarks/Makefile
@@ -22,6 +22,8 @@ RUN_DEPENDS= rubygem-benchmark-ips>=2.0.0:benchmarks/rubygem-benchmark-ips \
USES= gem
USE_RUBY= yes
+CONFLICTS_INSTALL= rubygem-derailed_benchmarks
+
NO_ARCH= yes
PLIST_FILES= bin/derailed