aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorPhilippe Audeoud <jadawin@FreeBSD.org>2008-05-08 07:14:19 +0000
committerPhilippe Audeoud <jadawin@FreeBSD.org>2008-05-08 07:14:19 +0000
commitc071c00e675234c9faaf2846666ef4dd3b1ad673 (patch)
treeabb3585f53dfb83b8f7d0a358db8bac05a654dbe /benchmarks
parent591e7166d9fad5c79eb224247f6d0de469de813e (diff)
downloadports-c071c00e675234c9faaf2846666ef4dd3b1ad673.tar.gz
ports-c071c00e675234c9faaf2846666ef4dd3b1ad673.zip
- Update to 3.1
PR: ports/123470 Submitted by: Artem Naluzhnyy <tut@nhamon.com.ua> Approved by: tabthorpe (mentor)
Notes
Notes: svn path=/head/; revision=212811
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/sipp/Makefile8
-rw-r--r--benchmarks/sipp/distinfo6
-rw-r--r--benchmarks/sipp/files/patch-Makefile34
-rw-r--r--benchmarks/sipp/files/patch-sipp.cpp11
-rw-r--r--benchmarks/sipp/files/patch-sipp.hpp11
5 files changed, 26 insertions, 44 deletions
diff --git a/benchmarks/sipp/Makefile b/benchmarks/sipp/Makefile
index 0ddcf896169e..1ee5301e3551 100644
--- a/benchmarks/sipp/Makefile
+++ b/benchmarks/sipp/Makefile
@@ -6,18 +6,20 @@
#
PORTNAME= sipp
-PORTVERSION= 3.0
-PORTREVISION= 1
+PORTVERSION= 3.1
CATEGORIES= benchmarks net
MASTER_SITES= SF
-DISTNAME= ${PORTNAME}-3.0.src
+DISTNAME= ${PORTNAME}.${PORTVERSION}.src
MAINTAINER= tut@nhamon.com.ua
COMMENT= SIP testing tool
+WRKSRC= ${WRKDIR}/${PORTNAME}.svn
+
PLIST_FILES= bin/sipp
MAN1= sipp.1
+USE_GMAKE= yes
MAKE_ENV+= CPP="${CXX}" \
CPPFLAGS="${CXXFLAGS}" \
CCLINK="${CXX}"
diff --git a/benchmarks/sipp/distinfo b/benchmarks/sipp/distinfo
index ce9ef4358b86..7d5ab9ceba8c 100644
--- a/benchmarks/sipp/distinfo
+++ b/benchmarks/sipp/distinfo
@@ -1,3 +1,3 @@
-MD5 (sipp-3.0.src.tar.gz) = 31906c63eb5efa09e0b148c27435cdac
-SHA256 (sipp-3.0.src.tar.gz) = bb7622e64e0cf971a2b1931b0a0f6d93a4e25ad95dad0bbd64f077d2c35f07dd
-SIZE (sipp-3.0.src.tar.gz) = 195692
+MD5 (sipp.3.1.src.tar.gz) = 452a6f88f2d314dbb2f44e318a60982b
+SHA256 (sipp.3.1.src.tar.gz) = 123391c7c5545fc61594cd62334986540604f5a3a3d405faef5e02dab5200399
+SIZE (sipp.3.1.src.tar.gz) = 9428792
diff --git a/benchmarks/sipp/files/patch-Makefile b/benchmarks/sipp/files/patch-Makefile
index 0c31815c876c..1eb0712eaf44 100644
--- a/benchmarks/sipp/files/patch-Makefile
+++ b/benchmarks/sipp/files/patch-Makefile
@@ -1,15 +1,17 @@
---- Makefile.orig 2007-09-06 11:51:24.000000000 +0300
-+++ Makefile 2007-09-08 19:16:08.000000000 +0300
-@@ -18,8 +18,6 @@
+--- Makefile.orig 2008-04-11 15:26:37.000000000 +0300
++++ Makefile 2008-05-06 20:11:59.000000000 +0300
+@@ -18,10 +18,6 @@
# From Hewlett Packard Company.
#
--include local.mk
+-SVN_VERSION=$(shell if test -d .svn ; then svnversion . | sed -e 's/^/svn/;' ; else echo unknown ; fi)
+-VERINFO=-DSVN_VERSION="\"$(SVN_VERSION)\""
-
# Output binary to be built
OUTPUT=sipp
-@@ -69,7 +67,7 @@
+@@ -71,7 +67,7 @@
CC_SunOS=gcc
CC_Cygwin=cc
CC_Darwin=cc
@@ -18,7 +20,7 @@
# C++ compiler mapping
CPP_hpux=aCC
-@@ -79,7 +77,7 @@
+@@ -81,7 +77,7 @@
CPP_SunOS=g++
CPP_Cygwin=g++
CPP_Darwin=g++
@@ -27,25 +29,25 @@
#Model specific flags
MFLAGS_ia64=+DD64
-@@ -102,7 +100,7 @@
- CFLAGS_SunOS=-g -D__SUNOS
+@@ -104,7 +100,7 @@
+ CFLAGS_SunOS=${DEBUG_FLAGS} -D__SUNOS
CFLAGS_Cygwin=-D__CYGWIN -Dsocklen_t=int
CFLAGS_Darwin=-D__DARWIN
--CFLAGS=$(CFLAGS_$(SYSTEM)) -D__3PCC__ $(TLS) $(PCAPPLAY) $(EXTRACFLAGS)
-+CFLAGS+=$(CFLAGS_$(SYSTEM)) -D__3PCC__ $(TLS) $(PCAPPLAY) $(EXTRACFLAGS)
+-CFLAGS=$(CFLAGS_$(SYSTEM)) $(VERINFO) $(TLS) $(PCAPPLAY) $(EXTRACFLAGS)
++CFLAGS+=$(CFLAGS_$(SYSTEM)) $(VERINFO) $(TLS) $(PCAPPLAY) $(EXTRACFLAGS)
#C++ Compiler Flags
- CPPFLAGS_hpux=-AA -mt -D__HPUX +W829
-@@ -112,7 +110,7 @@
- CPPFLAGS_SunOS=-g -D__SUNOS
+ CPPFLAGS_hpux=-AA -mt -D__HPUX -D_INCLUDE_LONGLONG -DNOMACROS +W829
+@@ -114,7 +110,7 @@
+ CPPFLAGS_SunOS=${DEBUG_FLAGS} -D__SUNOS
CPPFLAGS_Cygwin=-D__CYGWIN -Dsocklen_t=int
CPPFLAGS_Darwin=-D__DARWIN
--CPPFLAGS=$(CPPFLAGS_$(SYSTEM)) -D__3PCC__ $(TLS) $(PCAPPLAY) $(EXTRACPPFLAGS)
-+CPPFLAGS+=$(CPPFLAGS_$(SYSTEM)) -D__3PCC__ $(TLS) $(PCAPPLAY) $(EXTRACPPFLAGS)
+-CPPFLAGS=$(CPPFLAGS_$(SYSTEM)) $(VERINFO) $(TLS) $(PCAPPLAY) $(EXTRACPPFLAGS)
++CPPFLAGS+=$(CPPFLAGS_$(SYSTEM)) $(VERINFO) $(TLS) $(PCAPPLAY) $(EXTRACPPFLAGS)
#Linker mapping
CCLINK_hpux=aCC
-@@ -122,7 +120,7 @@
+@@ -124,7 +120,7 @@
CCLINK_SunOS=gcc
CCLINK_Cygwin=g++
CCLINK_Darwin=g++
@@ -54,7 +56,7 @@
#Linker Flags
LFLAGS_hpux=-AA -mt
-@@ -154,8 +152,6 @@
+@@ -156,8 +152,6 @@
INCDIR_Darwin=-I. -I/usr/local/ssl/include
INCDIR=$(INCDIR_$(SYSTEM))
diff --git a/benchmarks/sipp/files/patch-sipp.cpp b/benchmarks/sipp/files/patch-sipp.cpp
deleted file mode 100644
index 4a24269617b3..000000000000
--- a/benchmarks/sipp/files/patch-sipp.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- sipp.cpp.orig 2007-11-28 17:09:53.000000000 +0200
-+++ sipp.cpp 2008-01-15 22:57:14.000000000 +0200
-@@ -3627,7 +3627,7 @@
- }
- exit(EXIT_OTHER);
- case SIPP_OPTION_VERSION:
-- printf("\n SIPp v2.0"
-+ printf("\n SIPp v3.0"
- #ifdef _USE_OPENSSL
- "-TLS"
- #endif
diff --git a/benchmarks/sipp/files/patch-sipp.hpp b/benchmarks/sipp/files/patch-sipp.hpp
deleted file mode 100644
index 5dd12f64c2a5..000000000000
--- a/benchmarks/sipp/files/patch-sipp.hpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- sipp.hpp.orig 2007-11-28 12:33:23.000000000 +0200
-+++ sipp.hpp 2008-01-15 22:57:46.000000000 +0200
-@@ -93,7 +93,7 @@
-
- /************************** Constants **************************/
-
--#define SIPP_VERSION 20071128
-+#define SIPP_VERSION 20071204
- #define T_UDP 0
- #define T_TCP 1
- #define T_TLS 2