aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-11-23 11:56:19 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-11-23 11:56:19 +0000
commitfb483d9c58812cdf24dc4be8ecca67c19398af56 (patch)
treed09f290823e2137318f782464b0b31ae8a24ffc4 /benchmarks
parent11fb80b76fb3ac7f48ccd000111d5a4cac55d361 (diff)
downloadports-fb483d9c58812cdf24dc4be8ecca67c19398af56.tar.gz
ports-fb483d9c58812cdf24dc4be8ecca67c19398af56.zip
This integer benchmark solves positions in the game of connect-4,
as played on a vertical 7x6 board. This takes about 10 minutes on contemporary PCs. WWW: http://homepages.cwi.nl/~tromp/c4/fhour.html PR: ports/105778 Submitted by: trasz <trasz at pin.if.uz.zgora.pl>
Notes
Notes: svn path=/head/; revision=177882
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/Makefile1
-rw-r--r--benchmarks/fhourstones/Makefile31
-rw-r--r--benchmarks/fhourstones/distinfo3
-rw-r--r--benchmarks/fhourstones/files/patch-Makefile8
-rw-r--r--benchmarks/fhourstones/files/patch-fhourstones7
-rw-r--r--benchmarks/fhourstones/pkg-descr5
6 files changed, 55 insertions, 0 deletions
diff --git a/benchmarks/Makefile b/benchmarks/Makefile
index 47e4e3611833..07c01ad617b0 100644
--- a/benchmarks/Makefile
+++ b/benchmarks/Makefile
@@ -10,6 +10,7 @@
SUBDIR += dbench
SUBDIR += dbs
SUBDIR += dkftpbench
+ SUBDIR += fhourstones
SUBDIR += flops
SUBDIR += forkbomb
SUBDIR += gtkperf
diff --git a/benchmarks/fhourstones/Makefile b/benchmarks/fhourstones/Makefile
new file mode 100644
index 000000000000..ddb713d14d79
--- /dev/null
+++ b/benchmarks/fhourstones/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: fhourstones
+# Date created: 2006-11-23
+# Whom: trasz <trasz@pin.if.uz.zgora.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fhourstones
+PORTVERSION= 3.1
+CATEGORIES= benchmarks
+MASTER_SITES= http://homepages.cwi.nl/~tromp/c4/
+DISTNAME= Fhourstones
+
+MAINTAINER= trasz@pin.if.uz.zgora.pl
+COMMENT= The Fhourstones Benchmark
+
+NO_WRKSUBDIR= yes
+PLIST_FILES= bin/fhourstones lib/fhourstones/SearchGame lib/fhourstones/inputs
+PLIST_DIRS= lib/fhourstones
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/fhourstones
+
+do-install:
+ ${MKDIR} ${PREFIX}/lib/fhourstones
+ ${INSTALL_SCRIPT} ${WRKDIR}/fhourstones ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKDIR}/SearchGame ${PREFIX}/lib/fhourstones/
+ ${INSTALL_DATA} ${WRKDIR}/inputs ${PREFIX}/lib/fhourstones
+
+.include <bsd.port.mk>
diff --git a/benchmarks/fhourstones/distinfo b/benchmarks/fhourstones/distinfo
new file mode 100644
index 000000000000..14b50ae2d15d
--- /dev/null
+++ b/benchmarks/fhourstones/distinfo
@@ -0,0 +1,3 @@
+MD5 (Fhourstones.tar.gz) = 4137746ea1520aa6041ed1cd9b1a0d26
+SHA256 (Fhourstones.tar.gz) = a7b3562562b5522900480aaa29d70e1b70239ef028a0d5222a41c7222e3f5a6c
+SIZE (Fhourstones.tar.gz) = 10387
diff --git a/benchmarks/fhourstones/files/patch-Makefile b/benchmarks/fhourstones/files/patch-Makefile
new file mode 100644
index 000000000000..cc579396ec34
--- /dev/null
+++ b/benchmarks/fhourstones/files/patch-Makefile
@@ -0,0 +1,8 @@
+--- /dev/null Thu Nov 23 08:54:18 2006
++++ Makefile Thu Nov 23 08:54:28 2006
+@@ -0,0 +1,5 @@
++all: SearchGame
++
++SearchGame: Game.c SearchGame.c TransGame.c
++ $(CC) -o $@ $(CFLAGS) SearchGame.c
++
diff --git a/benchmarks/fhourstones/files/patch-fhourstones b/benchmarks/fhourstones/files/patch-fhourstones
new file mode 100644
index 000000000000..b55ccf45180a
--- /dev/null
+++ b/benchmarks/fhourstones/files/patch-fhourstones
@@ -0,0 +1,7 @@
+--- /dev/null Thu Nov 23 08:52:26 2006
++++ fhourstones Thu Nov 23 08:45:21 2006
+@@ -0,0 +1,4 @@
++#!/bin/sh
++
++exec %%PREFIX%%/lib/fhourstones/SearchGame < %%PREFIX%%/lib/fhourstones/inputs
++
diff --git a/benchmarks/fhourstones/pkg-descr b/benchmarks/fhourstones/pkg-descr
new file mode 100644
index 000000000000..2850b473f8c1
--- /dev/null
+++ b/benchmarks/fhourstones/pkg-descr
@@ -0,0 +1,5 @@
+This integer benchmark solves positions in the game of connect-4,
+as played on a vertical 7x6 board. This takes about 10 minutes
+on contemporary PCs.
+
+WWW: http://homepages.cwi.nl/~tromp/c4/fhour.html