aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2007-01-17 08:45:40 +0000
committerMaho Nakata <maho@FreeBSD.org>2007-01-17 08:45:40 +0000
commitfd1bfc37add16b16a26a55165383f83ac59948d6 (patch)
tree09397318b887adc4598d0466007a73232eb54792 /benchmarks
parent12f36d180991cd15ced531841c1cf5b7eec76936 (diff)
downloadports-fd1bfc37add16b16a26a55165383f83ac59948d6.tar.gz
ports-fd1bfc37add16b16a26a55165383f83ac59948d6.zip
* Migrate to gfortran.
* Bump port revision. * Use gfortran compiled atlas/blas/lapack. Approved by: portmgr(kris)
Notes
Notes: svn path=/head/; revision=182616
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/hpl/Makefile21
1 files changed, 17 insertions, 4 deletions
diff --git a/benchmarks/hpl/Makefile b/benchmarks/hpl/Makefile
index acad5055b9e9..59a2cdac25af 100644
--- a/benchmarks/hpl/Makefile
+++ b/benchmarks/hpl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= hpl
PORTVERSION= 1.0a
+PORTREVISION= 1
CATEGORIES= benchmarks
MASTER_SITES= http://www.netlib.org/benchmark/hpl/ \
ftp://ftp.hipecs.hokudai.ac.jp/netlib/benchmark/hpl/
@@ -25,11 +26,23 @@ FC= ${LOCALBASE}/bin/mpicc
.endif
RUN_DEPENDS= ${BUILD_DEPENDS}
+WANT_FORTRAN= yes #dummy but future use
+BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
+FC= gfortran42
+F77= gfortran42
+MAKE_ENV+= FC="${FC}" F77="${F77}" FFLAGS="${FFLAGS}"
-.if defined(WITH_BLAS)
-LIB_DEPENDS+= blas.1:${PORTSDIR}/math/blas
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/lib/libatlas.a) && !defined(WITH_BLAS)
+WITH_ATLAS= yes
+.else
+WITH_BLAS= yes
+.endif
+.if defined(WITH_ATLAS)
+LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
.else
-LIB_DEPENDS+= cblas.1:${PORTSDIR}/math/atlas
+LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
.endif
INSTALLS_SHLIB= yes
@@ -112,4 +125,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>