aboutsummaryrefslogtreecommitdiff
path: root/biology/avida
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-04-20 15:17:46 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-04-20 15:17:46 +0000
commit9e3da593d2b8eb711044789d0248d901ce4777a0 (patch)
treec87a1b9cb53bd13391f4e0f80f265b332cf6b17c /biology/avida
parent38eea96cd4c6b5c14b4f4ebd344dde917c002aaf (diff)
downloadports-9e3da593d2b8eb711044789d0248d901ce4777a0.tar.gz
ports-9e3da593d2b8eb711044789d0248d901ce4777a0.zip
add avida 1.6.0
Avida is an auto-adaptive genetic system designed for ALife research PR: 37268 Submitted by: Jeremy Karlson <karlj000@unbc.ca>
Notes
Notes: svn path=/head/; revision=57919
Diffstat (limited to 'biology/avida')
-rw-r--r--biology/avida/Makefile39
-rw-r--r--biology/avida/distinfo1
-rw-r--r--biology/avida/files/patch-aa10
-rw-r--r--biology/avida/files/patch-ab10
-rw-r--r--biology/avida/files/patch-ac11
-rw-r--r--biology/avida/files/patch-ad11
-rw-r--r--biology/avida/files/patch-ae11
-rw-r--r--biology/avida/pkg-comment1
-rw-r--r--biology/avida/pkg-descr16
-rw-r--r--biology/avida/pkg-plist35
10 files changed, 145 insertions, 0 deletions
diff --git a/biology/avida/Makefile b/biology/avida/Makefile
new file mode 100644
index 000000000000..d02462e1fd4f
--- /dev/null
+++ b/biology/avida/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: avida
+# Date created: 17 April 2002
+# Whom: Jeremy <karlj000@unbc.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= avida
+PORTVERSION= 1.6.0
+CATEGORIES= biology
+MASTER_SITES= http://dllab.caltech.edu/avida/versions/
+
+MAINTAINER= karlj000@unbc.ca
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/\.[[:alnum:]]+$//}
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-viewer --enable-standard-prefix --prefix=${PREFIX} --datadir=${PREFIX}/share/${PORTNAME}
+
+post-patch:
+ # Change source/defs.hh prefix and port name.
+ @ ${MV} ${WRKSRC}/source/defs.hh ${WRKSRC}/source/defs.hh.presed
+ @ ${SED} -e 's#%%PREFIX%%#${PREFIX}#g' ${WRKSRC}/source/defs.hh.presed \
+ | ${SED} -e 's#%%PORTNAME%%#${PORTNAME}#g' \
+ > ${WRKSRC}/source/defs.hh
+
+ # Change source/support/genesis prefix and port name.
+ @ ${MV} ${WRKSRC}/source/support/genesis ${WRKSRC}/source/support/genesis.presed
+ @ ${SED} -e 's#%%PREFIX%%#${PREFIX}#g' ${WRKSRC}/source/support/genesis.presed \
+ | ${SED} -e 's#%%PORTNAME%%#${PORTNAME}#g' \
+ > ${WRKSRC}/source/support/genesis
+
+ # Change source/support/genesis.heads prefix and port name.
+ @ ${MV} ${WRKSRC}/source/support/genesis.heads ${WRKSRC}/source/support/genesis.heads.presed
+ @ ${SED} -e 's#%%PREFIX%%#${PREFIX}#g' ${WRKSRC}/source/support/genesis.heads.presed \
+ | ${SED} -e 's#%%PORTNAME%%#${PORTNAME}#g' \
+ > ${WRKSRC}/source/support/genesis.heads
+
+.include <bsd.port.mk>
diff --git a/biology/avida/distinfo b/biology/avida/distinfo
new file mode 100644
index 000000000000..d0e179ea3e42
--- /dev/null
+++ b/biology/avida/distinfo
@@ -0,0 +1 @@
+MD5 (avida-1.6.0.tar.gz) = 2294af061f200c486de2ed889e0e17af
diff --git a/biology/avida/files/patch-aa b/biology/avida/files/patch-aa
new file mode 100644
index 000000000000..554cac9efe93
--- /dev/null
+++ b/biology/avida/files/patch-aa
@@ -0,0 +1,10 @@
+--- source/event/event_base.hh.orig Wed Apr 17 21:26:31 2002
++++ source/event/event_base.hh Wed Apr 17 21:26:41 2002
+@@ -18,6 +18,7 @@
+
+ #include "../defs.hh"
+ #include <values.h>
++#include <float.h>
+ //#include "event_defs.hh"
+
+ enum eTriggerVariable { UPDATE, GENERATION, IMMEDIATE, UNDEFINED };
diff --git a/biology/avida/files/patch-ab b/biology/avida/files/patch-ab
new file mode 100644
index 000000000000..453635356a94
--- /dev/null
+++ b/biology/avida/files/patch-ab
@@ -0,0 +1,10 @@
+--- source/main/fitness_matrix.hh.orig Thu Apr 18 08:54:04 2002
++++ source/main/fitness_matrix.hh Thu Apr 18 08:54:15 2002
+@@ -7,6 +7,7 @@
+ #include <vector>
+ #include <map>
+ #include <list>
++#include <sys/types.h>
+ #include <sys/timeb.h>
+
+ #include "../cpu/cpu.hh"
diff --git a/biology/avida/files/patch-ac b/biology/avida/files/patch-ac
new file mode 100644
index 000000000000..980deaebc657
--- /dev/null
+++ b/biology/avida/files/patch-ac
@@ -0,0 +1,11 @@
+--- source/defs.hh.orig Thu Apr 18 18:42:56 2002
++++ source/defs.hh Thu Apr 18 18:43:14 2002
+@@ -8,7 +8,7 @@
+ #ifndef DEFS_HH
+ #define DEFS_HH
+
+-#define DEFAULT_DIR "../work/"
++#define DEFAULT_DIR "%%PREFIX%%/share/%%PORTNAME%%/"
+
+ // -= Remove bugfixes that change execution
+ //#define REMOVE_SIZE_RANGE_FIX // had only affected upper limit in heads
diff --git a/biology/avida/files/patch-ad b/biology/avida/files/patch-ad
new file mode 100644
index 000000000000..0440d2e48130
--- /dev/null
+++ b/biology/avida/files/patch-ad
@@ -0,0 +1,11 @@
+--- source/support/genesis.orig Fri Apr 19 20:00:53 2002
++++ source/support/genesis Fri Apr 19 20:02:24 2002
+@@ -13,7 +13,7 @@
+ RANDOM_SEED 0 # Random number seed. (0 for based on time)
+
+ ### Configuration Files ###
+-DEFAULT_DIR ../work/ # Directory in which config files can be found.
++DEFAULT_DIR %%PREFIX%%/share/%%PORTNAME%%/ # Directory in which config files can be found.
+ INST_SET inst_set.28.base # File containing instruction set.
+ TASK_SET task_set # File containing task set.
+ RESOURCE_SET resource_set # File containing resource set.
diff --git a/biology/avida/files/patch-ae b/biology/avida/files/patch-ae
new file mode 100644
index 000000000000..34a692b7cbca
--- /dev/null
+++ b/biology/avida/files/patch-ae
@@ -0,0 +1,11 @@
+--- source/support/genesis.heads.orig Fri Apr 19 20:01:09 2002
++++ source/support/genesis.heads Fri Apr 19 20:02:47 2002
+@@ -13,7 +13,7 @@
+ RANDOM_SEED 0 # Random number seed. (0 for based on time)
+
+ ### Configuration Files ###
+-DEFAULT_DIR ../work/ # Directory in which config files can be found.
++DEFAULT_DIR %%PREFIX%%/share/%%PORTNAME%%/ # Directory in which config files can be found.
+ INST_SET inst_set.26.heads.new # File containing instruction set.
+ TASK_SET task_set # File containing task set.
+ RESOURCE_SET resource_set # File containing resource set.
diff --git a/biology/avida/pkg-comment b/biology/avida/pkg-comment
new file mode 100644
index 000000000000..7d166f5a2674
--- /dev/null
+++ b/biology/avida/pkg-comment
@@ -0,0 +1 @@
+Avida is an auto-adaptive genetic system designed for ALife research
diff --git a/biology/avida/pkg-descr b/biology/avida/pkg-descr
new file mode 100644
index 000000000000..3f85f3975c88
--- /dev/null
+++ b/biology/avida/pkg-descr
@@ -0,0 +1,16 @@
+The computer program avida is an auto-adaptive genetic system designed
+primarily for use as a platform in Digital or Artificial Life research. The
+avida system is based on concepts similar to those employed by the tierra
+program developed by Tom Ray. It is a population of self-reproducing strings
+with a Turing-complete genetic basis subjected to Poisson-random mutations.
+The population adapts to the combination of an intrinsic fitness landscape
+(self-reproduction) and an externally imposed (extrinsic) fitness function
+provided by the researcher. By studying this system, one can examine
+evolutionary adaptation, general traits of living systems (such as
+self-organization), and other issues pertaining to theoretical or
+evolutionary biology and dynamic systems.
+
+WWW: http://dllab.caltech.edu/avida/
+
+Jeremy
+karlj000@unbc.ca
diff --git a/biology/avida/pkg-plist b/biology/avida/pkg-plist
new file mode 100644
index 000000000000..e7ce0d5f69bd
--- /dev/null
+++ b/biology/avida/pkg-plist
@@ -0,0 +1,35 @@
+bin/avida
+share/avida/creature.base
+share/avida/creature.heads
+share/avida/creature.heads.new
+share/avida/genesis
+share/avida/genesis.heads
+share/avida/inst_set.19.short
+share/avida/inst_set.24.base
+share/avida/inst_set.26.heads.new
+share/avida/inst_set.27.multi
+share/avida/inst_set.27.no-nop
+share/avida/inst_set.27.parasite
+share/avida/inst_set.28.base
+share/avida/inst_set.28.const
+share/avida/inst_set.28.dir-match
+share/avida/inst_set.29.base_memsize
+share/avida/inst_set.31.multi
+share/avida/inst_set.32.heads
+share/avida/inst_set.84.long
+share/avida/inst_set.args
+share/avida/inst_set.big
+share/avida/inst_set.dev
+share/avida/inst_set.full
+share/avida/inst_set.long
+share/avida/inst_set.re
+share/avida/inst_set.red
+share/avida/inst_set.short
+share/avida/inst_set.test
+share/avida/inst_set.tiny
+share/avida/inst_set.travc
+share/avida/event_list
+share/avida/resource_set
+share/avida/task_set
+share/avida/analyze.cfg
+@dirrm share/avida