aboutsummaryrefslogtreecommitdiff
path: root/biology/bcftools
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2021-03-20 17:14:32 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2021-03-20 17:14:32 +0000
commit6f516a8acf5122668b71a77d90e28cff1c3881e4 (patch)
tree74aa85b99a6dcff8050252330fb33340525ae72e /biology/bcftools
parent1131956c47169cc9ba0e0809795e7021de6e7b3c (diff)
downloadports-6f516a8acf5122668b71a77d90e28cff1c3881e4.tar.gz
ports-6f516a8acf5122668b71a77d90e28cff1c3881e4.zip
biology/htslib: Update to 1.12
biology/samtools: Update to 1.12 biology/bcftools: Update to 1.12 Numerous enhancements, performance improvements, and bug fixes since 1.11 Build-tested all other htslib dependents, no revbumps should be needed Reported by: portscout
Notes
Notes: svn path=/head/; revision=568874
Diffstat (limited to 'biology/bcftools')
-rw-r--r--biology/bcftools/Makefile5
-rw-r--r--biology/bcftools/distinfo6
-rw-r--r--biology/bcftools/files/patch-Makefile16
-rw-r--r--biology/bcftools/files/patch-test_test.pl20
-rw-r--r--biology/bcftools/files/pkg-message.in13
-rw-r--r--biology/bcftools/pkg-plist2
6 files changed, 9 insertions, 53 deletions
diff --git a/biology/bcftools/Makefile b/biology/bcftools/Makefile
index 964affb3cd6f..f70a8d828a2d 100644
--- a/biology/bcftools/Makefile
+++ b/biology/bcftools/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= bcftools
-PORTVERSION= 1.11
+PORTVERSION= 1.12
CATEGORIES= biology
MAINTAINER= jwb@FreeBSD.org
@@ -11,14 +11,13 @@ COMMENT= Tools for manipulating next-generation sequencing data
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= libhts.so.3:biology/htslib
+LIB_DEPENDS= libhts.so:biology/htslib
TEST_DEPENDS= bash:shells/bash
RUN_DEPENDS= bash:shells/bash
USES= autoreconf gmake localbase perl5 python:env shebangfix
USE_GITHUB= yes
-USE_LDCONFIG= ${PREFIX}/libexec/${PORTNAME}
USE_PERL5= test
GH_ACCOUNT= samtools
diff --git a/biology/bcftools/distinfo b/biology/bcftools/distinfo
index aac1660e88f1..204108d9af60 100644
--- a/biology/bcftools/distinfo
+++ b/biology/bcftools/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1603028344
-SHA256 (samtools-bcftools-1.11_GH0.tar.gz) = f2d9a09fd7920754b60948b81ec047882864213b93a0cd1ef0372b0e025cba3f
-SIZE (samtools-bcftools-1.11_GH0.tar.gz) = 3004923
+TIMESTAMP = 1616112968
+SHA256 (samtools-bcftools-1.12_GH0.tar.gz) = b29e6d41ca0bb3f1761bee81be0c423329928a724a75501641c1ac5065d65526
+SIZE (samtools-bcftools-1.12_GH0.tar.gz) = 3048508
diff --git a/biology/bcftools/files/patch-Makefile b/biology/bcftools/files/patch-Makefile
index 8dc6a8e96e69..3299954ae45b 100644
--- a/biology/bcftools/files/patch-Makefile
+++ b/biology/bcftools/files/patch-Makefile
@@ -1,16 +1,6 @@
---- Makefile.orig 2020-10-18 13:31:52 UTC
+--- Makefile.orig 2021-03-17 09:16:18 UTC
+++ Makefile
-@@ -45,7 +45,8 @@ OBJS = main.o vcfindex.o tabix.o \
- ccall.o em.o prob1.o kmin.o # the original samtools calling
- PLUGIN_OBJS = vcfplugin.o
-
--prefix = /usr/local
-+PREFIX ?= /usr/local
-+prefix = $(PREFIX)
- exec_prefix = $(prefix)
- bindir = $(exec_prefix)/bin
- libdir = $(exec_prefix)/lib
-@@ -58,13 +59,14 @@ pluginpath = $(plugindir)
+@@ -58,13 +58,14 @@ pluginpath = $(plugindir)
# Installation location for $(MISC_PROGRAMS) and $(MISC_SCRIPTS)
misc_bindir = $(bindir)
@@ -32,7 +22,7 @@
PROGRAMS = bcftools
MISC_SCRIPTS = \
-@@ -142,7 +144,7 @@ print-version:
+@@ -142,7 +143,7 @@ print-version:
ifdef USE_GPL
main.o : EXTRA_CPPFLAGS += -DUSE_GPL
OBJS += polysomy.o peakfit.o
diff --git a/biology/bcftools/files/patch-test_test.pl b/biology/bcftools/files/patch-test_test.pl
deleted file mode 100644
index 39ccb4466b54..000000000000
--- a/biology/bcftools/files/patch-test_test.pl
+++ /dev/null
@@ -1,20 +0,0 @@
---- test/test.pl.orig 2020-10-18 13:36:42 UTC
-+++ test/test.pl
-@@ -1236,7 +1236,7 @@ sub test_usage
- my $command = $args{cmd};
- my $commandpath = $$opts{bin}."/".$command;
- my ($ret,$out) = _cmd("$commandpath $args{redirection} 2>&1");
-- if ( $out =~ m/\/bin\/bash.*no.*such/i ) { failed($opts,$test,"could not run $commandpath: $out"); return; }
-+ if ( $out =~ m/bash.*no.*such/i ) { failed($opts,$test,"could not run $commandpath: $out"); return; }
-
- my @sections = ($out =~ m/(^[A-Za-z]+.*?)(?:(?=^[A-Za-z]+:)|\z)/msg);
-
-@@ -1291,7 +1291,7 @@ sub test_usage_subcommand
- my $subcommand = $args{subcmd};
- my $commandpath = $$opts{bin}."/".$command;
- my ($ret,$out) = _cmd("$commandpath $subcommand $args{redirection} 2>&1");
-- if ( $out =~ m/\/bin\/bash.*no.*such/i ) { failed($opts,$test,"could not run $commandpath $subcommand: $out"); return; }
-+ if ( $out =~ m/bash.*no.*such/i ) { failed($opts,$test,"could not run $commandpath $subcommand: $out"); return; }
-
- my @sections = ($out =~ m/(^[A-Za-z]+.*?)(?:(?=^[A-Za-z]+:)|\z)/msg);
-
diff --git a/biology/bcftools/files/pkg-message.in b/biology/bcftools/files/pkg-message.in
deleted file mode 100644
index 8bee64d8ea83..000000000000
--- a/biology/bcftools/files/pkg-message.in
+++ /dev/null
@@ -1,13 +0,0 @@
-[
-{ type: install
- message: <<EOM
-The miscellaneous tools included with Bcftools have been installed to
-%%PREFIX%%/bin/samtools_misc
-
-Add that directory to your path if you want to use these tools.
-
-Some of these tools depend on Perl5/Python, and it will need to be installed to
-use them.
-EOM
-}
-]
diff --git a/biology/bcftools/pkg-plist b/biology/bcftools/pkg-plist
index ed393533217b..11f94eafff86 100644
--- a/biology/bcftools/pkg-plist
+++ b/biology/bcftools/pkg-plist
@@ -40,7 +40,7 @@ libexec/bcftools/smpl-stats.so
libexec/bcftools/split-vep.so
libexec/bcftools/split.so
libexec/bcftools/tag2tag.so
-libexec/bcftools/trio-dnm.so
+libexec/bcftools/trio-dnm2.so
libexec/bcftools/trio-stats.so
libexec/bcftools/trio-switch-rate.so
libexec/bcftools/variantkey-hex.so