aboutsummaryrefslogtreecommitdiff
path: root/biology/bifrost
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2023-07-07 13:37:33 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2023-07-07 13:38:22 +0000
commit964411795080849c96f95a7ce315e1b230b9b93a (patch)
tree98a820a584dae2b502fecd0c78d1c3eb665b6c2d /biology/bifrost
parent062481165673585a01a42f1ba5689b04e923f6c7 (diff)
downloadports-964411795080849c96f95a7ce315e1b230b9b93a.tar.gz
ports-964411795080849c96f95a7ce315e1b230b9b93a.zip
biology/bifrost: Parallel tool for de Bruijn graphs
Bifrost is a tool and API for parallel construction, indexing and querying of colored and compacted de Bruijn graphs from FASTA/FASTQ DNA/RNA sequence files.
Diffstat (limited to 'biology/bifrost')
-rw-r--r--biology/bifrost/Makefile18
-rw-r--r--biology/bifrost/distinfo3
-rw-r--r--biology/bifrost/files/patch-src_strict__fstream.hpp11
-rw-r--r--biology/bifrost/pkg-descr3
-rw-r--r--biology/bifrost/pkg-plist53
5 files changed, 88 insertions, 0 deletions
diff --git a/biology/bifrost/Makefile b/biology/bifrost/Makefile
new file mode 100644
index 000000000000..1ca58622a09a
--- /dev/null
+++ b/biology/bifrost/Makefile
@@ -0,0 +1,18 @@
+PORTNAME= bifrost
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.2.1
+CATEGORIES= biology
+
+MAINTAINER= jwb@FreeBSD.org
+COMMENT= Parallel construction, indexing and querying of de Bruijn graphs
+WWW= https://github.com/pmelsted/bifrost
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= cmake
+USE_GITHUB= yes
+
+GH_ACCOUNT= pmelsted
+
+.include <bsd.port.mk>
diff --git a/biology/bifrost/distinfo b/biology/bifrost/distinfo
new file mode 100644
index 000000000000..f92944f13d87
--- /dev/null
+++ b/biology/bifrost/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1688397139
+SHA256 (pmelsted-bifrost-v1.2.1_GH0.tar.gz) = fe93080ef3ea71ff009fc206b5c17dd40fbfd18293000621a83d7d947dfedf1a
+SIZE (pmelsted-bifrost-v1.2.1_GH0.tar.gz) = 905438
diff --git a/biology/bifrost/files/patch-src_strict__fstream.hpp b/biology/bifrost/files/patch-src_strict__fstream.hpp
new file mode 100644
index 000000000000..e3b3caf35931
--- /dev/null
+++ b/biology/bifrost/files/patch-src_strict__fstream.hpp
@@ -0,0 +1,11 @@
+--- src/strict_fstream.hpp.orig 2023-07-03 15:14:36 UTC
++++ src/strict_fstream.hpp
+@@ -64,7 +64,7 @@ static std::string strerror()
+ } else {
+ return "Unknown error (" + std::to_string(err_num) + ")";
+ }
+-#elif ((_POSIX_C_SOURCE >= 200112L || _XOPEN_SOURCE >= 600) && ! _GNU_SOURCE) || defined(__APPLE__) || defined(__MUSL__)
++#elif ((_POSIX_C_SOURCE >= 200112L || _XOPEN_SOURCE >= 600) && ! _GNU_SOURCE) || defined(__APPLE__) || defined(__MUSL__) || defined(__FreeBSD__)
+ // XSI-compliant strerror_r()
+ const int err_num = errno; // See above
+ if (strerror_r(err_num, buff.data(), buff.size()) == 0) {
diff --git a/biology/bifrost/pkg-descr b/biology/bifrost/pkg-descr
new file mode 100644
index 000000000000..68c41b2f44fc
--- /dev/null
+++ b/biology/bifrost/pkg-descr
@@ -0,0 +1,3 @@
+Bifrost is a tool and API for parallel construction, indexing and
+querying of colored and compacted de Bruijn graphs from FASTA/FASTQ
+DNA/RNA sequence files.
diff --git a/biology/bifrost/pkg-plist b/biology/bifrost/pkg-plist
new file mode 100644
index 000000000000..7d555618743c
--- /dev/null
+++ b/biology/bifrost/pkg-plist
@@ -0,0 +1,53 @@
+bin/Bifrost
+include/bifrost/BitContainer.hpp
+include/bifrost/BlockedBloomFilter.hpp
+include/bifrost/ColorSet.hpp
+include/bifrost/ColoredCDBG.hpp
+include/bifrost/ColoredCDBG.tcc
+include/bifrost/Common.hpp
+include/bifrost/CompactedDBG.hpp
+include/bifrost/CompactedDBG.tcc
+include/bifrost/CompressedCoverage.hpp
+include/bifrost/CompressedSequence.hpp
+include/bifrost/DataAccessor.hpp
+include/bifrost/DataAccessor.tcc
+include/bifrost/DataManager.hpp
+include/bifrost/DataStorage.hpp
+include/bifrost/DataStorage.tcc
+include/bifrost/FASTX_Parser.hpp
+include/bifrost/File_Parser.hpp
+include/bifrost/GFA_Parser.hpp
+include/bifrost/IO.tcc
+include/bifrost/Kmer.hpp
+include/bifrost/KmerCovIndex.hpp
+include/bifrost/KmerCovIndex.tcc
+include/bifrost/KmerHashTable.hpp
+include/bifrost/KmerIterator.hpp
+include/bifrost/KmerStream.hpp
+include/bifrost/Lock.hpp
+include/bifrost/MinimizerIndex.hpp
+include/bifrost/NeighborIterator.hpp
+include/bifrost/NeighborIterator.tcc
+include/bifrost/RepHash.hpp
+include/bifrost/Search.tcc
+include/bifrost/StreamCounter.hpp
+include/bifrost/TinyBitmap.hpp
+include/bifrost/TinyVector.hpp
+include/bifrost/Unitig.hpp
+include/bifrost/UnitigIterator.hpp
+include/bifrost/UnitigIterator.tcc
+include/bifrost/UnitigMap.hpp
+include/bifrost/UnitigMap.tcc
+include/bifrost/getRSS.h
+include/bifrost/kseq.h
+include/bifrost/libdivide.h
+include/bifrost/libpopcnt.h
+include/bifrost/minHashIterator.hpp
+include/bifrost/roaring.h
+include/bifrost/roaring.hh
+include/bifrost/rw_spin_lock.h
+include/bifrost/strict_fstream.hpp
+include/bifrost/wyhash.h
+include/bifrost/zstr.hpp
+lib/libbifrost.a
+lib/libbifrost.so