aboutsummaryrefslogtreecommitdiff
path: root/biology/fasta
diff options
context:
space:
mode:
authorJames E. Housley <jeh@FreeBSD.org>2001-02-11 16:24:18 +0000
committerJames E. Housley <jeh@FreeBSD.org>2001-02-11 16:24:18 +0000
commitc82fc943113baf5de2e9b2282c7f015ba8965de9 (patch)
treee1341803fd3045f53f3dd1852e88928fc6e80c85 /biology/fasta
parentb03bca912cc7f9544e8da92771777aaa85bcc9c4 (diff)
downloadports-c82fc943113baf5de2e9b2282c7f015ba8965de9.tar.gz
ports-c82fc943113baf5de2e9b2282c7f015ba8965de9.zip
New port: biology/fasta, the FASTA2 suite of DNA and protein sequence
search tools PR: 24715 Submitted by: Johann Visagie <johann@egenetics.com>
Notes
Notes: svn path=/head/; revision=38205
Diffstat (limited to 'biology/fasta')
-rw-r--r--biology/fasta/Makefile47
-rw-r--r--biology/fasta/distinfo1
-rw-r--r--biology/fasta/files/patch-Makefile28
-rw-r--r--biology/fasta/pkg-comment1
-rw-r--r--biology/fasta/pkg-descr20
-rw-r--r--biology/fasta/pkg-message15
-rw-r--r--biology/fasta/pkg-plist38
7 files changed, 150 insertions, 0 deletions
diff --git a/biology/fasta/Makefile b/biology/fasta/Makefile
new file mode 100644
index 000000000000..a5cff36068c4
--- /dev/null
+++ b/biology/fasta/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: fasta
+# Date created: 29 January 2001
+# Whom: Johann Visagie <johann@egenetics.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fasta
+PORTVERSION= 20.u66
+CATEGORIES= biology
+MASTER_SITES= http://ftp.virginia.edu/pub/fasta/
+DISTNAME= fasta${PORTVERSION:S/.//g}
+EXTRACT_SUFX= .shar.Z
+
+MAINTAINER= johann@egenetics.com
+
+NO_CDROM= May not be sold or incorporated into a commercial product
+WRKSRC= ${WRKDIR}/fasta
+PKGMESSAGE= ${WRKDIR}/pkg-message
+FASTA_DOCDIR= ${PREFIX}/share/doc/fasta
+FASTA_DOCS= COPYRIGHT README.versions fasta20.doc fasta20.me format.doc \
+ readme.*
+
+MAN1= align.1 fasta.1 lalign.1 prdf.1 prss.1 randseq.1 ssearch.1
+MLINKS= fasta.1 tfasta.1 fasta.1 lfasta.1 fasta.1 plfasta.1 \
+ fasta.1 fastx.1 fasta.1 tfastx.1 \
+ align.1 align0.1 lalign.1 plalign.1
+
+do-extract:
+ @ ${RM} -rf ${WRKDIR}
+ @ ${MKDIR} ${WRKSRC}
+ @ for file in ${EXTRACT_ONLY}; do \
+ cd ${WRKSRC} && (${GZCAT} ${DISTDIR}/$${file} | ${SH} >/dev/null); \
+ done
+
+post-install:
+.for manpage in ${MAN1}
+ @ ${INSTALL_MAN} ${WRKSRC}/${manpage} ${MAN1PREFIX}/man/man1/
+.endfor
+.if !defined(NOPORTDOCS)
+ @ ${MKDIR} ${FASTA_DOCDIR}
+.for docfile in ${FASTA_DOCS}
+ @ ${INSTALL_MAN} ${WRKSRC}/${docfile} ${FASTA_DOCDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/biology/fasta/distinfo b/biology/fasta/distinfo
new file mode 100644
index 000000000000..d1bcef75803b
--- /dev/null
+++ b/biology/fasta/distinfo
@@ -0,0 +1 @@
+MD5 (fasta20u66.shar.Z) = 3960df040e5006969cf02568544751e9
diff --git a/biology/fasta/files/patch-Makefile b/biology/fasta/files/patch-Makefile
new file mode 100644
index 000000000000..25262482eef8
--- /dev/null
+++ b/biology/fasta/files/patch-Makefile
@@ -0,0 +1,28 @@
+--- Makefile.orig Mon Jan 29 15:10:42 2001
++++ Makefile Mon Jan 29 15:15:08 2001
+@@ -3,13 +3,13 @@
+ # for mips, also use: -mips2 -O2
+ #
+
+-CC= cc -O
++#CC= cc -O
+ #CC=cc -g
+
+-CFLAGS= -DUNIX -DBIGMEM -DSFCHAR="':'" -DEXPM1 -DPROGRESS
++CFLAGS+= -DUNIX -DBIGMEM -DSFCHAR="':'" -DEXPM1 -DPROGRESS
+ LFLAGS= -lm -o
+
+-BIN = /seqprg/slib/bin
++BIN = $(PREFIX)/bin
+ #NRAND= nrand
+ #IBM RS/6000
+ NRAND= nrand48
+@@ -29,7 +29,7 @@
+ sall : $(SPROGS)
+
+ install :
+- cp $(PROGS) $(BIN)
++ $(BSD_INSTALL_PROGRAM) $(PROGS) $(BIN)
+
+ clean-up :
+ rm *.o $(PROGS)
diff --git a/biology/fasta/pkg-comment b/biology/fasta/pkg-comment
new file mode 100644
index 000000000000..b4e576aaaea1
--- /dev/null
+++ b/biology/fasta/pkg-comment
@@ -0,0 +1 @@
+A collection of programs for searching DNA and protein databases
diff --git a/biology/fasta/pkg-descr b/biology/fasta/pkg-descr
new file mode 100644
index 000000000000..b5230be12f67
--- /dev/null
+++ b/biology/fasta/pkg-descr
@@ -0,0 +1,20 @@
+Version 2 of the FASTA packages contains many programs for searching DNA and
+protein databases, performing sequence comparisons, producing local
+alignments, and other related tasks.
+
+Currently, the FASTA2 suite is in maintenance mode. Updated versions of ONLY
+the searching programs are available in version 3 of the FASTA packages,
+which may be found in the port biology/fasta3.
+
+FASTA is described in: W. R. Pearson and D. J. Lipman (1988), "Improved
+Tools for Biological Sequence Analysis", PNAS 85:2444- 2448, and W. R.
+Pearson (1990) "Rapid and Sensitive Sequence Comparison with FASTP and FASTA"
+Methods in Enzymology 183:63- 98).
+
+The FASTA2 suite is distributed freely subject to the condition that it may
+not be sold or incorporated into a commercial product.
+
+Author: William R Pearson <wrp@virginia.edu>
+WWW: http://fasta.bioch.virginia.edu/
+
+-- Johann Visagie <johann@egenetics.com>
diff --git a/biology/fasta/pkg-message b/biology/fasta/pkg-message
new file mode 100644
index 000000000000..4a6cc7e32515
--- /dev/null
+++ b/biology/fasta/pkg-message
@@ -0,0 +1,15 @@
+--------------------------------------------------------------------------
+
+The FASTA3 package has been successfully installed.
+
+NB: A sample configuration file has been installed to %%PREFIX%%/etc as
+"fastlibs.sample". This may be renamed to "fastlibs" and edited
+to suit the requirements of a particular site.
+
+In order to use the FASTA3 programs, a user must set the environment
+variable FASTLIBS to contain the full path of the FASTA3 configuration
+file, e.g.:
+
+- set FASTLIBS to: "%%PREFIX%%/etc/fastlibs"
+
+--------------------------------------------------------------------------
diff --git a/biology/fasta/pkg-plist b/biology/fasta/pkg-plist
new file mode 100644
index 000000000000..7b65ef9c827a
--- /dev/null
+++ b/biology/fasta/pkg-plist
@@ -0,0 +1,38 @@
+%%PORTDOCS%%share/doc/fasta/COPYRIGHT
+%%PORTDOCS%%share/doc/fasta/README.versions
+%%PORTDOCS%%share/doc/fasta/fasta20.doc
+%%PORTDOCS%%share/doc/fasta/fasta20.me
+%%PORTDOCS%%share/doc/fasta/format.doc
+%%PORTDOCS%%share/doc/fasta/readme.v15
+%%PORTDOCS%%share/doc/fasta/readme.v16
+%%PORTDOCS%%share/doc/fasta/readme.v17
+%%PORTDOCS%%share/doc/fasta/readme.v20
+%%PORTDOCS%%share/doc/fasta/readme.v20u4
+%%PORTDOCS%%share/doc/fasta/readme.v20u5
+%%PORTDOCS%%share/doc/fasta/readme.v20u6
+bin/aacomp
+bin/align
+bin/align0
+bin/bestscor
+bin/crandseq
+bin/fasta
+bin/fastx
+bin/flalign
+bin/fromgb
+bin/garnier
+bin/grease
+bin/lalign
+bin/lfasta
+bin/plalign
+bin/plfasta
+bin/prdf
+bin/prss
+bin/psgrease
+bin/randseq
+bin/relate
+bin/ssearch
+bin/tfasta
+bin/tfastx
+bin/tgrease
+bin/zs_exp
+%%PORTDOCS%%@dirrm share/doc/fasta