aboutsummaryrefslogtreecommitdiff
path: root/biology/freebayes/files
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2018-04-20 00:07:27 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2018-04-20 00:07:27 +0000
commit73a92ce7601dc6d849e245e334e857de2b450dc8 (patch)
tree9dea7c85cd1f2fbded22dd7dacd50063db0c7b19 /biology/freebayes/files
parent42b89ed8c9872bdcc93f6510bb71f81980ac8e5d (diff)
downloadports-73a92ce7601dc6d849e245e334e857de2b450dc8.tar.gz
ports-73a92ce7601dc6d849e245e334e857de2b450dc8.zip
biology/freebayes: Bayesian haplotype-based polymorphism discovery and genotyping
Approved by: jrm (mentor) Differential Revision: https://reviews.freebsd.org/D15116
Notes
Notes: svn path=/head/; revision=467806
Diffstat (limited to 'biology/freebayes/files')
-rw-r--r--biology/freebayes/files/patch-Makefile20
-rw-r--r--biology/freebayes/files/patch-SeqLib_bwa_Makefile14
-rw-r--r--biology/freebayes/files/patch-SeqLib_bwa_bwt__lite.c10
-rw-r--r--biology/freebayes/files/patch-SeqLib_bwa_bwtgap.h10
-rw-r--r--biology/freebayes/files/patch-SeqLib_bwa_kthread.c10
-rw-r--r--biology/freebayes/files/patch-SeqLib_fermi-lite_Makefile12
-rw-r--r--biology/freebayes/files/patch-SeqLib_htslib_Makefile38
-rw-r--r--biology/freebayes/files/patch-src_LargeFileSupport.h11
-rw-r--r--biology/freebayes/files/patch-src_Makefile62
-rw-r--r--biology/freebayes/files/patch-vcflib_Makefile13
10 files changed, 200 insertions, 0 deletions
diff --git a/biology/freebayes/files/patch-Makefile b/biology/freebayes/files/patch-Makefile
new file mode 100644
index 000000000000..9c87b87ffbcb
--- /dev/null
+++ b/biology/freebayes/files/patch-Makefile
@@ -0,0 +1,20 @@
+--- Makefile.orig 2018-03-23 14:01:01 UTC
++++ Makefile
+@@ -5,7 +5,7 @@ wbamtools: vcflib/Makefile log
+ cd src && $(MAKE) -f Makefile.bamtools
+
+ log: src/version_git.h
+- wget -q http://hypervolu.me/freebayes/build/$(shell cat src/version_git.h | grep v | cut -f 3 -d\ | sed s/\"//g) &
++ # wget -q http://hypervolu.me/freebayes/build/$(shell cat src/version_git.h | grep v | cut -f 3 -d\ | sed s/\"//g) &
+
+ src/version_git.h:
+ cd src && $(MAKE) autoversion
+@@ -27,7 +27,7 @@ uninstall:
+ rm /usr/local/bin/freebayes /usr/local/bin/bamleftalign
+
+ test:
+- cd test && make test
++ cd test && ${MAKE} test
+
+ clean:
+ cd src && $(MAKE) clean
diff --git a/biology/freebayes/files/patch-SeqLib_bwa_Makefile b/biology/freebayes/files/patch-SeqLib_bwa_Makefile
new file mode 100644
index 000000000000..356ac3bd66ea
--- /dev/null
+++ b/biology/freebayes/files/patch-SeqLib_bwa_Makefile
@@ -0,0 +1,14 @@
+--- SeqLib/bwa/Makefile.orig 2018-03-23 18:47:04 UTC
++++ SeqLib/bwa/Makefile
+@@ -1,8 +1,8 @@
+-CC= gcc
++CC ?= gcc
+ #CC= clang --analyze
+-CFLAGS= -g -Wall -Wno-unused-function -O2
++CFLAGS ?= -g -Wall -Wno-unused-function -O2
+ WRAP_MALLOC=-DUSE_MALLOC_WRAPPERS
+-AR= ar
++AR ?= ar
+ DFLAGS= -DHAVE_PTHREAD $(WRAP_MALLOC)
+ ## moved is.o bwtiindex.o rope.o to LOBJS
+ LOBJS= utils.o kthread.o ksw.o bwt.o bntseq.o bwa.o bwamem.o bwamem_pair.o \
diff --git a/biology/freebayes/files/patch-SeqLib_bwa_bwt__lite.c b/biology/freebayes/files/patch-SeqLib_bwa_bwt__lite.c
new file mode 100644
index 000000000000..f664bd55c48a
--- /dev/null
+++ b/biology/freebayes/files/patch-SeqLib_bwa_bwt__lite.c
@@ -0,0 +1,10 @@
+--- SeqLib/bwa/bwt_lite.c.orig 2018-03-23 18:49:48 UTC
++++ SeqLib/bwa/bwt_lite.c
+@@ -1,6 +1,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <stdio.h>
++#include <sys/types.h>
+ #include "bwt_lite.h"
+
+ #ifdef USE_MALLOC_WRAPPERS
diff --git a/biology/freebayes/files/patch-SeqLib_bwa_bwtgap.h b/biology/freebayes/files/patch-SeqLib_bwa_bwtgap.h
new file mode 100644
index 000000000000..4b2e4322b70a
--- /dev/null
+++ b/biology/freebayes/files/patch-SeqLib_bwa_bwtgap.h
@@ -0,0 +1,10 @@
+--- SeqLib/bwa/bwtgap.h.orig 2018-03-23 18:49:18 UTC
++++ SeqLib/bwa/bwtgap.h
+@@ -3,6 +3,7 @@
+
+ #include "bwt.h"
+ #include "bwtaln.h"
++#include <sys/types.h>
+
+ typedef struct { // recursion stack
+ u_int32_t info; // score<<21 | i
diff --git a/biology/freebayes/files/patch-SeqLib_bwa_kthread.c b/biology/freebayes/files/patch-SeqLib_bwa_kthread.c
new file mode 100644
index 000000000000..5193e4a2a2ab
--- /dev/null
+++ b/biology/freebayes/files/patch-SeqLib_bwa_kthread.c
@@ -0,0 +1,10 @@
+--- SeqLib/bwa/kthread.c.orig 2018-03-23 18:48:35 UTC
++++ SeqLib/bwa/kthread.c
+@@ -1,6 +1,7 @@
+ #include <pthread.h>
+ #include <stdlib.h>
+ #include <limits.h>
++#include <inttypes.h>
+
+ /************
+ * kt_for() *
diff --git a/biology/freebayes/files/patch-SeqLib_fermi-lite_Makefile b/biology/freebayes/files/patch-SeqLib_fermi-lite_Makefile
new file mode 100644
index 000000000000..ba795955ec76
--- /dev/null
+++ b/biology/freebayes/files/patch-SeqLib_fermi-lite_Makefile
@@ -0,0 +1,12 @@
+--- SeqLib/fermi-lite/Makefile.orig 2018-03-23 18:50:25 UTC
++++ SeqLib/fermi-lite/Makefile
+@@ -1,6 +1,6 @@
+-CC= gcc
+-CFLAGS= -g -Wall -O2 -Wno-unused-function #-fno-inline-functions -fno-inline-functions-called-once
+-CPPFLAGS=
++CC ?= gcc
++CFLAGS ?= -g -Wall -O2 -Wno-unused-function #-fno-inline-functions -fno-inline-functions-called-once
++CPPFLAGS ?=
+ INCLUDES=
+ OBJS= kthread.o misc.o \
+ bseq.o htab.o bfc.o \
diff --git a/biology/freebayes/files/patch-SeqLib_htslib_Makefile b/biology/freebayes/files/patch-SeqLib_htslib_Makefile
new file mode 100644
index 000000000000..e533e6ca5f45
--- /dev/null
+++ b/biology/freebayes/files/patch-SeqLib_htslib_Makefile
@@ -0,0 +1,38 @@
+--- SeqLib/htslib/Makefile.orig 2017-06-20 12:40:28 UTC
++++ SeqLib/htslib/Makefile
+@@ -22,20 +22,20 @@
+ # FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+ # DEALINGS IN THE SOFTWARE.
+
+-CC = gcc
+-AR = ar
+-RANLIB = ranlib
++CC ?= gcc
++AR ?= ar
++RANLIB ?= ranlib
+
+ # Default libraries to link if configure is not used
+ htslib_default_libs = -lz -lm -lbz2 -llzma
+
+-CPPFLAGS =
++CPPFLAGS ?=
+ # TODO: probably update cram code to make it compile cleanly with -Wc++-compat
+ # For testing strict C99 support add -std=c99 -D_XOPEN_SOURCE=600
+ #CFLAGS = -g -Wall -O2 -pedantic -std=c99 -D_XOPEN_SOURCE=600 -D__FUNCTION__=__func__
+-CFLAGS = -g -Wall -O2
++CFLAGS ?= -g -Wall -O2
+ EXTRA_CFLAGS_PIC = -fpic
+-LDFLAGS =
++LDFLAGS ?=
+ LIBS = $(htslib_default_libs)
+
+ prefix = /usr/local
+@@ -86,7 +86,7 @@ BUILT_THRASH_PROGRAMS = \
+ test/thrash_threads5 \
+ test/thrash_threads6
+
+-all: lib-static lib-shared $(BUILT_PROGRAMS) plugins $(BUILT_TEST_PROGRAMS)
++all: lib-static $(BUILT_PROGRAMS) plugins $(BUILT_TEST_PROGRAMS)
+
+ HTSPREFIX =
+ include htslib_vars.mk
diff --git a/biology/freebayes/files/patch-src_LargeFileSupport.h b/biology/freebayes/files/patch-src_LargeFileSupport.h
new file mode 100644
index 000000000000..60adfad0de8f
--- /dev/null
+++ b/biology/freebayes/files/patch-src_LargeFileSupport.h
@@ -0,0 +1,11 @@
+--- src/LargeFileSupport.h.orig 2018-03-23 21:15:04 UTC
++++ src/LargeFileSupport.h
+@@ -8,7 +8,7 @@ typedef __int64 off_type;
+ #define ftell64(a) ftell(a)
+ #define fseek64(a,b,c) fseek(a,b,c)
+ typedef __int64_t off_type;
+-#elif defined(__APPLE__)
++#elif defined(__APPLE__) || defined(__FreeBSD__)
+ #define ftell64(a) ftello(a)
+ #define fseek64(a,b,c) fseeko(a,b,c)
+ typedef off_t off_type;
diff --git a/biology/freebayes/files/patch-src_Makefile b/biology/freebayes/files/patch-src_Makefile
new file mode 100644
index 000000000000..cfe34b3b4ead
--- /dev/null
+++ b/biology/freebayes/files/patch-src_Makefile
@@ -0,0 +1,62 @@
+--- src/Makefile.orig 2018-03-23 14:01:01 UTC
++++ src/Makefile
+@@ -5,8 +5,9 @@
+ ################################################################################
+
+ # Compiler
+-CXX=g++ ${CXXFLAGS}
+-C=gcc
++CXX ?= g++
++# CXX += ${CXXFLAGS}
++CC ?= gcc
+
+ export CXXFLAGS
+ export C
+@@ -17,7 +18,7 @@ export LIBFLAGS
+
+ # Compiler flags
+
+-CFLAGS=-O3 -D_FILE_OFFSET_BITS=64 -g
++CFLAGS += -D_FILE_OFFSET_BITS=64
+ #CFLAGS=-O3 -static -D VERBOSE_DEBUG # enables verbose debugging via --debug2
+
+ SEQLIB_ROOT=../SeqLib
+@@ -25,7 +26,7 @@ VCFLIB_ROOT=../vcflib
+ TABIX_ROOT=$(VCFLIB_ROOT)/tabixpp
+ HTSLIB_ROOT=$(SEQLIB_ROOT)/htslib
+
+-LIBS = -lz -llzma -lbz2 -lm -lpthread
++LIBS = -lz -llzma -lbz2 -lm -lpthread -lexecinfo
+ INCLUDE = -I../src -I../ttmath -I$(VCFLIB_ROOT)/src/ -I$(VCFLIB_ROOT)/smithwaterman/ -I$(VCFLIB_ROOT)/multichoose/ -I$(VCFLIB_ROOT)/filevercmp/ -I$(VCFLIB_ROOT)/fastahack/ -I$(HTSLIB_ROOT) -I$(SEQLIB_ROOT)
+ #INCLUDE = -I../ttmath -I$(BAMTOOLS_ROOT)/src/ -I$(VCFLIB_ROOT)/src/ -I$(TABIX_ROOT)/ -I$(VCFLIB_ROOT)/smithwaterman/ -I$(VCFLIB_ROOT)/multichoose/ -I$(VCFLIB_ROOT)/filevercmp/ -I$(VCFLIB_ROOT)/fastahack/ -I$(HTSLIB_ROOT) -I$(SEQLIB_ROOT) -I$(SEQLIB_ROOT)/htslib
+
+@@ -46,10 +47,10 @@ gprof:
+ .PHONY: all static debug profiling gprof
+
+ $(HTSLIB_ROOT)/libhts.a:
+- cd $(HTSLIB_ROOT) && make
++ cd $(HTSLIB_ROOT) && ${MAKE}
+
+ $(SEQLIB_ROOT)/src/libseqlib.a:
+- cd $(SEQLIB_ROOT) && ./configure && make
++ cd $(SEQLIB_ROOT) && ./configure && ${MAKE}
+
+ OBJECTS=BedReader.o \
+ CNV.o \
+@@ -122,7 +123,7 @@ freebayes.o: freebayes.cpp TryCatch.h $(
+ $(CXX) $(CXXFLAGS) $(INCLUDE) -c freebayes.cpp
+
+ fastlz.o: fastlz.c fastlz.h
+- $(C) $(CFLAGS) $(INCLUDE) -c fastlz.c
++ $(CC) $(CFLAGS) $(INCLUDE) -c fastlz.c
+
+ Parameters.o: Parameters.cpp Parameters.h Version.h
+ $(CXX) $(CXXFLAGS) $(INCLUDE) -c Parameters.cpp
+@@ -277,5 +278,5 @@ autoversion:
+
+ clean:
+ rm -rf *.o *.cgh *~ freebayes alleles ../bin/freebayes ../bin/alleles ../vcflib/*.o ../vcflib/tabixpp/*.{o,a} tabix.hpp
+- if [ -d $(BAMTOOLS_ROOT)/build ]; then make -C $(BAMTOOLS_ROOT)/build clean; fi
+- make -C $(VCFLIB_ROOT)/smithwaterman clean
++ if [ -d $(BAMTOOLS_ROOT)/build ]; then ${MAKE} -C $(BAMTOOLS_ROOT)/build clean; fi
++ ${MAKE} -C $(VCFLIB_ROOT)/smithwaterman clean
diff --git a/biology/freebayes/files/patch-vcflib_Makefile b/biology/freebayes/files/patch-vcflib_Makefile
new file mode 100644
index 000000000000..c3df0fb79e6c
--- /dev/null
+++ b/biology/freebayes/files/patch-vcflib_Makefile
@@ -0,0 +1,13 @@
+--- vcflib/Makefile.orig 2018-03-23 18:36:07 UTC
++++ vcflib/Makefile
+@@ -136,8 +136,8 @@ all: $(OBJECTS) $(BINS)
+
+ GIT_VERSION := $(shell git describe --abbrev=4 --dirty --always)
+
+-CXX = g++
+-CXXFLAGS = -O3 -D_FILE_OFFSET_BITS=64 -std=c++0x
++CXX ?= g++
++CXXFLAGS += -D_FILE_OFFSET_BITS=64 -std=c++0x
+ #CXXFLAGS = -O2
+ #CXXFLAGS = -pedantic -Wall -Wshadow -Wpointer-arith -Wcast-qual
+