aboutsummaryrefslogtreecommitdiff
path: root/biology/migrate/Makefile
diff options
context:
space:
mode:
authorGabor Kovesdan <gabor@FreeBSD.org>2006-12-10 12:39:32 +0000
committerGabor Kovesdan <gabor@FreeBSD.org>2006-12-10 12:39:32 +0000
commit93e805e722802e216308f6cc1455da45fa16533f (patch)
tree04a4f6cd02ccf7d8db22c6b0e1028317ce006324 /biology/migrate/Makefile
parentac97872da3aa8ca0895798d054c666d8f0f086fe (diff)
downloadports-93e805e722802e216308f6cc1455da45fa16533f.tar.gz
ports-93e805e722802e216308f6cc1455da45fa16533f.zip
- Update to 2.1.3
- Fix fetching - Remove old patch and use MAKE_ARGS instead - portlint(1) and whitespace Approved by: erwin (mentor)
Notes
Notes: svn path=/head/; revision=179374
Diffstat (limited to 'biology/migrate/Makefile')
-rw-r--r--biology/migrate/Makefile23
1 files changed, 12 insertions, 11 deletions
diff --git a/biology/migrate/Makefile b/biology/migrate/Makefile
index 351bc6e5966b..0be9c9a3be0e 100644
--- a/biology/migrate/Makefile
+++ b/biology/migrate/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= migrate
-PORTVERSION= 2.0.3
+PORTVERSION= 2.1.3
CATEGORIES= biology
-MASTER_SITES= ftp://evolution.genetics.washington.edu/pub/lamarc/migrate/
+MASTER_SITES= http://popgen.csit.fsu.edu/currentversion/
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
MAINTAINER= ports@FreeBSD.org
@@ -17,17 +17,18 @@ COMMENT= A program to estimate population sizes and migration rates
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+MAKE_ARGS= CFLAGS="${CFLAGS}"
MAN1= migrate.1
MLINKS= migrate.1 migrate-n.1
DOCS= HISTORY HOWTO-PARALLEL README migrate.html
-EXAMPLES= README infile.benchmark infile.ep infile.msat infile.seq \
- parmfile parmfile.benchmark parmfile.ep parmfile.msat \
- parmfile.seq
+EXAMPLES= README infile.ep infile.msat infile.seq \
+ outfile-bayes-saved outfile-ml-saved \
+ parmfile parmfile.testbayes parmfile.testml
post-patch:
- @${REINPLACE_CMD} 's,-falign-loops=16,,g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} 's,-falign-loops=16,,g' ${WRKSRC}/configure
do-install:
@ ${INSTALL_PROGRAM} ${WRKSRC}/migrate-n ${PREFIX}/bin
@@ -35,12 +36,12 @@ do-install:
@ ${INSTALL_MAN} ${WRKSRC}/migrate.1 ${MAN1PREFIX}/man/man1
.if !defined(NOPORTDOCS)
@ ${MKDIR} ${DOCSDIR}/graphics
-.for file in ${DOCS}
- @ ${INSTALL_DATA} ${WRKSRC}/../${file} ${DOCSDIR}
+.for i in ${DOCS}
+ @ ${INSTALL_DATA} ${WRKSRC}/../${i} ${DOCSDIR}
.endfor
@ ${MKDIR} ${EXAMPLESDIR}
-.for file in ${EXAMPLES}
- @ ${INSTALL_DATA} ${WRKSRC}/../example/${file} ${EXAMPLESDIR}
+.for i in ${EXAMPLES}
+ @ ${INSTALL_DATA} ${WRKSRC}/../example/${i} ${EXAMPLESDIR}
.endfor
@ ${INSTALL_DATA} ${WRKSRC}/../graphics/* ${DOCSDIR}/graphics
.endif
@@ -48,7 +49,7 @@ do-install:
.include <bsd.port.pre.mk>
.if ${ARCH} == "alpha"
-BROKEN= "Does not compile"
+BROKEN= Does not compile
.endif
.include <bsd.port.post.mk>