aboutsummaryrefslogtreecommitdiff
path: root/biology/mmseqs2
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2021-06-29 14:04:48 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2021-06-29 14:04:48 +0000
commita881e9d0c3ccd79a71282e2e239cfbf2c22107f7 (patch)
tree57076d18f93f2d853eb802f6f3da85f938148586 /biology/mmseqs2
parentc4a4d868413e3d1a19e0cc0a15313b4dd28dd0cd (diff)
downloadports-a881e9d0c3ccd79a71282e2e239cfbf2c22107f7.tar.gz
ports-a881e9d0c3ccd79a71282e2e239cfbf2c22107f7.zip
biology/mmseqs2: Fix runtime error when built with clang
Disable IPS4O to avoid deadlocks (upstream developer fix) Removing USE_GCC should fix pkg build errors caused by
Diffstat (limited to 'biology/mmseqs2')
-rw-r--r--biology/mmseqs2/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/biology/mmseqs2/Makefile b/biology/mmseqs2/Makefile
index 755ed6f7aaa0..2ca647d74995 100644
--- a/biology/mmseqs2/Makefile
+++ b/biology/mmseqs2/Makefile
@@ -1,6 +1,6 @@
PORTNAME= MMseqs2
DISTVERSION= 13-45111
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= biology
MAINTAINER= jwb@FreeBSD.org
@@ -20,18 +20,14 @@ USE_PERL5= build
SHEBANG_GLOB= *.sh
GH_ACCOUNT= soedinglab
-CMAKE_ARGS+= -DUSE_SYSTEM_ZSTD:BOOL=ON
+CMAKE_ARGS+= -DUSE_SYSTEM_ZSTD:BOOL=ON -DDISABLE_IPS4O:BOOL=ON
LDFLAGS+= -lpthread
PLIST_FILES= bin/mmseqs ${DATADIR}/bash-completion.sh
.include <bsd.port.pre.mk>
-# Hangs when built with clang and SSE or x86-64 only. Works fine with
-# -march=native. Upstream is investigating. To build fully optimized,
-# non-portable binary with clang: env CFLAGS='-O2 -march=native' make
.if ${ARCH} == "amd64" && empty(CFLAGS:M*march=native*)
-USE_GCC= yes
# Need at least SSE2 for decent performance. x86-64 groups SSE2 with other
# common features in low-end AMD64 CPUs.
CFLAGS+= -march=x86-64