aboutsummaryrefslogtreecommitdiff
path: root/biology/p5-Bio-Glite/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-04-02 18:24:59 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-04-02 18:24:59 +0000
commit9de088104296724367c2f7dff72615474672d653 (patch)
tree212d47139222a77a4aece674e0bbfcd311f65119 /biology/p5-Bio-Glite/Makefile
parent85245ba154ec9ff878cc20390fb1efd5aee2f6e5 (diff)
downloadports-9de088104296724367c2f7dff72615474672d653.tar.gz
ports-9de088104296724367c2f7dff72615474672d653.zip
Bio::Glite is an interface to G-language Genome Analysis Environment
through its REST web service (http://www.g-language.org). This module allows almost everything G-language GAE can do, without installing all necessary tookits and modules. Advantage of this module over the standard installation of G-language GAE package is: 1. Easy installation from CPAN 2. Extremely light-weight (less than 1000 lines of code) 3. Does not require much CPU/RAM (all calculation is done on the cloud) Disadvantages includes: 1. Slower analysis speed 2. Internet connection is required 3. No other software interfaces such as the G-language Shell WWW: http://search.cpan.org/dist/Bio-Glite/ PR: ports/133273 Submitted by: Wen Heping <wenheping at gmail.com>
Notes
Notes: svn path=/head/; revision=231492
Diffstat (limited to 'biology/p5-Bio-Glite/Makefile')
-rw-r--r--biology/p5-Bio-Glite/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/biology/p5-Bio-Glite/Makefile b/biology/p5-Bio-Glite/Makefile
new file mode 100644
index 000000000000..61e52557e15e
--- /dev/null
+++ b/biology/p5-Bio-Glite/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Bio-Glite
+# Date created: 1st April, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Bio-Glite
+PORTVERSION= 0.10
+CATEGORIES= biology perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= An Perl Interface to G-language
+
+BUILD_DEPENDS= p5-Data-Dumper>=2.121:${PORTSDIR}/devel/p5-Data-Dumper \
+ p5-libwww>=5:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN3= Bio::Glite.3
+
+.include <bsd.port.mk>