aboutsummaryrefslogtreecommitdiff
path: root/biology/paml/Makefile
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2016-09-28 02:30:29 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2016-09-28 02:30:29 +0000
commit512daaacda3f00379c25b6c9852284234721a0bc (patch)
treefa6b81e0f9966e4269483763095c15fea9c47d76 /biology/paml/Makefile
parent29a8954d58b9bb869e19a0a606f68863afe95455 (diff)
downloadports-512daaacda3f00379c25b6c9852284234721a0bc.tar.gz
ports-512daaacda3f00379c25b6c9852284234721a0bc.zip
biology/paml: update to version 4.9c and various improvements
- Update to version 4.9c - Set LICENSE=GPLv3 - Use the variable PORTDOCS to automate the generation of the DOCS plist (as suggested by mat@). - Install dat/ examples/ and Technical/ directories as well as files in the root directory of the distribution tarball. - Fix broken permissions. - Delete Windows executables. - Build and install useful binaries not built by upstream's Makefile. - Update pkg-descr. Reviewed by: swills (mentor) Approved by: swills (mentor) Differential Revision: https://reviews.freebsd.org/D8040
Notes
Notes: svn path=/head/; revision=422846
Diffstat (limited to 'biology/paml/Makefile')
-rw-r--r--biology/paml/Makefile46
1 files changed, 37 insertions, 9 deletions
diff --git a/biology/paml/Makefile b/biology/paml/Makefile
index 9a74d5ac1235..265e61490a39 100644
--- a/biology/paml/Makefile
+++ b/biology/paml/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= paml
-PORTVERSION= 4.9a
+PORTVERSION= 4.9c
CATEGORIES= biology
MASTER_SITES= http://abacus.gene.ucl.ac.uk/software/
DISTNAME= ${PORTNAME}${PORTVERSION}
@@ -10,24 +10,52 @@ DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= jrm@FreeBSD.org
COMMENT= Phylogenetic Analysis by Maximum Likelihood (PAML)
+LICENSE= GPLv3
+
USES= gmake tar:tgz
-WRKSRC= ${WRKDIR}/${DISTNAME}/src
-MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
-BINARIES= baseml basemlg chi2 codeml evolver pamp yn00
-DOC_FILES= pamlDOC.pdf pamlFAQs.pdf pamlHistory.txt
+BINARIES= baseml basemlg chi2 codeml evolver evolverNSbranches \
+ evolverNSbranchsites evolverNSsites pamp yn00
+
+PORTDOCS= MCMCtree.Tutorials.pdf MCMCtreeDOC.pdf pamlDOC.pdf pamlFAQs.pdf \
+ pamlHistory.txt README.txt
+
+DATA= 3s.trees 4s.trees 5s.trees 6s.trees GeneticCode.txt MCaa.dat \
+ MCbase.dat MCbaseRandomTree.dat MCcodon.dat aaml.ctl baseml.ctl \
+ brown.nuc brown.rooted.trees brown.trees codeml.ctl codonml.ctl \
+ mcmctree.ctl pamp.ctl paupblock paupend paupstart stewart.aa \
+ stewart.trees yn00.ctl
+PORTDATA= ${DATA} dat examples Technical
OPTIONS_DEFINE= DOCS
+# Fix broken permissions and remove Windows executables
+post-extract:
+ @${CHMOD} -R a+rX ${WRKDIR}
+ @${FIND} ${WRKSRC}/Technical -name "*.exe" -delete
+
+do-build:
+ @cd ${WRKSRC}/src && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD}
+.for f in NSbranches NSsites NSbranchsites
+ @cd ${WRKSRC}/src && \
+ ${CC} ${CFLAGS} -DCodon${f} -o evolver${f} evolver.c tools.c -lm
+.endfor
+
do-install:
.for f in ${BINARIES}
- ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${f} ${STAGEDIR}${PREFIX}/bin
+.endfor
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+.for f in ${DATA}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}/${DATADIR}
.endfor
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} "dat examples Technical" \
+ ${STAGEDIR}/${DATADIR})
do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
-.for f in ${DOC_FILES}
- ${INSTALL_DATA} ${WRKSRC}/../doc/${f} ${STAGEDIR}${DOCSDIR}
-.endfor
+ ${INSTALL_DATA} ${WRKSRC}/doc/* ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.txt ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>