aboutsummaryrefslogtreecommitdiff
path: root/biology/py-biopython
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-11-06 23:12:14 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-11-06 23:12:14 +0000
commit6743d66769fcd3ee9204cb6f2a6906695a217d28 (patch)
treecd048ee9597a6c890cc3fb8c7ed3dbff1d921370 /biology/py-biopython
parent166eb9dfb760d3252c968a2ba05644cec3b21bdb (diff)
downloadports-6743d66769fcd3ee9204cb6f2a6906695a217d28.tar.gz
ports-6743d66769fcd3ee9204cb6f2a6906695a217d28.zip
- Fix build on amd64 (crude hack to pass -fPIC to c++ compiles)
Reported by: pointyhat via kris Tested on: arved's box
Notes
Notes: svn path=/head/; revision=121009
Diffstat (limited to 'biology/py-biopython')
-rw-r--r--biology/py-biopython/files/patch-setup.py11
1 files changed, 11 insertions, 0 deletions
diff --git a/biology/py-biopython/files/patch-setup.py b/biology/py-biopython/files/patch-setup.py
new file mode 100644
index 000000000000..fdbd92ff3b60
--- /dev/null
+++ b/biology/py-biopython/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig Fri May 14 15:17:43 2004
++++ setup.py Sun Nov 7 01:02:10 2004
+@@ -199,7 +199,7 @@
+ self.compiler.set_executable("linker_so",
+ cxx + ["-shared"])
+ elif build: # fix for 2.3, only if we are making C++ modules
+- self.compiler.compiler_so = self.compiler.compiler_cxx
++ self.compiler.compiler_so = self.compiler.compiler_cxx + ["-fPIC"]
+ else:
+ self.compiler.compiler_so = self._original_compiler_so
+