aboutsummaryrefslogtreecommitdiff
path: root/biology/seqan-apps/Makefile
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2018-11-09 21:37:01 +0000
committerSteve Wills <swills@FreeBSD.org>2018-11-09 21:37:01 +0000
commit9bd4256613e52c43fe596b77fb12174a340c264b (patch)
treee9a813f3f4981da58dadf2309cf9f40a665d0675 /biology/seqan-apps/Makefile
parentd0d7c5bddaf7440c2972f1d6bda5b406825e8355 (diff)
downloadports-9bd4256613e52c43fe596b77fb12174a340c264b.tar.gz
ports-9bd4256613e52c43fe596b77fb12174a340c264b.zip
biology/seqan-apps: fix build with GCC-based architectures
PR: 232045 Submitted by: Piotr Kubaj <pkubaj@anongoth.pl> Approved by: maintainer timeout (h2+fbsdports@fsfe.org >1 month)
Notes
Notes: svn path=/head/; revision=484547
Diffstat (limited to 'biology/seqan-apps/Makefile')
-rw-r--r--biology/seqan-apps/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/biology/seqan-apps/Makefile b/biology/seqan-apps/Makefile
index e6425016d59e..ec72e33445da 100644
--- a/biology/seqan-apps/Makefile
+++ b/biology/seqan-apps/Makefile
@@ -13,8 +13,6 @@ COMMENT= Official bioinformatic applications based on the SeqAn library
LICENSE= BSD3CLAUSE LGPL3 GPLv3
LICENSE_COMB= multi
-BROKEN_powerpc64= fails to build: requires 'c++14-lang' in USES (cf.)
-
BUILD_DEPENDS= boost-libs>0:devel/boost-libs
USES= cmake:outsource compiler:openmp # once #199603 is resolved, add c++14-lang
@@ -40,4 +38,8 @@ PLIST_SUB+= RM_I386="@comment "
PLIST_SUB+= RM_I386=""
.endif
+.if ${ARCH:Mmips*} || ${ARCH:Mpowerpc*} || ${ARCH} == sparc64
+USE_GCC= yes
+.endif
+
.include <bsd.port.post.mk>