aboutsummaryrefslogtreecommitdiff
path: root/biology/tinker
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2003-07-25 07:19:40 +0000
committerMaho Nakata <maho@FreeBSD.org>2003-07-25 07:19:40 +0000
commit7a5f7030acd5c04da0f8e49d7f47f60f5bcc1c2e (patch)
tree011664599bdbb679df47654cf1977c820fbf5223 /biology/tinker
parent1809686ff32e8587596a5a6a2c89d6eebb8f751b (diff)
downloadports-7a5f7030acd5c04da0f8e49d7f47f60f5bcc1c2e.tar.gz
ports-7a5f7030acd5c04da0f8e49d7f47f60f5bcc1c2e.zip
a) Some corrupts with Makefile and pkg-plist.
b) forgot to notice that drop maintainership to ports@ Submitted by: Glenn Johnson <gjohnson@srrc.ars.usda.gov> Pointy hat to: myself
Notes
Notes: svn path=/head/; revision=85573
Diffstat (limited to 'biology/tinker')
-rw-r--r--biology/tinker/Makefile36
-rw-r--r--biology/tinker/files/patch-aa2
2 files changed, 26 insertions, 12 deletions
diff --git a/biology/tinker/Makefile b/biology/tinker/Makefile
index 5e2ac7488d26..e37ce9aae1fb 100644
--- a/biology/tinker/Makefile
+++ b/biology/tinker/Makefile
@@ -21,26 +21,38 @@ WRKSRC= ${WRKDIR}/tinker/source
MAKEFILE= ${WRKDIR}/tinker/make/Makefile
ALL_TARGET= all listing
INSTALL_TARGET= rename
-
+USE_REINPLACE= yes
RESTRICTED= author requests no distribution except from his FTP site
-NO_CDROM= ${RESTRICTED}
-NO_PACKAGE= ${RESTRICTED}
+
+pre-fetch:
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} If you get a CHECKSUM mismatch, try doing a \'make distclean\' first.
+ @${ECHO_MSG} ""
.include <bsd.port.pre.mk>
.if defined(WITH_VIEWER)
.if ${XFREE86_VERSION} == 3
-BUILD_DEPENDS+= imake:${PORTSDIR}/devel/imake
+BUILD_DEPENDS+= imake:${PORTSDIR}/devel/imake
.elif ${XFREE86_VERSION} == 4
-BUILD_DEPENDS+= imake:${PORTSDIR}/devel/imake-4
+BUILD_DEPENDS+= imake:${PORTSDIR}/devel/imake-4
+.endif
+PLIST= ${PKGDIR}/pkg-plist.viewer
+USE_XLIB= yes
+post-build:
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/build_viewer
+.else
+pre-extract:
+ @${ECHO} ""
+ @${ECHO} If you would like to also build
+ @${ECHO} the molecular viewer, define WITH_VIEWER.
+ @${ECHO} ""
.endif
-PLIST= ${PKGDIR}/pkg-plist.viewer
-USE_XLIB= yes
.if defined(WITH_OPTIMIZED_FLAGS)
-CFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations
+FFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations
.if (${MACHINE_ARCH} == "i386")
-CFLAGS+= -mfancy-math-387 -malign-double
+FFLAGS+= -mfancy-math-387 -malign-double
.endif # i386
.endif
@@ -51,17 +63,19 @@ pre-everything::
post-build:
@${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/build_viewer
-.else
+
pre-extract:
@${ECHO} ""
@${ECHO} If you would like to also build
@${ECHO} the molecular viewer, define WITH_VIEWER.
@${ECHO} ""
-.endif
post-extract:
${CHMOD} -R u+w ${WRKDIR}/tinker
+post-patch:
+ @${REINPLACE_CMD} -e 's,%%FFLAGS%%,${FFLAGS},g' ${WRKSRC}/../make/Makefile
+
post-install:
@${MKDIR} ${PREFIX}/share/tinker
@${MKDIR} ${PREFIX}/share/tinker/params
diff --git a/biology/tinker/files/patch-aa b/biology/tinker/files/patch-aa
index 7f4270289c43..f115ed7936b5 100644
--- a/biology/tinker/files/patch-aa
+++ b/biology/tinker/files/patch-aa
@@ -58,7 +58,7 @@
+LIBS =
+F77FLAGS = -Wno-globals -fno-globals -c -w
+LINKFLAGS =
-+OPTFLAGS = ${FFLAGS}
++OPTFLAGS = %%FFLAGS%%
+LIBFLAGS = -rcuv
+
#################################################################