aboutsummaryrefslogtreecommitdiff
path: root/biology/wise
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2002-09-10 13:58:40 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2002-09-10 13:58:40 +0000
commitce85742f4fc00f1ab0479da5545530750ee1ba48 (patch)
tree17eb3064211081396ec81cc21e22ce6eccf34569 /biology/wise
parent69a078280213aabd17852a9619554815721c1a41 (diff)
downloadports-ce85742f4fc00f1ab0479da5545530750ee1ba48.tar.gz
ports-ce85742f4fc00f1ab0479da5545530750ee1ba48.zip
"Wise2 is package that is focused on comparing DNA sequences at
the level of its conceptual translation, regardless of sequencing error and introns."
Notes
Notes: svn path=/head/; revision=66053
Diffstat (limited to 'biology/wise')
-rw-r--r--biology/wise/Makefile94
-rw-r--r--biology/wise/distinfo1
-rw-r--r--biology/wise/pkg-comment1
-rw-r--r--biology/wise/pkg-descr13
-rw-r--r--biology/wise/pkg-message15
-rw-r--r--biology/wise/pkg-plist60
6 files changed, 184 insertions, 0 deletions
diff --git a/biology/wise/Makefile b/biology/wise/Makefile
new file mode 100644
index 000000000000..2c99524ff8c9
--- /dev/null
+++ b/biology/wise/Makefile
@@ -0,0 +1,94 @@
+# New ports collection makefile for: wise
+# Date created: 26 February 2002
+# Whom: Tony Maher <tonym@biolateral.com.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wise
+PORTVERSION= 2.2.0
+CATEGORIES= biology
+MASTER_SITES= ftp://ftp.sanger.ac.uk/pub/birney/wise2/
+DISTNAME= ${PORTNAME}${PORTVERSION}
+
+MAINTAINER= tonym@biolateral.com.au
+
+WRKTOP= ${WRKDIR}/${DISTNAME}
+WRKSRC= ${WRKTOP}/src
+MAKEFILE= makefile
+
+#
+# Actually want an 'ALL_TARGET = all perl' which then requires
+# 'USE_PERL5= yes' but the perl sub-build is currently broken.
+# The perl stuff is only so you can use the base libraries/functions
+# from perl scripts. This is extra, independent functionality for the
+# port and not required for the base system which are C applications.
+# When the perl part is fixed, it will require an install line
+# something like '@cd ${WRKSRC}/perl/Wise2; ${MAKE} install'
+#
+
+BINFILES= dba dnal estwise estwisedb genewise genewisedb \
+ genomewise psw pswdb
+DATAFILES= BLOSUM30.bla BLOSUM45.bla BLOSUM62.bla BLOSUM80.bla \
+ aa.rnd blosum30.bla blosum62.bla cb.tmf codon.table \
+ gene.stat gon120.bla gon160.bla gon200.bla gon250.bla \
+ gon350.bla human.gf human.gp human.stats idenity.bla \
+ methods pb.gf pombe.gf tm.pri wise.2 wise.per worm.gf
+DOCFILES= README apiend.tex appendix.tex dynamite.tex \
+ genewise21.eps genewise6.eps gettex.pl makefile \
+ wise2.tex wise2api.tex wise3arch.tex
+EXFILES= README db.hmm hn_est.fa human.genomic \
+ keratin_intron.human keratin_intron.mouse pep.fa \
+ road.pep rrm.HMM vav.dna xeno.cdna xeno.pep
+
+#
+# Top level makefile does not respect CFLAGS. Fixing it means
+# having to fix some of the sub-directory makefiles.
+# Note: some makefiles are ok and know that '-c' does not belong
+# in CFLAGS and are part of the rule.
+#
+
+post-configure:
+ @${PERL} -pi.orig \
+ -e s'#^CFLAGS = -c -O#CFLAGS ?= -c -O#;' \
+ -e s'#\tcsh welcome.csh##;' \
+ ${WRKSRC}/${MAKEFILE}
+ @${PERL} -pi.orig \
+ -e s'#CFLAGS\) $?#CFLAGS\) -c $?#;' \
+ ${WRKSRC}/base/${MAKEFILE}
+ @${PERL} -pi.orig \
+ -e s'#INCFLAGS\) $?#INCFLAGS\) -c $?#;' \
+ ${WRKSRC}/dynlibsrc/${MAKEFILE}
+ @${PERL} -pi.orig \
+ -e s'#INCFLAGS\) $?#INCFLAGS\) -c $?#;' \
+ -e s'#CFLAGS\) estwise.c#CFLAGS\) -c estwise.c#;' \
+ -e s'#CFLAGS\) estwiseb.c#CFLAGS\) -c estwiseb.c#;' \
+ -e s'#CFLAGS\) estwisedb.c#CFLAGS\) -c estwisedb.c#;' \
+ -e s'#CFLAGS\) genewise.c#CFLAGS\) -c genewise.c#;' \
+ -e s'#CFLAGS\) genewisedb.c#CFLAGS\) -c genewisedb.c#;' \
+ ${WRKSRC}/models/${MAKEFILE}
+
+do-install:
+.for file in ${BINFILES}
+ @${INSTALL_PROGRAM} ${WRKSRC}/bin/${file} ${PREFIX}/bin
+.endfor
+ @${MKDIR} ${DATADIR}
+.for file in ${DATAFILES}
+ @${INSTALL_DATA} ${WRKTOP}/wisecfg/${file} ${DATADIR}
+.endfor
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${DOCFILES}
+ @${INSTALL_DATA} ${WRKTOP}/docs/${file} ${DOCSDIR}
+.endfor
+ @${MKDIR} ${EXAMPLESDIR}
+.for file in ${EXFILES}
+ @${INSTALL_DATA} ${WRKTOP}/test_data/${file} ${EXAMPLESDIR}
+.endfor
+
+.endif
+
+post-install:
+ @${SED} -E -e 's#PREFIX#${PREFIX}#' -e '/(^\[|]$$)/d' ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/biology/wise/distinfo b/biology/wise/distinfo
new file mode 100644
index 000000000000..9f150e61108e
--- /dev/null
+++ b/biology/wise/distinfo
@@ -0,0 +1 @@
+MD5 (wise2.2.0.tar.gz) = 0584240f77885e37528e99e64535ab60
diff --git a/biology/wise/pkg-comment b/biology/wise/pkg-comment
new file mode 100644
index 000000000000..0e362eb59dd9
--- /dev/null
+++ b/biology/wise/pkg-comment
@@ -0,0 +1 @@
+Intelligent algorithms for DNA searches
diff --git a/biology/wise/pkg-descr b/biology/wise/pkg-descr
new file mode 100644
index 000000000000..1f870e431d5b
--- /dev/null
+++ b/biology/wise/pkg-descr
@@ -0,0 +1,13 @@
+"Wise2 is package that is focused on comparing DNA sequences at
+the level of its conceptual translation, regardless of sequencing
+error and introns. This really is a rewrite of the old wisetools
+package, which I wrote about 3 years ago.
+
+It can compare a single protein or a profile HMM to a genomic DNA
+sequence, and predict a gene structure. This is algorithm, called
+genewise, is one of the algorithms available in Wise2. There are
+other algorithms focused on EST data rather than genomic data, as
+well as some other algorithm curios."
+- from the web site (Ewan Birney)
+
+WWW: http://www.sanger.ac.uk/Software/Wise2
diff --git a/biology/wise/pkg-message b/biology/wise/pkg-message
new file mode 100644
index 000000000000..434ac35ab71b
--- /dev/null
+++ b/biology/wise/pkg-message
@@ -0,0 +1,15 @@
+Welcome to Wise2.2
+
+You must set your WISECONFIGDIR to the config directory before
+using the programs:
+
+in (t)csh: setenv WISECONFIGDIR PREFIX/share/wise/
+in (ba)sh: export WISECONFIGDIR=PREFIX/share/wise/
+
+To try an example:
+
+cd PREFIX/share/examples/wise
+genewise road.pep human.genomic
+
+[Replace 'PREFIX' above with the actual installation prefix,
+which by default is '/usr/local'.]
diff --git a/biology/wise/pkg-plist b/biology/wise/pkg-plist
new file mode 100644
index 000000000000..384fd64f5ab9
--- /dev/null
+++ b/biology/wise/pkg-plist
@@ -0,0 +1,60 @@
+%%PORTDOCS%%share/doc/wise/README
+%%PORTDOCS%%share/doc/wise/apiend.tex
+%%PORTDOCS%%share/doc/wise/appendix.tex
+%%PORTDOCS%%share/doc/wise/dynamite.tex
+%%PORTDOCS%%share/doc/wise/genewise21.eps
+%%PORTDOCS%%share/doc/wise/genewise6.eps
+%%PORTDOCS%%share/doc/wise/gettex.pl
+%%PORTDOCS%%share/doc/wise/makefile
+%%PORTDOCS%%share/doc/wise/wise2.tex
+%%PORTDOCS%%share/doc/wise/wise2api.tex
+%%PORTDOCS%%share/doc/wise/wise3arch.tex
+%%PORTDOCS%%share/examples/wise/README
+%%PORTDOCS%%share/examples/wise/db.hmm
+%%PORTDOCS%%share/examples/wise/hn_est.fa
+%%PORTDOCS%%share/examples/wise/human.genomic
+%%PORTDOCS%%share/examples/wise/keratin_intron.human
+%%PORTDOCS%%share/examples/wise/keratin_intron.mouse
+%%PORTDOCS%%share/examples/wise/pep.fa
+%%PORTDOCS%%share/examples/wise/road.pep
+%%PORTDOCS%%share/examples/wise/rrm.HMM
+%%PORTDOCS%%share/examples/wise/vav.dna
+%%PORTDOCS%%share/examples/wise/xeno.cdna
+%%PORTDOCS%%share/examples/wise/xeno.pep
+share/wise/BLOSUM30.bla
+share/wise/BLOSUM45.bla
+share/wise/BLOSUM62.bla
+share/wise/BLOSUM80.bla
+share/wise/aa.rnd
+share/wise/blosum30.bla
+share/wise/blosum62.bla
+share/wise/cb.tmf
+share/wise/codon.table
+share/wise/gene.stat
+share/wise/gon120.bla
+share/wise/gon160.bla
+share/wise/gon200.bla
+share/wise/gon250.bla
+share/wise/gon350.bla
+share/wise/human.gf
+share/wise/human.gp
+share/wise/human.stats
+share/wise/idenity.bla
+share/wise/methods
+share/wise/pb.gf
+share/wise/pombe.gf
+share/wise/tm.pri
+share/wise/wise.2
+share/wise/wise.per
+share/wise/worm.gf
+bin/dba
+bin/dnal
+bin/estwise
+bin/estwisedb
+bin/genewise
+bin/genewisedb
+bin/psw
+bin/pswdb
+%%PORTDOCS%%@dirrm share/doc/wise
+%%PORTDOCS%%@dirrm share/examples/wise
+@dirrm share/wise