aboutsummaryrefslogtreecommitdiff
path: root/cad/alliance
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2017-08-18 12:21:43 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2017-08-18 12:21:43 +0000
commit46c66481397d5bc47d1c94b22505de3e5ea92197 (patch)
treeea629ad4a6d9bf1cfeba04f950fdf8bb7e626efb /cad/alliance
parent7820b1f0bb4f5217878af0b6571f04a436b3a5cc (diff)
downloadports-46c66481397d5bc47d1c94b22505de3e5ea92197.tar.gz
ports-46c66481397d5bc47d1c94b22505de3e5ea92197.zip
Explicitly pass -std=gnu++03 to the compiler.
This fixes the build with GCC 6, which defaults to -std=gnu++14. The port's code does not work with C++11 or later. PR: 219275
Notes
Notes: svn path=/head/; revision=448221
Diffstat (limited to 'cad/alliance')
-rw-r--r--cad/alliance/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/cad/alliance/Makefile b/cad/alliance/Makefile
index 28e04d902d3a..bdfad7f5ea56 100644
--- a/cad/alliance/Makefile
+++ b/cad/alliance/Makefile
@@ -33,6 +33,9 @@ CONFIGURE_ENV+= ALLIANCE_TOP=${ALLIANCE_TOP}
CONFIGURE_ARGS+=--mandir=${MANPREFIX}/man \
--prefix=${ALLIANCE_TOP}
+# The port does not build with C++11 or later (bug 219275).
+USE_CXXSTD= gnu++03
+
MAKE_JOBS_UNSAFE= yes
post-patch: