aboutsummaryrefslogtreecommitdiff
path: root/cad/calculix-ccx/Makefile
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-09-30 20:44:19 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-12-31 00:37:05 +0000
commitbbab7f59e9630416397189df70ec133bdd690e38 (patch)
tree2ebb595d5a675fda686781b56ea08f80b933cb61 /cad/calculix-ccx/Makefile
parenta1bc4fbdf378334c7c39521ab236318c53f27441 (diff)
downloadports-bbab7f59e9630416397189df70ec133bdd690e38.tar.gz
ports-bbab7f59e9630416397189df70ec133bdd690e38.zip
*/*: Sunset 12.4-RELEASE/12-STABLE from ports tree
- Remove all references to defunct ARCH arm - Remove all references to defunct ARCH sparc64 - Remove x11-drivers/xf86-video-sunffb which requires defunct sparc64 ARCH - Remove sysutils/afbinit requires defunct sparc64 ARCH - Remove all references to bktr driver - Remove all references to defunct FreeBSD_12 - Remove all references to OSVERSION/OSREL corresponding to 12 - Remove conditionals in Mk/Uses/cabal.mk - Remove sparc reference from Mk/Uses/qt-dist.mk - Remove BROKEN_sparc64/NOT_FOR_ARCH=sparc64 - Remove BROKEN_FreeBSD_12* from: - Remove OpenSSL patches from: - Remove conditional flags for OSVERSION >= 1300000 to fixed flags. Also move conditional flags for non sparc64/arm ARCH to fixed flags. Reviewed by: brooks, jbeich, rene, salvadore Differential Revision: https://reviews.freebsd.org/D42068
Diffstat (limited to 'cad/calculix-ccx/Makefile')
-rw-r--r--cad/calculix-ccx/Makefile11
1 files changed, 3 insertions, 8 deletions
diff --git a/cad/calculix-ccx/Makefile b/cad/calculix-ccx/Makefile
index 7534ceac5692..031a7a842320 100644
--- a/cad/calculix-ccx/Makefile
+++ b/cad/calculix-ccx/Makefile
@@ -32,6 +32,9 @@ WRKSRC= ${WRKDIR}/CalculiX/${CCX_VER}/src
OPTIONS_DEFINE= DOCS EXAMPLES
+CFLAGS+= -fpic
+FFLAGS+= -fpic
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
@@ -44,14 +47,6 @@ DISTFILES+= ${DIST_EXAMPLES}
EXTRACT_ONLY+= ${DIST_EXAMPLES}
.endif
-.if ${ARCH} == "sparc64"
-CFLAGS+= -fPIC
-FFLAGS+= -fPIC
-.else
-CFLAGS+= -fpic
-FFLAGS+= -fpic
-.endif
-
.if ${GCC_DEFAULT} >= 10
# workaround for Missing actual argument for argument '_formal_15' at (1)
FFLAGS+= -fallow-argument-mismatch