aboutsummaryrefslogtreecommitdiff
path: root/cad/csxcad/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-08-19 00:27:24 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-08-19 01:25:38 +0000
commit72814688400e7e540398c2a2ed83f775ef545582 (patch)
tree953cf0403e44e3ddf6eaa4ae50485eda0195b246 /cad/csxcad/Makefile
parent2eb1585ce461adff906fe6263cfe2aaa345bc54c (diff)
downloadports-72814688400e7e540398c2a2ed83f775ef545582.tar.gz
ports-72814688400e7e540398c2a2ed83f775ef545582.zip
cad/csxcad: New port: C++ library to describe geometrical objects
Diffstat (limited to 'cad/csxcad/Makefile')
-rw-r--r--cad/csxcad/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/cad/csxcad/Makefile b/cad/csxcad/Makefile
new file mode 100644
index 000000000000..a4a96f5c2c21
--- /dev/null
+++ b/cad/csxcad/Makefile
@@ -0,0 +1,32 @@
+PORTNAME= csxcad
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.6.2-103
+DISTVERSIONSUFFIX= -g3c4fb66
+CATEGORIES= cad
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= C++ library to describe geometrical objects
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= cgal>0:math/cgal
+LIB_DEPENDS= libboost_system.so:devel/boost-libs \
+ libfparser-4.5.so:math/fparser \
+ libgmp.so:math/gmp \
+ libhdf5.so:science/hdf5 \
+ libmpfr.so:math/mpfr \
+ libsz.so:science/szip \
+ libtinyxml.so:textproc/tinyxml \
+ libvtkCommonMath-9.0.so:math/vtk9
+
+USES= cmake pkgconfig
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= thliebig
+GH_PROJECT= ${PORTNAME:tu}
+
+CMAKE_ARGS= -DFPARSER_ROOT_DIR=${LOCALBASE}
+
+.include <bsd.port.mk>