aboutsummaryrefslogtreecommitdiff
path: root/cad/dinotrace
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2009-01-12 10:31:44 +0000
committerStanislav Sedov <stas@FreeBSD.org>2009-01-12 10:31:44 +0000
commitce0cb11fd4c564bdfdae8b683ab2d8db86196d0b (patch)
tree102276b2008cb8f8c017ee13dfcda4b8324b3516 /cad/dinotrace
parentdc795febdac89949b1a8199248e1f5ba4c2e428e (diff)
downloadports-ce0cb11fd4c564bdfdae8b683ab2d8db86196d0b.tar.gz
ports-ce0cb11fd4c564bdfdae8b683ab2d8db86196d0b.zip
- Update to 9.3f.
- Add option for installing emacs mode files.
Notes
Notes: svn path=/head/; revision=225828
Diffstat (limited to 'cad/dinotrace')
-rw-r--r--cad/dinotrace/Makefile36
-rw-r--r--cad/dinotrace/distinfo6
-rw-r--r--cad/dinotrace/files/patch-src_dt__draw.c16
-rw-r--r--cad/dinotrace/pkg-message15
-rw-r--r--cad/dinotrace/pkg-plist10
5 files changed, 59 insertions, 24 deletions
diff --git a/cad/dinotrace/Makefile b/cad/dinotrace/Makefile
index 425fd3781339..28fc1f3fc724 100644
--- a/cad/dinotrace/Makefile
+++ b/cad/dinotrace/Makefile
@@ -6,15 +6,17 @@
#
PORTNAME= dinotrace
-DISTVERSION= 9.3b
-PORTREVISION= 2
+DISTVERSION= 9.3f
+PORTREVISION= 0
CATEGORIES= cad
-MASTER_SITES= http://www.veripool.com/ftp/
+MASTER_SITES= http://www.veripool.org/ftp/
EXTRACT_SUFX= .tgz
MAINTAINER= stas@FreeBSD.org
COMMENT= A graphical signal trace waveform viewer
+OPTIONS= EMACS "Install Emacs supplimentary files" on
+
USE_GNOME= gnometarget
GNU_CONFIGURE= yes
USE_MOTIF= yes
@@ -23,6 +25,30 @@ USE_XORG= x11 sm ice xmu xt
USE_GMAKE= yes
INFO= dinotrace
-PLIST_FILES= bin/dinotrace
-.include <bsd.port.mk>
+VERILOGEL_FILE= ${LOCALBASE}/share/verilog-mode.el/verilog-mode.el
+ELFILES= dinotrace.el sim-log.el
+EMACSLISPDIR= ${PREFIX}/share/emacs/site-lisp
+XEMACSLISPDIR= ${PREFIX}/lib/xemacs/site-lisp
+
+.include <bsd.port.pre.mk>
+.if !defined(WITHOUT_EMACS)
+RUN_DEPENDS+= ${VERILOGEL_FILE}:${PORTSDIR}/cad/verilog-mode.el
+PLIST_SUB+= EMACS=""
+.else
+PLIST_SUB+= EMACS="@comment "
+.endif
+
+post-install:
+.if !defined(WITHOUT_EMACS)
+ ${MKDIR} ${DATADIR}/
+ ${MKDIR} ${XEMACSLISPDIR}
+. for FILE in ${ELFILES}
+ ${INSTALL_DATA} ${WRKSRC}/lisp/${FILE} ${DATADIR}/
+ ${LN} -sf ${DATADIR}/${FILE} ${EMACSLISPDIR}/${FILE}
+ ${LN} -sf ${DATADIR}/${FILE} ${XEMACSLISPDIR}/${FILE}
+. endfor
+ @${CAT} ${PKGMESSAGE}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/cad/dinotrace/distinfo b/cad/dinotrace/distinfo
index d9408afa09c6..ce475eb1eb69 100644
--- a/cad/dinotrace/distinfo
+++ b/cad/dinotrace/distinfo
@@ -1,3 +1,3 @@
-MD5 (dinotrace-9.3b.tgz) = 0093c9208f551bff5c7b4803988669d0
-SHA256 (dinotrace-9.3b.tgz) = b4518bf06b3798c46151246ecc6f77c9fcc05809c5461d134d41d048c3ba0c0d
-SIZE (dinotrace-9.3b.tgz) = 561130
+MD5 (dinotrace-9.3f.tgz) = 67431b4774b76cbab86aced0b251b387
+SHA256 (dinotrace-9.3f.tgz) = ff312b240858e0544a9241be554d5bd98d1b80db68d8549107991131c1d934d9
+SIZE (dinotrace-9.3f.tgz) = 758390
diff --git a/cad/dinotrace/files/patch-src_dt__draw.c b/cad/dinotrace/files/patch-src_dt__draw.c
deleted file mode 100644
index 5ccff1a72aa6..000000000000
--- a/cad/dinotrace/files/patch-src_dt__draw.c
+++ /dev/null
@@ -1,16 +0,0 @@
-
-$FreeBSD$
-
---- src/dt_draw.c.orig Sun Aug 22 22:14:43 2004
-+++ src/dt_draw.c Sun Aug 22 22:18:04 2004
-@@ -542,7 +542,9 @@
- case STATE_Z: dr_mask |= DR_Z; break;
- default: dr_mask |= DR_LOW | DR_HIGH; break;
- }
-- color_value = MAX(color_value, nptr->siglw.stbits.color);
-+ if (color_value > nptr->siglw.stbits.color);
-+ color_value = nptr->siglw.stbits.color;
-+
- xright = MAX(xright, TIME_TO_XPOS (CPTR_TIME(nnptr)));
- nptr = nnptr;
- }
diff --git a/cad/dinotrace/pkg-message b/cad/dinotrace/pkg-message
new file mode 100644
index 000000000000..78d78be63f00
--- /dev/null
+++ b/cad/dinotrace/pkg-message
@@ -0,0 +1,15 @@
+====
+To activate dinotrace Emacs extensions add the following lines
+to your Emacs configuration file (usually ~/.emacs):
+
+;; Dinotrace mode
+(autoload 'dinotrace-update "dinotrace" "Update dinotrace annotations in this buffer" t)
+(autoload 'dinotrace-mode "dinotrace" "Toggle dinotrace annotations in this buffer" t)
+(global-set-key "\C-x\C-aa" 'dinotrace-update)
+(global-set-key "\C-x\C-ad" 'dinotrace-mode)
+
+;; Sim-Log mode
+(autoload 'sim-log-mode "sim-log" "Mode for Simulation Log files." t)
+(setq auto-mode-alist (append (list '("\\.log$" . sim-log-mode)) auto-mode-alist))
+
+====
diff --git a/cad/dinotrace/pkg-plist b/cad/dinotrace/pkg-plist
new file mode 100644
index 000000000000..222611c71ff8
--- /dev/null
+++ b/cad/dinotrace/pkg-plist
@@ -0,0 +1,10 @@
+bin/dinotrace
+%%EMACS%%%%DATADIR%%/dinotrace.el
+%%EMACS%%%%DATADIR%%/sim-log.el
+%%EMACS%%share/emacs/site-lisp/dinotrace.el
+%%EMACS%%share/emacs/site-lisp/sim-log.el
+%%EMACS%%lib/xemacs/site-lisp/dinotrace.el
+%%EMACS%%lib/xemacs/site-lisp/sim-log.el
+%%EMACS%%@dirrmtry lib/xemacs/site-lisp
+%%EMACS%%@dirrmtry lib/xemacs
+%%EMACS%%@dirrm %%DATADIR%%