aboutsummaryrefslogtreecommitdiff
path: root/cad/freehdl/Makefile
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-11-05 20:51:06 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-11-05 20:51:06 +0000
commit1c4c351b418524d8a77ce5dd2aeea213299911dd (patch)
treec26141b62a34e7736a3123ae97f4f7a27f781a2d /cad/freehdl/Makefile
parent5bdb805f911cd163a514d6733907238ecd4b9edc (diff)
downloadports-1c4c351b418524d8a77ce5dd2aeea213299911dd.tar.gz
ports-1c4c351b418524d8a77ce5dd2aeea213299911dd.zip
The goals of the FreeHDL project are to develop a VHDL simulator that has
a graphical waveform viewer and a source level debugger. It also aims at VHDL-93 compliancy. The project is at a very early development stage. WWW: http://www.freehdl.seul.org/ PR: ports/104634 Submitted by: lon_kamikaze at gmx.de
Notes
Notes: svn path=/head/; revision=176541
Diffstat (limited to 'cad/freehdl/Makefile')
-rw-r--r--cad/freehdl/Makefile53
1 files changed, 53 insertions, 0 deletions
diff --git a/cad/freehdl/Makefile b/cad/freehdl/Makefile
new file mode 100644
index 000000000000..49315ae1a392
--- /dev/null
+++ b/cad/freehdl/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: freehdl
+# Date created: 19 Oct 2006
+# Whom: lon_kamikaze@gmx.de
+#
+# $FreeBSD$
+#
+
+PORTNAME= freehdl
+PORTVERSION= 0.0.3
+CATEGORIES= cad
+MASTER_SITES= http://cran.mit.edu/~enaroska/
+
+MAINTAINER= lon_kamikaze@gmx.de
+COMMENT= A free VHDL simulator
+
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+USE_PERL5= yes
+USE_XLIB= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --x-libraries=${X11BASE}/lib \
+ --prefix=${PREFIX}
+
+MAN1= freehdl-config.1 \
+ freehdl-gennodes.1 \
+ freehdl-libtool.1 \
+ freehdl-v2cc.1 \
+ gvhdl.1
+MAN5= v2cc.libs.5
+
+INFO= fire
+
+MANCOMPRESSED= no
+
+PLIST_TMP= ${WRKDIR}/plist_tmp/
+
+plist: build
+ @${ECHO} "===> Rebuilding PLIST."
+ @${TOUCH} ${PLIST}
+ @${RM} ${PLIST}
+ @cd ${INSTALL_WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} \
+ ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} \
+ prefix=${PLIST_TMP} ${INSTALL_TARGET}
+ @${RM} -rf ${PLIST_TMP}/man
+ @${FIND} -d ${PLIST_TMP} -type f \
+ | ${SED} "s|${PLIST_TMP}||1" \
+ >> ${PLIST}
+ @${FIND} -d ${PLIST_TMP}/*/* -type d \
+ | ${SED} "s|${PLIST_TMP}|@dirrm |1" \
+ >> ${PLIST}
+ @${RM} -rf ${PLIST_TMP}
+
+.include <bsd.port.mk>