aboutsummaryrefslogtreecommitdiff
path: root/cad/freehdl/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2015-06-20 16:40:11 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2015-06-20 16:40:11 +0000
commit3db887160e1b26e6f7872fe67e71321124c38c32 (patch)
tree86de3feea888d37d57c3edbecb965e3a785efb22 /cad/freehdl/Makefile
parent3056e959dcde6f59c6784823102679e604eb8078 (diff)
downloadports-3db887160e1b26e6f7872fe67e71321124c38c32.tar.gz
ports-3db887160e1b26e6f7872fe67e71321124c38c32.zip
Remove plist generator (we now have make makeplist and make check-plist)
This plist generator was pulling deprecated syntaxes
Notes
Notes: svn path=/head/; revision=390168
Diffstat (limited to 'cad/freehdl/Makefile')
-rw-r--r--cad/freehdl/Makefile28
1 files changed, 0 insertions, 28 deletions
diff --git a/cad/freehdl/Makefile b/cad/freehdl/Makefile
index de274d39c62f..58525f17d4fe 100644
--- a/cad/freehdl/Makefile
+++ b/cad/freehdl/Makefile
@@ -19,32 +19,4 @@ INSTALL_TARGET= install-strip
INFO= fire
-PLIST_TMP= ${WRKDIR}/plist_tmp/
-
-PLIST_REPL= ${SED} "s|share/${PORTNAME}|%%DATADIR%%|1"
-
-plist: build
- @${ECHO} "===> Rebuilding PLIST."
- @${TOUCH} ${PLIST}
- @${RM} ${PLIST}
- @cd ${INSTALL_WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} \
- ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} \
- prefix=${PLIST_TMP} \
- mandir=${PLIST_TMP}/man \
- infodir=${PLIST_TMP}/info \
- ${INSTALL_TARGET}
- @${RM} -rf ${PLIST_TMP}/man ${PLIST_TMP}/info
- @${FIND} -d ${PLIST_TMP} -not -type d \
- | ${SED} "s|${PLIST_TMP}||1" \
- | ${PLIST_REPL} >> ${PLIST}
- @${FIND} -d ${PLIST_TMP} -type d -mindepth 2 \
- | ${SED} "s|${PLIST_TMP}|@dirrm |1" \
- | ${PLIST_REPL} \
- | ${GREP} -E '%%DATADIR%%|freehdl' >> ${PLIST}
- @${FIND} -d ${PLIST_TMP} -type d -mindepth 2 \
- | ${SED} "s|${PLIST_TMP}|@dirrmtry |1" \
- | ${PLIST_REPL} \
- | ${GREP} -vE '%%DATADIR%%|freehdl' >> ${PLIST}
- @${RM} -rf ${PLIST_TMP}
-
.include <bsd.port.mk>