aboutsummaryrefslogtreecommitdiff
path: root/cad/freehdl/Makefile
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-11-12 21:50:10 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-11-12 21:50:10 +0000
commitc0138bba1fa1079398c4747f4f9c01e1c0f69de7 (patch)
treee9ee34363d10a8eccf72ad36eddac34b1477e90f /cad/freehdl/Makefile
parent23a6236456f18910fd8a5e38d2ad5e5ab5aba11e (diff)
downloadports-c0138bba1fa1079398c4747f4f9c01e1c0f69de7.tar.gz
ports-c0138bba1fa1079398c4747f4f9c01e1c0f69de7.zip
Fix the plist target.
PR: 105454 Submitted by: Dominic Fandrey (maintainer)
Notes
Notes: svn path=/head/; revision=177139
Diffstat (limited to 'cad/freehdl/Makefile')
-rw-r--r--cad/freehdl/Makefile20
1 files changed, 14 insertions, 6 deletions
diff --git a/cad/freehdl/Makefile b/cad/freehdl/Makefile
index 49315ae1a392..4e26f99f3604 100644
--- a/cad/freehdl/Makefile
+++ b/cad/freehdl/Makefile
@@ -34,6 +34,8 @@ MANCOMPRESSED= no
PLIST_TMP= ${WRKDIR}/plist_tmp/
+PLIST_REPL= ${SED} "s|share/${PORTNAME}|%%DATADIR%%|1"
+
plist: build
@${ECHO} "===> Rebuilding PLIST."
@${TOUCH} ${PLIST}
@@ -41,13 +43,19 @@ plist: build
@cd ${INSTALL_WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} \
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} \
prefix=${PLIST_TMP} ${INSTALL_TARGET}
- @${RM} -rf ${PLIST_TMP}/man
- @${FIND} -d ${PLIST_TMP} -type f \
+ @${RM} -rf ${PLIST_TMP}/man ${PLIST_TMP}/info
+ @${FIND} -d ${PLIST_TMP} -not -type d \
| ${SED} "s|${PLIST_TMP}||1" \
- >> ${PLIST}
- @${FIND} -d ${PLIST_TMP}/*/* -type d \
+ | ${PLIST_REPL} >> ${PLIST}
+ @${FIND} -d ${PLIST_TMP} -type d -mindepth 2 \
| ${SED} "s|${PLIST_TMP}|@dirrm |1" \
- >> ${PLIST}
+ | ${PLIST_REPL} >> ${PLIST}
@${RM} -rf ${PLIST_TMP}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= doesn't link
+.endif
+
+.include <bsd.port.post.mk>