aboutsummaryrefslogtreecommitdiff
path: root/cad/gmsh
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2016-09-29 19:15:34 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2016-09-29 19:15:34 +0000
commit230bad277622d3d571015c81de28507ea89b1a3a (patch)
tree6bc721918ac1fc01a4fcc9d0a3a05f9b45088b4a /cad/gmsh
parent82469f9390fa32830590e41b59e88c8c7dae9137 (diff)
downloadports-230bad277622d3d571015c81de28507ea89b1a3a.tar.gz
ports-230bad277622d3d571015c81de28507ea89b1a3a.zip
Update cad/gmsh to 2.13.2; fix knob issue; other changes
- Upgrade to version 2.13.2 - Update MASTER_SITES to only include new gmsh site - Remove no-longer-needed definitions of DISTFILES, EXTRACT_ONLY, and WRKSRC - The licensing situation is simpler now: Gmsh itself is released under GPLv3+ [1], TetGen under AGPLv3+ [2], and METIS under an APACHE2 license [3] For now, TAUCS is the only component released under a non-standard license [4] - Fix misnamed KNOB in KNOB_DESC=, so `make config` shows descriptions - Fix errors/warnings reported by portlint and poudriere testport - Add missing entries to LIB_DEPENDS= - Add blaslapack to USES= - Change USE_GL=yes to USE_GL=gl glu - Add USE_XORG=x11 xext xfixes xft - Redo patches with make makepatch - Remove MAKE_JOBS_UNSAFE=yes - Remove options for bundled software - Update default options - Add patch to fix TAUCS linking error - Modernize option handling - Mark broken on FreeBSD 12 i386 due to clang bug: (https://llvm.org/bugs/show_bug.cgi?id=21903) - Remove unnecessary TAUCS_LIB_DEPENDS=libtaucs.so:math/taucs to prevent problems with french/aster - cad/gmsh includes a bundled taucs, so TAUCS_LIB_DEPENDS=libtaucs.so:math/taucs can be removed - math/taucs pulls in math/metis4, but french/aster, which depends on cad/gmsh, pulls in conflicting math/taucs-edf - Update pkg-plist [1] http://gmsh.info/#Licensing [2] http://wias-berlin.de/software/tetgen/1.5/FAQ-license.html [3] http://glaros.dtc.umn.edu/gkhome/metis/metis/faq?q=metis/metis/faq#cite [4] http://www.tau.ac.il/~stoledo/taucs/ PR: 212398 Reviewed by: swills (mentor) AMDmi3 (mentor) Approved by: swills (mentor) Differential Revision: https://reviews.freebsd.org/D7703
Notes
Notes: svn path=/head/; revision=422939
Diffstat (limited to 'cad/gmsh')
-rw-r--r--cad/gmsh/Makefile160
-rw-r--r--cad/gmsh/distinfo5
-rw-r--r--cad/gmsh/files/patch-Fltk_Main.cpp (renamed from cad/gmsh/files/patch-Fltk-Main.cpp)4
-rw-r--r--cad/gmsh/files/patch-Geo_CustomContainer.h (renamed from cad/gmsh/files/patch-Geo__CustomContainer.h)6
-rw-r--r--cad/gmsh/files/patch-contrib_taucs_config_taucs__config__build.h10
-rw-r--r--cad/gmsh/pkg-descr19
-rw-r--r--cad/gmsh/pkg-plist318
7 files changed, 229 insertions, 293 deletions
diff --git a/cad/gmsh/Makefile b/cad/gmsh/Makefile
index d60e7b9a5c45..0aeda9168f85 100644
--- a/cad/gmsh/Makefile
+++ b/cad/gmsh/Makefile
@@ -2,143 +2,73 @@
# $FreeBSD$
PORTNAME= gmsh
-PORTVERSION= 2.12.0
-PORTREVISION?= 1
+PORTVERSION= 2.13.2
CATEGORIES= cad
-MASTER_SITES= http://www.geuz.org/gmsh/src/ \
- http://glaros.dtc.umn.edu/gkhome/fetch/sw/metis/
+MASTER_SITES= http://gmsh.info/src/
DISTNAME= ${PORTNAME}-${PORTVERSION}-source
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
DIST_SUBDIR= gmsh
-EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
-MAINTAINER?= jrm@ftfl.ca
+MAINTAINER?= jrm@FreeBSD.org
COMMENT?= Automatic 3D finite element mesh generator
+LICENSE= AGPLv3+ APACHE20 GPLv3+ GPLv2+ LGPL21
+LICENSE_COMB= multi
+
LIB_DEPENDS= libfltk.so:x11-toolkits/fltk \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libgmp.so:math/gmp \
+ libhdf5.so:science/hdf5 \
libpng.so:graphics/png \
- liblapack.so:math/lapack
+ libsz.so:science/szip
RUN_DEPENDS= getdp:science/getdp
-BROKEN_powerpc64= Does not build on powerpc64
-
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-source
+BROKEN_powerpc64=Does not build on powerpc64
+BROKEN_FreeBSD_12_i386=Does not build on FreeBSD 12 i386 due to a clang bug: https://llvm.org/bugs/show_bug.cgi?id=21903
SLAVEDIRS= cad/gmsh-occ
-USES= cmake compiler:c++11-lib fortran gmake jpeg tar:tgz
-USE_GL= yes
-ALL_TARGET= all
+USES= blaslapack cmake fortran gmake jpeg tar:tgz
+USE_GL= gl glu
+USE_XORG= x11 xext xfixes xft
-MAKE_JOBS_UNSAFE= yes
+CMAKE_ARGS= -DCMAKE_SKIP_RPATH:BOOL=YES
-CMAKE_ARGS+= -DCMAKE_SKIP_RPATH:BOOL=YES
+OPTIONS_DEFINE= CGNS MED OCC SHARED STATIC
+OPTIONS_DEFAULT=MED
-OPTIONS_DEFINE= STATIC_LIB SHARED_LIB TETGEN METIS TAUCS MED CGNS GMM OCC
-OPTIONS_DEFAULT= STATIC_LIB SHARED_LIB TETGEN METIS MED CGNS GMM
+CGNS_DESC= Enable experimental CGNS mesh support
+MED_DESC= Enable MED mesh and post file formats
+OCC_DESC= Enable Open CASCADE geometrical models
+SHARED_DESC= Build shared library and install header files
+STATIC_DESC= Build static library
-STATIC_LIB_DESC= Build static library
-SHARED_LIB_DESC= Build shared library
-TETGEN_LIB_DESC= Enable tetgen as an alternative 3D mesh generator
-METIS_LIB_DESC= Enable metis as an alternative 3D mesh generator
-TAUCS_LIB_DESC= Enable the Taucs linear algebra solver
-MED_LIB_DESC= Enable MED support
-CGNS_LIB_DESC= Enable CGNS support
-GMM_LIB_DESC= Enable gmm++ support
-OCC_LIB_DESC= Enable STEP, IGES and BREP support
+OPTIONS_SUB= yes
+PLIST_SUB= VER=${PORTVERSION} VE=${PORTVERSION:R}
-OPTIONS_SUB= yes
+# TODO
+# Dependencies against PythonLibs, swig and petsc are found and registered if
+# installed
+# => add knobs to handle them.
-STATIC_LIB_CMAKE_ON= -DENABLE_BUILD_LIB=ON
-STATIC_LIB_ALL_TARGET= lib
-SHARED_LIB_CMAKE_ON= -DENABLE_BUILD_SHARED=ON
-SHARED_LIB_ALL_TARGET= shared
-SHARED_LIB_VARS= use_ldconfig=yes
-PLIST_SUB+= SHARED_LIB="" VER=${PORTVERSION} VE=${PORTVERSION:R}
-DOCS_CMAKE_OFF= -DINSTALL_DOCS=OFF
-TETGEN_CMAKE_ON= -DENABLE_TETGEN=ON
-TETGEN_CMAKE_OFF= -DENABLE_TETGEN=OFF
-TETGEN_VARS= "no_cdrom=Contact appropriate authors for commercial purposes if including Tetgen or Metis"
-METIS_CMAKE_ON= -DENABLE_METIS=ON
-METIS_CMAKE_OFF= -DENABLE_METIS=OFF
-METIS_VARS= "no_cdrom=Contact appropriate authors for commercial purposes if including Tetgen or Metis"
-METIS_VARS= distfiles+=manual.pdf
-TAUCS_LIB_DEPENDS= libtaucs.so:math/taucs
-TAUCS_CMAKE_ON= -DENABLE_TAUCS=ON
-TAUCS_CMAKE_OFF= -DENABLE_TAUCS=OFF
-MED_LIB_DEPENDS= libmed.so:french/med
-MED_CMAKE_ON= -DENABLE_MED=ON
-MED_CMAKE_OFF= -DENABLE_MED=OFF
+CGNS_CMAKE_BOOL= ENABLE_CGNS
CGNS_LIB_DEPENDS= libcgns.so:science/cgnslib
-CGNS_CMAKE_ON= -DENABLE_CGNS=ON
-CGNS_CMAKE_OFF= -DENABLE_CGNS=OFF
-GMM_CMAKE_OFF= -DENABLE_GMM=OFF
-OCC_LIB_DEPENDS= libTKernel.so:cad/opencascade
-OCC_CMAKE_ON= -DENABLE_OCC=ON -DOCC_INC=${LOCALBASE}/include/OpenCASCADE
+DOCS_CMAKE_BOOL= INSTALL_DOCS
+MED_CMAKE_BOOL= ENABLE_MED
+MED_LIB_DEPENDS= libmed.so:french/med
OCC_CFLAGS= -DHAVE_CONFIG_H -DHAVE_WOK_CONFIG_H -DFREEBSD
+OCC_CMAKE_BOOL= ENABLE_OCC
+OCC_CMAKE_ON= -DOCC_INC=${LOCALBASE}/include/OpenCASCADE
OCC_CONFLICTS= gmsh-2.*
-OCC_CMAKE_OFF= -DENABLE_OCC=OFF
OCC_CONFLICTS_OFF= gmsh-occ-2.*
+OCC_LIB_DEPENDS= libTKernel.so:cad/opencascade
+SHARED_ALL_TARGET= shared
+SHARED_CMAKE_BOOL= ENABLE_BUILD_SHARED
+SHARED_VARS= USE_LDCONFIG=yes
+STATIC_ALL_TARGET= lib
+STATIC_CMAKE_BOOL= ENABLE_BUILD_LIB
-.include <bsd.port.options.mk>
-
-# Even though the taucs port pulls in the metis port, we will still need
-# METIS set when TAUCS is set, otherwise the linker does not find the
-# libraries installed by the metis port.
-.if ${PORT_OPTIONS:MTAUCS} && !${PORT_OPTIONS:MMETIS}
-IGNORE= METIS must be set if TAUCS is set
-.endif
-
-.if !${PORT_OPTIONS:MMETIS} && ${PORT_OPTIONS:MDOCS}
-IGNORE= the license for Metis requires that its documentation is included
-.endif
-
-.if ${PORT_OPTIONS:MOCC}
-. if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1200000
-BROKEN_i386= Bad machine code: Using an undefined physical register
-. endif
-.endif
-
-# TODO
-# Dependencies against PythonLibs, swig and petsc are found and registered if installed
-# => add knobs to handle them.
-
-PKGMESSAGE= ${WRKDIR}/pkg-message
-
-.include <bsd.port.pre.mk>
-
-post-extract:
- ${CP} ${DISTDIR}/${DIST_SUBDIR}/manual.pdf ${WRKDIR}
- ${TOUCH} ${PKGMESSAGE}
-.if ${PORT_OPTIONS:MTETGEN}
- @${ECHO} >> ${PKGMESSAGE}
- @${ECHO} "The FreeBSD project has been granted redistribution rights" >> ${PKGMESSAGE}
- @${ECHO} "but anyone attempting to redistribute Gmsh with Tetgen" >> ${PKGMESSAGE}
- @${ECHO} "for strict commercial purposes must still contact the author" >> ${PKGMESSAGE}
- @${ECHO} "(Hang Si) and license the code." >> ${PKGMESSAGE}
-.endif
-.if ${PORT_OPTIONS:MMETIS}
- @${ECHO} >> ${PKGMESSAGE}
- @${ECHO} "The FreeBSD project has been granted redistribution rights" >> ${PKGMESSAGE}
- @${ECHO} "but anyone attempting to redistribute Gmsh with Metis" >> ${PKGMESSAGE}
- @${ECHO} "must still contact the author" >> ${PKGMESSAGE}
- @${ECHO} "http://glaros.dtc.umn.edu/gkhome/metis/metis/faq?q=metis/metis/faq#distribute" >> ${PKGMESSAGE}
- @${ECHO} "\"A Fast and Highly Quality Multilevel Scheme for Partitioning Irregular Graphs\". George Karypis and Vipin Kumar. SIAM Journal on Scientific Computing, Vol. 20, No. 1, pp. 359-392, 1999." >> ${PKGMESSAGE}
-.endif
-.if ${PORT_OPTIONS:MTAUCS}
- @${ECHO} >> ${PKGMESSAGE}
- @${ECHO} "There might be licensing issues with using Taucs with Gmsh" >> ${PKGMESSAGE}
- @${ECHO} "because Taucs requires Metis." >> ${PKGMESSAGE}
-.endif
-
-pre-configure:
- ${REINPLACE_CMD} -e s+share/doc/gmsh+${DOCSDIR_REL}+ \
- -e s+share/man/man1+man/man1+ ${WRKSRC}/CMakeLists.txt
-
-post-install:
-.if ${PORT_OPTIONS:MMETIS}
- ${MKDIR} ${STAGEDIR}${DOCSDIR}/metis
- ${INSTALL_DATA} ${WRKDIR}/manual.pdf ${STAGEDIR}${DOCSDIR}/metis
-.endif
+post-patch:
+ @${REINPLACE_CMD} -e "s|share/doc/gmsh|${DOCSDIR_REL}|" \
+ -e 's|share/man/man1|man/man1|' ${WRKSRC}/CMakeLists.txt
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/cad/gmsh/distinfo b/cad/gmsh/distinfo
index 6e8de841b988..37f19eb70c32 100644
--- a/cad/gmsh/distinfo
+++ b/cad/gmsh/distinfo
@@ -1,4 +1,5 @@
-SHA256 (gmsh/gmsh-2.12.0-source.tgz) = 7fbd2ec8071e79725266e72744d21e902d4fe6fa9e7c52340ad5f4be5c159d09
-SIZE (gmsh/gmsh-2.12.0-source.tgz) = 11618737
+TIMESTAMP = 1472424237
+SHA256 (gmsh/gmsh-2.13.2-source.tgz) = d68e1569f7ccf61cfd70d6845defe8dd73676745beafcf1de60ba9874ad15f26
+SIZE (gmsh/gmsh-2.13.2-source.tgz) = 11415014
SHA256 (gmsh/manual.pdf) = 8a682ee7f02380f52d5efdde5f9f9d8e927a4f4eb29287a878c1016225568911
SIZE (gmsh/manual.pdf) = 206713
diff --git a/cad/gmsh/files/patch-Fltk-Main.cpp b/cad/gmsh/files/patch-Fltk_Main.cpp
index d5ec754d8136..71a92f3ed4bd 100644
--- a/cad/gmsh/files/patch-Fltk-Main.cpp
+++ b/cad/gmsh/files/patch-Fltk_Main.cpp
@@ -1,8 +1,8 @@
---- Fltk/Main.cpp.orig
+--- Fltk/Main.cpp.orig 2016-08-28 23:27:04 UTC
+++ Fltk/Main.cpp
@@ -3,7 +3,7 @@
// See the LICENSE.txt file for license information. Please report all
- // bugs and problems to the public mailing list <gmsh@geuz.org>.
+ // bugs and problems to the public mailing list <gmsh@onelab.info>.
-#include <stdlib.h>
+#include <cstdlib>
diff --git a/cad/gmsh/files/patch-Geo__CustomContainer.h b/cad/gmsh/files/patch-Geo_CustomContainer.h
index c4538ad6980d..a2d5884b7e95 100644
--- a/cad/gmsh/files/patch-Geo__CustomContainer.h
+++ b/cad/gmsh/files/patch-Geo_CustomContainer.h
@@ -1,5 +1,5 @@
---- Geo/CustomContainer.h.orig 2010-10-15 09:35:00.000000000 -0400
-+++ Geo/CustomContainer.h 2011-08-09 05:12:35.000000000 -0400
+--- Geo/CustomContainer.h.orig 2016-08-28 23:25:55 UTC
++++ Geo/CustomContainer.h
@@ -8,6 +8,7 @@
#ifndef _CUSTOMCONTAINER_H_
#define _CUSTOMCONTAINER_H_
@@ -7,4 +7,4 @@
+#include <cstddef>
#include <cstdlib>
#include <cstring>
-
+ #include <cstddef>
diff --git a/cad/gmsh/files/patch-contrib_taucs_config_taucs__config__build.h b/cad/gmsh/files/patch-contrib_taucs_config_taucs__config__build.h
new file mode 100644
index 000000000000..424a7cf222ae
--- /dev/null
+++ b/cad/gmsh/files/patch-contrib_taucs_config_taucs__config__build.h
@@ -0,0 +1,10 @@
+--- contrib/taucs/config/taucs_config_build.h.orig 2016-09-28 15:41:06 UTC
++++ contrib/taucs/config/taucs_config_build.h
+@@ -3,7 +3,6 @@
+ #define TAUCS_CONFIG_DCOMPLEX
+ #define TAUCS_CONFIG_SCOMPLEX
+ #define TAUCS_CONFIG_GENERIC_COMPLEX
+-#define TAUCS_CONFIG_TIMING
+ #define TAUCS_CONFIG_BASE
+ #define TAUCS_CONFIG_MATRIX_IO
+ #define TAUCS_CONFIG_METIS
diff --git a/cad/gmsh/pkg-descr b/cad/gmsh/pkg-descr
index 2f747fce87ee..a98ebee9f0a2 100644
--- a/cad/gmsh/pkg-descr
+++ b/cad/gmsh/pkg-descr
@@ -1,14 +1,9 @@
-Gmsh is an automatic 3D finite element mesh generator (primarily
-Delaunay) with build-in CAD and post-processing facilities. Its primal
-design goal is to provide a simple meshing tool for academic test cases
-with parametric input and up to date visualization capabilities. One of
-its strengths is the ability to respect a characteristic length field for
-the generation of adapted meshes on lines, surfaces and volumes, and to
-mix these meshes with simple structured grids.
-
-Gmsh is built around four modules: geometry, mesh, solver and
-post-processing. The specification of any input to these modules is done
-either interactively using the graphical user interface or in ASCII text
-files using Gmsh's own scripting language.
+Gmsh is a free 3D finite element grid generator with a build-in CAD engine and
+post-processor. Its design goal is to provide a fast, light and user-friendly
+meshing tool with parametric input and advanced visualization capabilities. Gmsh
+is built around four modules: geometry, mesh, solver and post-processing. The
+specification of any input to these modules is done either interactively using
+the graphical user interface or in ASCII text files using Gmsh's own scripting
+language.
WWW: http://www.geuz.org/gmsh/
diff --git a/cad/gmsh/pkg-plist b/cad/gmsh/pkg-plist
index 2d3ac4f157f4..e7bb976efdae 100644
--- a/cad/gmsh/pkg-plist
+++ b/cad/gmsh/pkg-plist
@@ -1,163 +1,163 @@
bin/gmsh
bin/onelab.py
-%%STATIC_LIB%%lib/libGmsh.a
-%%SHARED_LIB%%lib/libGmsh.so
-%%SHARED_LIB%%lib/libGmsh.so.%%VE%%
-%%SHARED_LIB%%lib/libGmsh.so.%%VER%%
-include/gmsh/BasisFactory.h
-include/gmsh/CADDistances.h
-include/gmsh/CGNSOptions.h
-include/gmsh/Cell.h
-include/gmsh/CellComplex.h
-include/gmsh/Chain.h
-include/gmsh/ChainComplex.h
-include/gmsh/ColorTable.h
-include/gmsh/CondNumBasis.h
-include/gmsh/Context.h
-include/gmsh/ElementType.h
-include/gmsh/FuncSpaceData.h
-include/gmsh/GEdge.h
-include/gmsh/GEdgeCompound.h
-include/gmsh/GEdgeLoop.h
-include/gmsh/GEntity.h
-include/gmsh/GFace.h
-include/gmsh/GFaceCompound.h
-include/gmsh/GModel.h
-include/gmsh/GPoint.h
-include/gmsh/GRbf.h
-include/gmsh/GRegion.h
-include/gmsh/GRegionCompound.h
-include/gmsh/GVertex.h
-include/gmsh/GaussIntegration.h
-include/gmsh/GenericEdge.h
-include/gmsh/GenericFace.h
-include/gmsh/GenericRegion.h
-include/gmsh/GenericVertex.h
-include/gmsh/Gmsh.h
-include/gmsh/GmshConfig.h
-include/gmsh/GmshDefines.h
-include/gmsh/GmshMessage.h
-include/gmsh/GmshSocket.h
-include/gmsh/GmshVersion.h
-include/gmsh/Homology.h
-include/gmsh/Integration3D.h
-include/gmsh/JacobianBasis.h
-include/gmsh/Levy3D.h
-include/gmsh/MEdge.h
-include/gmsh/MElement.h
-include/gmsh/MElementCut.h
-include/gmsh/MElementOctree.h
-include/gmsh/MFace.h
-include/gmsh/MHexahedron.h
-include/gmsh/MLine.h
-include/gmsh/MPoint.h
-include/gmsh/MPrism.h
-include/gmsh/MPyramid.h
-include/gmsh/MQuadrangle.h
-include/gmsh/MTetrahedron.h
-include/gmsh/MTriangle.h
-include/gmsh/MTrihedron.h
-include/gmsh/MVertex.h
-include/gmsh/MVertexBoundaryLayerData.h
-include/gmsh/MeshOpt.h
-include/gmsh/MeshOptCommon.h
-include/gmsh/MeshOptObjContrib.h
-include/gmsh/MeshOptObjContribFunc.h
-include/gmsh/MeshOptObjContribScaledNodeDispSq.h
-include/gmsh/MeshOptObjectiveFunction.h
-include/gmsh/MeshOptPatch.h
-include/gmsh/MeshOptVertexCoord.h
-include/gmsh/MeshOptimizer.h
-include/gmsh/MeshQualityObjContribIdealJac.h
-include/gmsh/MeshQualityObjContribInvCond.h
-include/gmsh/MeshQualityOptimizer.h
-include/gmsh/MetricBasis.h
-include/gmsh/Numeric.h
-include/gmsh/OS.h
-include/gmsh/Octree.h
-include/gmsh/OctreeInternals.h
-include/gmsh/OctreePost.h
-include/gmsh/OpenFile.h
-include/gmsh/OptHOM.h
-include/gmsh/OptHomFastCurving.h
-include/gmsh/OptHomMesh.h
-include/gmsh/OptHomIntegralBoundaryDist.h
-include/gmsh/OptHomObjContribCADDist.h
-include/gmsh/OptHomObjContribMetricMin.h
-include/gmsh/OptHomObjContribScaledJac.h
-include/gmsh/OptHomRun.h
-include/gmsh/Options.h
-include/gmsh/PView.h
-include/gmsh/PViewData.h
-include/gmsh/PViewDataGModel.h
-include/gmsh/PViewDataList.h
-include/gmsh/PViewOptions.h
-include/gmsh/Pair.h
-include/gmsh/ParamCoord.h
-include/gmsh/PluginManager.h
-include/gmsh/Range.h
-include/gmsh/SBoundingBox3d.h
-include/gmsh/SOrientedBoundingBox.h
-include/gmsh/SPoint2.h
-include/gmsh/SPoint3.h
-include/gmsh/STensor3.h
-include/gmsh/SVector3.h
-include/gmsh/StringUtils.h
-include/gmsh/SuperEl.h
-include/gmsh/ThinLayer.h
-include/gmsh/VertexArray.h
-include/gmsh/Voronoi3D.h
-include/gmsh/adaptiveData.h
-include/gmsh/bezierBasis.h
-include/gmsh/boundaryLayersData.h
-include/gmsh/cartesian.h
-include/gmsh/crossConfTerm.h
-include/gmsh/directions3D.h
-include/gmsh/discreteEdge.h
-include/gmsh/discreteFace.h
-include/gmsh/discreteRegion.h
-include/gmsh/discreteVertex.h
-include/gmsh/dofManager.h
-include/gmsh/drawContext.h
-include/gmsh/elasticitySolver.h
-include/gmsh/elasticityTerm.h
-include/gmsh/femTerm.h
-include/gmsh/fullMatrix.h
-include/gmsh/gmp_blas.h
-include/gmsh/gmp_matrix.h
-include/gmsh/gmp_normal_form.h
-include/gmsh/gmshLevelset.h
-include/gmsh/groupOfElements.h
-include/gmsh/laplaceTerm.h
-include/gmsh/linearSystem.h
-include/gmsh/linearSystemCSR.h
-include/gmsh/linearSystemFull.h
-include/gmsh/linearSystemGMM.h
-include/gmsh/linearSystemMUMPS.h
-include/gmsh/linearSystemPETSc.h
-include/gmsh/mathEvaluator.h
-include/gmsh/mathex.h
-include/gmsh/meshGEdge.h
-include/gmsh/meshGFace.h
-include/gmsh/meshGFaceDelaunayInsertion.h
-include/gmsh/meshGFaceElliptic.h
-include/gmsh/meshGFaceOptimize.h
-include/gmsh/meshMetric.h
-include/gmsh/meshPartition.h
-include/gmsh/meshPartitionOptions.h
-include/gmsh/mpz.h
-include/gmsh/nodalBasis.h
-include/gmsh/onelab.h
-include/gmsh/onelabUtils.h
-include/gmsh/orthogonalTerm.h
-include/gmsh/partitionEdge.h
-include/gmsh/periodical.h
-include/gmsh/polynomialBasis.h
-include/gmsh/simple3D.h
-include/gmsh/simpleFunction.h
-include/gmsh/sparsityPattern.h
-include/gmsh/thermicSolver.h
-include/gmsh/yamakawa.h
+%%STATIC%%lib/libGmsh.a
+%%SHARED%%lib/libGmsh.so
+%%SHARED%%lib/libGmsh.so.%%VE%%
+%%SHARED%%lib/libGmsh.so.%%VER%%
+%%SHARED%%include/gmsh/BasisFactory.h
+%%SHARED%%include/gmsh/CADDistances.h
+%%SHARED%%include/gmsh/CGNSOptions.h
+%%SHARED%%include/gmsh/Cell.h
+%%SHARED%%include/gmsh/CellComplex.h
+%%SHARED%%include/gmsh/Chain.h
+%%SHARED%%include/gmsh/ChainComplex.h
+%%SHARED%%include/gmsh/ColorTable.h
+%%SHARED%%include/gmsh/CondNumBasis.h
+%%SHARED%%include/gmsh/Context.h
+%%SHARED%%include/gmsh/ElementType.h
+%%SHARED%%include/gmsh/FuncSpaceData.h
+%%SHARED%%include/gmsh/GEdge.h
+%%SHARED%%include/gmsh/GEdgeCompound.h
+%%SHARED%%include/gmsh/GEdgeLoop.h
+%%SHARED%%include/gmsh/GEntity.h
+%%SHARED%%include/gmsh/GFace.h
+%%SHARED%%include/gmsh/GFaceCompound.h
+%%SHARED%%include/gmsh/GModel.h
+%%SHARED%%include/gmsh/GPoint.h
+%%SHARED%%include/gmsh/GRbf.h
+%%SHARED%%include/gmsh/GRegion.h
+%%SHARED%%include/gmsh/GRegionCompound.h
+%%SHARED%%include/gmsh/GVertex.h
+%%SHARED%%include/gmsh/GaussIntegration.h
+%%SHARED%%include/gmsh/GenericEdge.h
+%%SHARED%%include/gmsh/GenericFace.h
+%%SHARED%%include/gmsh/GenericRegion.h
+%%SHARED%%include/gmsh/GenericVertex.h
+%%SHARED%%include/gmsh/Gmsh.h
+%%SHARED%%include/gmsh/GmshConfig.h
+%%SHARED%%include/gmsh/GmshDefines.h
+%%SHARED%%include/gmsh/GmshMessage.h
+%%SHARED%%include/gmsh/GmshSocket.h
+%%SHARED%%include/gmsh/GmshVersion.h
+%%SHARED%%include/gmsh/Homology.h
+%%SHARED%%include/gmsh/Integration3D.h
+%%SHARED%%include/gmsh/JacobianBasis.h
+%%SHARED%%include/gmsh/Levy3D.h
+%%SHARED%%include/gmsh/MEdge.h
+%%SHARED%%include/gmsh/MElement.h
+%%SHARED%%include/gmsh/MElementCut.h
+%%SHARED%%include/gmsh/MElementOctree.h
+%%SHARED%%include/gmsh/MFace.h
+%%SHARED%%include/gmsh/MHexahedron.h
+%%SHARED%%include/gmsh/MLine.h
+%%SHARED%%include/gmsh/MPoint.h
+%%SHARED%%include/gmsh/MPrism.h
+%%SHARED%%include/gmsh/MPyramid.h
+%%SHARED%%include/gmsh/MQuadrangle.h
+%%SHARED%%include/gmsh/MTetrahedron.h
+%%SHARED%%include/gmsh/MTriangle.h
+%%SHARED%%include/gmsh/MTrihedron.h
+%%SHARED%%include/gmsh/MVertex.h
+%%SHARED%%include/gmsh/MVertexBoundaryLayerData.h
+%%SHARED%%include/gmsh/MeshOpt.h
+%%SHARED%%include/gmsh/MeshOptCommon.h
+%%SHARED%%include/gmsh/MeshOptObjContrib.h
+%%SHARED%%include/gmsh/MeshOptObjContribFunc.h
+%%SHARED%%include/gmsh/MeshOptObjContribScaledNodeDispSq.h
+%%SHARED%%include/gmsh/MeshOptObjectiveFunction.h
+%%SHARED%%include/gmsh/MeshOptPatch.h
+%%SHARED%%include/gmsh/MeshOptVertexCoord.h
+%%SHARED%%include/gmsh/MeshOptimizer.h
+%%SHARED%%include/gmsh/MeshQualityObjContribIdealJac.h
+%%SHARED%%include/gmsh/MeshQualityObjContribInvCond.h
+%%SHARED%%include/gmsh/MeshQualityOptimizer.h
+%%SHARED%%include/gmsh/MetricBasis.h
+%%SHARED%%include/gmsh/Numeric.h
+%%SHARED%%include/gmsh/OS.h
+%%SHARED%%include/gmsh/Octree.h
+%%SHARED%%include/gmsh/OctreeInternals.h
+%%SHARED%%include/gmsh/OctreePost.h
+%%SHARED%%include/gmsh/OpenFile.h
+%%SHARED%%include/gmsh/OptHOM.h
+%%SHARED%%include/gmsh/OptHomFastCurving.h
+%%SHARED%%include/gmsh/OptHomMesh.h
+%%SHARED%%include/gmsh/OptHomIntegralBoundaryDist.h
+%%SHARED%%include/gmsh/OptHomObjContribCADDist.h
+%%SHARED%%include/gmsh/OptHomObjContribMetricMin.h
+%%SHARED%%include/gmsh/OptHomObjContribScaledJac.h
+%%SHARED%%include/gmsh/OptHomRun.h
+%%SHARED%%include/gmsh/Options.h
+%%SHARED%%include/gmsh/PView.h
+%%SHARED%%include/gmsh/PViewData.h
+%%SHARED%%include/gmsh/PViewDataGModel.h
+%%SHARED%%include/gmsh/PViewDataList.h
+%%SHARED%%include/gmsh/PViewOptions.h
+%%SHARED%%include/gmsh/Pair.h
+%%SHARED%%include/gmsh/ParamCoord.h
+%%SHARED%%include/gmsh/PluginManager.h
+%%SHARED%%include/gmsh/Range.h
+%%SHARED%%include/gmsh/SBoundingBox3d.h
+%%SHARED%%include/gmsh/SOrientedBoundingBox.h
+%%SHARED%%include/gmsh/SPoint2.h
+%%SHARED%%include/gmsh/SPoint3.h
+%%SHARED%%include/gmsh/STensor3.h
+%%SHARED%%include/gmsh/SVector3.h
+%%SHARED%%include/gmsh/StringUtils.h
+%%SHARED%%include/gmsh/SuperEl.h
+%%SHARED%%include/gmsh/ThinLayer.h
+%%SHARED%%include/gmsh/VertexArray.h
+%%SHARED%%include/gmsh/Voronoi3D.h
+%%SHARED%%include/gmsh/adaptiveData.h
+%%SHARED%%include/gmsh/bezierBasis.h
+%%SHARED%%include/gmsh/boundaryLayersData.h
+%%SHARED%%include/gmsh/cartesian.h
+%%SHARED%%include/gmsh/crossConfTerm.h
+%%SHARED%%include/gmsh/directions3D.h
+%%SHARED%%include/gmsh/discreteEdge.h
+%%SHARED%%include/gmsh/discreteFace.h
+%%SHARED%%include/gmsh/discreteRegion.h
+%%SHARED%%include/gmsh/discreteVertex.h
+%%SHARED%%include/gmsh/dofManager.h
+%%SHARED%%include/gmsh/drawContext.h
+%%SHARED%%include/gmsh/elasticitySolver.h
+%%SHARED%%include/gmsh/elasticityTerm.h
+%%SHARED%%include/gmsh/femTerm.h
+%%SHARED%%include/gmsh/fullMatrix.h
+%%SHARED%%include/gmsh/gmp_blas.h
+%%SHARED%%include/gmsh/gmp_matrix.h
+%%SHARED%%include/gmsh/gmp_normal_form.h
+%%SHARED%%include/gmsh/gmshLevelset.h
+%%SHARED%%include/gmsh/groupOfElements.h
+%%SHARED%%include/gmsh/laplaceTerm.h
+%%SHARED%%include/gmsh/linearSystem.h
+%%SHARED%%include/gmsh/linearSystemCSR.h
+%%SHARED%%include/gmsh/linearSystemFull.h
+%%SHARED%%include/gmsh/linearSystemGMM.h
+%%SHARED%%include/gmsh/linearSystemMUMPS.h
+%%SHARED%%include/gmsh/linearSystemPETSc.h
+%%SHARED%%include/gmsh/mathEvaluator.h
+%%SHARED%%include/gmsh/mathex.h
+%%SHARED%%include/gmsh/meshGEdge.h
+%%SHARED%%include/gmsh/meshGFace.h
+%%SHARED%%include/gmsh/meshGFaceDelaunayInsertion.h
+%%SHARED%%include/gmsh/meshGFaceElliptic.h
+%%SHARED%%include/gmsh/meshGFaceOptimize.h
+%%SHARED%%include/gmsh/meshMetric.h
+%%SHARED%%include/gmsh/meshPartition.h
+%%SHARED%%include/gmsh/meshPartitionOptions.h
+%%SHARED%%include/gmsh/mpz.h
+%%SHARED%%include/gmsh/nodalBasis.h
+%%SHARED%%include/gmsh/onelab.h
+%%SHARED%%include/gmsh/onelabUtils.h
+%%SHARED%%include/gmsh/orthogonalTerm.h
+%%SHARED%%include/gmsh/partitionEdge.h
+%%SHARED%%include/gmsh/periodical.h
+%%SHARED%%include/gmsh/polynomialBasis.h
+%%SHARED%%include/gmsh/simple3D.h
+%%SHARED%%include/gmsh/simpleFunction.h
+%%SHARED%%include/gmsh/sparsityPattern.h
+%%SHARED%%include/gmsh/thermicSolver.h
+%%SHARED%%include/gmsh/yamakawa.h
man/man1/gmsh.1.gz
%%PORTDOCS%%%%DOCSDIR%%/CREDITS.txt
%%PORTDOCS%%%%DOCSDIR%%/LICENSE.txt
@@ -192,6 +192,7 @@ man/man1/gmsh.1.gz
%%PORTDOCS%%%%DOCSDIR%%/demos/sphere-surf.stl
%%PORTDOCS%%%%DOCSDIR%%/demos/sphere.geo
%%PORTDOCS%%%%DOCSDIR%%/demos/splines.geo
+%%PORTDOCS%%%%DOCSDIR%%/demos/square_regular.geo
%%PORTDOCS%%%%DOCSDIR%%/demos/title.script
%%PORTDOCS%%%%DOCSDIR%%/demos/tower.geo
%%PORTDOCS%%%%DOCSDIR%%/demos/tower.i1
@@ -224,4 +225,3 @@ man/man1/gmsh.1.gz
%%PORTDOCS%%%%DOCSDIR%%/tutorial/view3.pos
%%PORTDOCS%%%%DOCSDIR%%/tutorial/view4.pos
%%PORTDOCS%%%%DOCSDIR%%/tutorial/view5.msh
-%%METIS%%%%DOCSDIR%%/metis/manual.pdf