aboutsummaryrefslogtreecommitdiff
path: root/cad/gnucap
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-08-19 13:29:59 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-08-19 13:29:59 +0000
commitbb271f0bf7b513a23a31da4ec8819b113ebf4587 (patch)
treeac5a462edc3d85d5f0b20a594802ce4b12f0bf9f /cad/gnucap
parent29879aded766da253313579a3503ff5e15026355 (diff)
downloadports-bb271f0bf7b513a23a31da4ec8819b113ebf4587.tar.gz
ports-bb271f0bf7b513a23a31da4ec8819b113ebf4587.zip
Convert ports to use the options helpers in categories [abc]*, and minor fixes.
Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D3412?
Notes
Notes: svn path=/head/; revision=394778
Diffstat (limited to 'cad/gnucap')
-rw-r--r--cad/gnucap/Makefile15
1 files changed, 4 insertions, 11 deletions
diff --git a/cad/gnucap/Makefile b/cad/gnucap/Makefile
index d44af868604e..54be5201c261 100644
--- a/cad/gnucap/Makefile
+++ b/cad/gnucap/Makefile
@@ -24,13 +24,8 @@ PORTEXAMPLES= *
PLIST_FILES= bin/gnucap bin/gnucap-modelgen \
man/man1/gnucap-ibis.1.gz man/man1/gnucap.1.gz
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MREADLINE}
-USES+= readline
-.else
-CONFIGURE_ARGS+=--with-readline=no
-.endif
+READLINE_USES= readline
+READLINE_CONFIGURE_OFF= --with-readline=no
post-patch:
@${REINPLACE_CMD} -e \
@@ -43,20 +38,18 @@ post-patch:
post-install:
${INSTALL_MAN} ${WRKSRC}/doc/*.1 ${STAGEDIR}${MANPREFIX}/man/man1
-.if ${PORT_OPTIONS:MDOCS}
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/acs-tutorial ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/history ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/relnotes.* ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/whatisit ${STAGEDIR}${DOCSDIR}
-.endif
-.if ${PORT_OPTIONS:MEXAMPLES}
+post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/README ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/runall ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/*.c ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/*.ckt ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/*.doc ${STAGEDIR}${EXAMPLESDIR}
-.endif
.include <bsd.port.mk>