aboutsummaryrefslogtreecommitdiff
path: root/cad/graywolf
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2020-06-22 03:13:11 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2020-06-22 03:13:11 +0000
commit109b0f84caf40c9b4879fe67a7a8d4614d439dce (patch)
tree61ccc89455de12324086204d1fcc58839b2e6740 /cad/graywolf
parentb13bbddd60632bfe494a1c43101ca577b9ac4843 (diff)
downloadports-109b0f84caf40c9b4879fe67a7a8d4614d439dce.tar.gz
ports-109b0f84caf40c9b4879fe67a7a8d4614d439dce.zip
cad/graywolf: Unbreak build with GCC 10 (-fno-common)
/usr/local/bin/ld: src/twmc/CMakeFiles/TimberWolfMC.dir/readnets.c.o:(.bss+0x5e40): multiple definition of `yyss'; src/twmc/CMakeFiles/TimberWolfMC.dir/readcells.c.o:(.bss+0x5e40): first defined here /usr/local/bin/ld: src/twmc/CMakeFiles/TimberWolfMC.dir/readnets.c.o:(.bss+0x6240): multiple definition of `yyssp'; src/twmc/CMakeFiles/TimberWolfMC.dir/readcells.c.o:(.bss+0x6240): first defined here /usr/local/bin/ld: src/twmc/CMakeFiles/TimberWolfMC.dir/readnets.c.o:(.bss+0x4ea0): multiple definition of `yyvs'; src/twmc/CMakeFiles/TimberWolfMC.dir/readcells.c.o:(.bss+0x4ea0): first defined here /usr/local/bin/ld: src/twmc/CMakeFiles/TimberWolfMC.dir/readnets.c.o:(.bss+0x6238): multiple definition of `yyvsp'; src/twmc/CMakeFiles/TimberWolfMC.dir/readcells.c.o:(.bss+0x6238): first defined here http://package18.nyi.freebsd.org/data/121amd64-default-PR244494/2020-06-10_18h04m44s/logs/errors/graywolf-0.1.6.3_1.log PR: 246700
Notes
Notes: svn path=/head/; revision=539793
Diffstat (limited to 'cad/graywolf')
-rw-r--r--cad/graywolf/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/cad/graywolf/Makefile b/cad/graywolf/Makefile
index dfc85ff92b77..84814a941715 100644
--- a/cad/graywolf/Makefile
+++ b/cad/graywolf/Makefile
@@ -24,4 +24,6 @@ USE_LDCONFIG= yes
USE_GCC= any # lots of obviously incorrect C where clang fails, which gcc nevertheless magically finds a way to compile
+CFLAGS+= -fcommon
+
.include <bsd.port.mk>