aboutsummaryrefslogtreecommitdiff
path: root/cad/gspiceui/Makefile
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2016-11-11 18:39:57 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2016-11-11 18:39:57 +0000
commit7a9654af15fd537a976664c80b93524f1de229a9 (patch)
tree292e0bde1d9bc1175d31ccbcb5e07becc42a9368 /cad/gspiceui/Makefile
parent187849787c56178f8ca88a4d7591bc6ffaf32265 (diff)
downloadports-7a9654af15fd537a976664c80b93524f1de229a9.tar.gz
ports-7a9654af15fd537a976664c80b93524f1de229a9.zip
Fix build with gcc 4.9 by lowering optimization level
Notes
Notes: svn path=/head/; revision=425901
Diffstat (limited to 'cad/gspiceui/Makefile')
-rw-r--r--cad/gspiceui/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/cad/gspiceui/Makefile b/cad/gspiceui/Makefile
index 8dc0b8a5790b..6c667ef14625 100644
--- a/cad/gspiceui/Makefile
+++ b/cad/gspiceui/Makefile
@@ -29,6 +29,12 @@ PORTEXAMPLES= *
PLIST_FILES= bin/gspiceui share/pixmaps/gspiceui-48x48.xpm \
man/man1/gspiceui.1.gz
+.include <bsd.port.pre.mk>
+
+.if ${CHOSEN_COMPILER_TYPE} == gcc
+CFLAGS:= ${CFLAGS:C/-O[2-9]/-O1/g}
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|share/gspiceui|${DOCSDIR}|g' \
${WRKSRC}/src/main/HelpTasks.cpp
@@ -47,4 +53,4 @@ do-install:
"! -name Makefile")
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>