aboutsummaryrefslogtreecommitdiff
path: root/cad/gspiceui/Makefile
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2013-05-20 14:57:46 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2013-05-20 14:57:46 +0000
commitc1dc5f06041afb55f9872357457b9272b20cf714 (patch)
treeebfea76dbcd05f2eb3c1a08a715929ca263e8b71 /cad/gspiceui/Makefile
parentc8e15569b2eae61f0201c33bda60932b824c123c (diff)
downloadports-c1dc5f06041afb55f9872357457b9272b20cf714.tar.gz
ports-c1dc5f06041afb55f9872357457b9272b20cf714.zip
Do quite a bit of cleanup work for cad/gspiceui. This means:
- Trim Makefile header - Take maintainership - Install a nice-looking desktop icon (and bump PORTREVISION) - Remove LICENSE_FILE for standard license - Improve OPTIONS now that we have optionsng - Update pkg-descr and WWW Pass maitanership to submitter PR: ports/178678 Submitted by: Kevin Zheng <kevinz5000@gmail.com>
Notes
Notes: svn path=/head/; revision=318603
Diffstat (limited to 'cad/gspiceui/Makefile')
-rw-r--r--cad/gspiceui/Makefile49
1 files changed, 31 insertions, 18 deletions
diff --git a/cad/gspiceui/Makefile b/cad/gspiceui/Makefile
index a7389965ea3b..6c0f32780b94 100644
--- a/cad/gspiceui/Makefile
+++ b/cad/gspiceui/Makefile
@@ -1,29 +1,31 @@
-# New ports collection makefile for: gspiceui
-# Date created: 30 April 2006
-# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
-#
+# Created by: Stanislav Sedov <ssedov@mbsd.msk.ru>
# $FreeBSD$
-#
PORTNAME= gspiceui
PORTVERSION= 1.0.00
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= cad
MASTER_SITES= SF/${PORTNAME}/gSpiceUI/${PORTNAME}-v${PORTVERSION}
DISTNAME= ${PORTNAME}-v${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
-COMMENT= GUI frontend for gnucap/ng-spice circuit simulators
+MAINTAINER= kevinz5000@gmail.com
+COMMENT= GUI frontend to gnucap and ngspice circuit simulators
LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/License
-RUN_DEPENDS= gwave:${PORTSDIR}/cad/gwave
+RUN_DEPENDS= # none if no options are set
-OPTIONS_DEFINE= NGSPICE GNUCAP EXAMPLES DOCS
-OPTIONS_DEFAULT= NGSPICE
-NGSPICE_DESC= Use ng-spice as backend
-GNUCAP_DESC= Use gnucap as backend
+OPTIONS_DEFINE= DOCS EXAMPLES
+OPTIONS_GROUP= BACKEND VIEWER
+
+OPTIONS_GROUP_BACKEND= GNUCAP NGSPICE
+OPTIONS_GROUP_VIEWER= GWAVE
+
+GNUCAP_DESC= Depend on gnucap as a simulation backend
+NGSPICE_DESC= Depend on ngspice as a simulation backend
+GWAVE_DESC= Depend on gwave waveform viewer
+
+OPTIONS_DEFAULT= NGSPICE GWAVE
USE_WX= 2.6+
WX_UNICODE= yes
@@ -31,19 +33,27 @@ USE_GCC= 4.6+
USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
+DESKTOP_ENTRIES= "GSpiceUI" "Circuit Simulator GUI" \
+ "${PREFIX}/share/pixmaps/gspiceui-48x48.xpm" \
+ "gspiceui" "Science;Electronics;" false
+
MAN1= gspiceui.1
PORTDOCS= *
PORTEXAMPLES= *
-PLIST_FILES= bin/gspiceui
+PLIST_FILES= bin/gspiceui share/pixmaps/gspiceui-48x48.xpm
.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MGNUCAP}
+RUN_DEPENDS+= gnucap:${PORTSDIR}/cad/gnucap
+.endif
+
.if ${PORT_OPTIONS:MNGSPICE}
RUN_DEPENDS+= ngspice:${PORTSDIR}/cad/ngspice_rework
.endif
-.if ${PORT_OPTIONS:MGNUCAP}
-RUN_DEPENDS+= gnucap:${PORTSDIR}/cad/gnucap
+.if ${PORT_OPTIONS:MGWAVE}
+RUN_DEPENDS+= gwave:${PORTSDIR}/cad/gwave
.endif
post-patch:
@@ -53,10 +63,13 @@ post-patch:
s|$$(WXCFG)|$$(WX_CONFIG)|g ; \
s|$$(CC)|$$(CXX)|g' ${WRKSRC}/src/Makefile
@${REINPLACE_CMD} -e \
- 's|share/gspiceui|share/doc/gspiceui|g' ${WRKSRC}/src/main/HelpTasks.cpp
+ 's|share/gspiceui|${DOCSDIR}|g' \
+ ${WRKSRC}/src/main/HelpTasks.cpp
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/gspiceui ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/src/icons/gspiceui-48x48.xpm \
+ ${PREFIX}/share/pixmaps
${INSTALL_MAN} ${WRKSRC}/gspiceui.1 ${MANPREFIX}/man/man1
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}