aboutsummaryrefslogtreecommitdiff
path: root/cad/gspiceui
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-02-17 23:10:39 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-02-17 23:10:39 +0000
commit8c79d3d1c87f5c4800b9525d4432f22979a6e50f (patch)
treee08d56a58fe31b0c88151fed126d38196a1c9ca0 /cad/gspiceui
parent53ae62258b039225e9a551f9cfb6b461fe7a8503 (diff)
downloadports-8c79d3d1c87f5c4800b9525d4432f22979a6e50f.tar.gz
ports-8c79d3d1c87f5c4800b9525d4432f22979a6e50f.zip
- Support staging [1]
- Use option helpers and install docs and examples files implicitly allowing to remove bsd.port.options.mk inclusion PR: ports/186800 [1] Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=344830
Diffstat (limited to 'cad/gspiceui')
-rw-r--r--cad/gspiceui/Makefile38
1 files changed, 12 insertions, 26 deletions
diff --git a/cad/gspiceui/Makefile b/cad/gspiceui/Makefile
index 82802463ee48..4ee90513a6ae 100644
--- a/cad/gspiceui/Makefile
+++ b/cad/gspiceui/Makefile
@@ -28,27 +28,19 @@ OPTIONS_DEFAULT= NGSPICE
USE_WX= 2.6+
WX_UNICODE= yes
USE_GCC= yes
-USE_GMAKE= yes
+USES= gmake
DESKTOP_ENTRIES= "GSpiceUI" "Circuit Simulator GUI" \
"${PREFIX}/share/pixmaps/gspiceui-48x48.xpm" \
"gspiceui" "Science;Electronics;" false
-MAN1= gspiceui.1
PORTDOCS= *
PORTEXAMPLES= *
-PLIST_FILES= bin/gspiceui share/pixmaps/gspiceui-48x48.xpm
+PLIST_FILES= bin/gspiceui share/pixmaps/gspiceui-48x48.xpm \
+ man/man1/gspiceui.1.gz
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MGNUCAP}
-RUN_DEPENDS+= gnucap:${PORTSDIR}/cad/gnucap
-.endif
-
-.if ${PORT_OPTIONS:MNGSPICE}
-RUN_DEPENDS+= ngspice:${PORTSDIR}/cad/ngspice_rework
-.endif
+GNUCAP_RUN_DEPENDS= gnucap:${PORTSDIR}/cad/gnucap
+NGSPICE_RUN_DEPENDS= ngspice:${PORTSDIR}/cad/ngspice_rework
post-patch:
@${REINPLACE_CMD} -e \
@@ -61,23 +53,17 @@ post-patch:
${WRKSRC}/src/main/HelpTasks.cpp
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/gspiceui ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/gspiceui ${STAGEDIR}${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/src/icons/gspiceui-48x48.xpm \
- ${PREFIX}/share/pixmaps
- ${INSTALL_MAN} ${WRKSRC}/gspiceui.1 ${MANPREFIX}/man/man1
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
-.for dir in html
- @(cd ${WRKSRC} && ${COPYTREE_SHARE} ${dir} ${DOCSDIR} \
+ ${STAGEDIR}${PREFIX}/share/pixmaps
+ ${INSTALL_MAN} ${WRKSRC}/gspiceui.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} html ${STAGEDIR}${DOCSDIR} \
"! -name Makefile")
-.endfor
-.endif
-.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
.for dir in lib sch
- @(cd ${WRKSRC} && ${COPYTREE_SHARE} ${dir} ${EXAMPLESDIR} \
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} ${dir} ${STAGEDIR}${EXAMPLESDIR} \
"! -name Makefile")
.endfor
-.endif
.include <bsd.port.mk>