aboutsummaryrefslogtreecommitdiff
path: root/cad/gspiceui
diff options
context:
space:
mode:
authorBartek Rutkowski <robak@FreeBSD.org>2015-11-08 10:53:51 +0000
committerBartek Rutkowski <robak@FreeBSD.org>2015-11-08 10:53:51 +0000
commitcd351e43751bafe2032076984d2fcfb239d8dad7 (patch)
tree1d110294b8e98c90d09dd9734c20dd7ce7d2325f /cad/gspiceui
parentff33c0ed8e73c7a2d2b4799d29989428656b00a8 (diff)
downloadports-cd351e43751bafe2032076984d2fcfb239d8dad7.tar.gz
ports-cd351e43751bafe2032076984d2fcfb239d8dad7.zip
cad/gspiceui: update 1.0.00 -> 1.1.00
- Remove RUN_DEPENDS on circuit simulators - Support building with WX 3.0 - Update COMMENT and pkg-descr - Update LICENSE to GPLv3 - Respect CFLAGS from ports infrastructure PR: 202232 Submitted by: Kevin Zheng <kevinz5000@gmail.com> (maintainer)
Notes
Notes: svn path=/head/; revision=401047
Diffstat (limited to 'cad/gspiceui')
-rw-r--r--cad/gspiceui/Makefile36
-rw-r--r--cad/gspiceui/distinfo4
-rw-r--r--cad/gspiceui/files/patch-src_Makefile35
-rw-r--r--cad/gspiceui/files/patch-src_TypeDefs.hpp25
-rw-r--r--cad/gspiceui/pkg-descr10
5 files changed, 76 insertions, 34 deletions
diff --git a/cad/gspiceui/Makefile b/cad/gspiceui/Makefile
index 74058e2a8a03..8dc0b8a5790b 100644
--- a/cad/gspiceui/Makefile
+++ b/cad/gspiceui/Makefile
@@ -2,32 +2,23 @@
# $FreeBSD$
PORTNAME= gspiceui
-PORTVERSION= 1.0.00
-PORTREVISION= 8
+PORTVERSION= 1.1.00
CATEGORIES= cad
MASTER_SITES= SF/${PORTNAME}/gSpiceUI/${PORTNAME}-v${PORTVERSION}
DISTNAME= ${PORTNAME}-v${PORTVERSION}
MAINTAINER= kevinz5000@gmail.com
-COMMENT= GUI frontend to gnucap and ngspice circuit simulators
+COMMENT= GUI for ngspice and gnucap circuit simulators
-LICENSE= GPLv2
-
-RUN_DEPENDS= # none if no options are set
+LICENSE= GPLv3
OPTIONS_DEFINE= DOCS EXAMPLES
-OPTIONS_GROUP= BACKEND
-
-OPTIONS_GROUP_BACKEND= GNUCAP NGSPICE
-
-GNUCAP_DESC= Depend on gnucap as a simulation backend
-NGSPICE_DESC= Depend on ngspice as a simulation backend
-OPTIONS_DEFAULT= NGSPICE
-
-USE_WX= 2.8+
+USE_WX= 2.8 3.0
WX_UNICODE= yes
-USES= gmake compiler:c++11-lib
+USES= compiler:c++11-lib gmake pkgconfig
+
+CXXFLAGS+= -std=c++11
DESKTOP_ENTRIES= "GSpiceUI" "Circuit Simulator GUI" \
"${PREFIX}/share/pixmaps/gspiceui-48x48.xpm" \
@@ -38,18 +29,9 @@ PORTEXAMPLES= *
PLIST_FILES= bin/gspiceui share/pixmaps/gspiceui-48x48.xpm \
man/man1/gspiceui.1.gz
-GNUCAP_RUN_DEPENDS= gnucap:${PORTSDIR}/cad/gnucap
-NGSPICE_RUN_DEPENDS= ngspice:${PORTSDIR}/cad/ngspice_rework
-
post-patch:
- @${REINPLACE_CMD} -e \
- 's|:= -Ofast -pipe|+= -I.|g ; \
- s|^INCLUDES |#INCLUDES |g ; \
- s|$$(WXCFG)|$$(WX_CONFIG)|g ; \
- s|$$(CC)|$$(CXX)|g' ${WRKSRC}/src/Makefile
- @${REINPLACE_CMD} -e \
- 's|share/gspiceui|${DOCSDIR}|g' \
- ${WRKSRC}/src/main/HelpTasks.cpp
+ @${REINPLACE_CMD} -e 's|share/gspiceui|${DOCSDIR}|g' \
+ ${WRKSRC}/src/main/HelpTasks.cpp
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/gspiceui ${STAGEDIR}${PREFIX}/bin
diff --git a/cad/gspiceui/distinfo b/cad/gspiceui/distinfo
index 30bf7b17f073..c1323db32ee5 100644
--- a/cad/gspiceui/distinfo
+++ b/cad/gspiceui/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gspiceui-v1.0.00.tar.gz) = ff8d38b9bb10bf695c00a0660dcbd14a43072e93851c5100a85133919736d5da
-SIZE (gspiceui-v1.0.00.tar.gz) = 612517
+SHA256 (gspiceui-v1.1.00.tar.gz) = 22cbe0a8800f9fade43235c74df2e3defb06f2d6e0ac57cff81d058ab89da564
+SIZE (gspiceui-v1.1.00.tar.gz) = 1048236
diff --git a/cad/gspiceui/files/patch-src_Makefile b/cad/gspiceui/files/patch-src_Makefile
new file mode 100644
index 000000000000..1dd97ea94cdc
--- /dev/null
+++ b/cad/gspiceui/files/patch-src_Makefile
@@ -0,0 +1,35 @@
+--- src/Makefile.orig 2015-03-29 12:25:24 UTC
++++ src/Makefile
+@@ -38,13 +38,12 @@ DESTDIR = /usr/local/bin
+ #***************************************************************************************************
+
+ # Which compiler
+-CXX = g++
+
+ # Application name
+ PROG = gspiceui
+
+ # wxWidgets configuration utility
+-WXCFG = wx-config --unicode --version=$(GSPICEUI_WXLIB)
++WXCFG = $(WX_CONFIG)
+
+ # Dependency file
+ DEPS = Makefile.deps
+@@ -71,7 +70,7 @@ BINDIR = $(ROOT)/bin
+ # -Og Optimize debugging experience but don't break debugging
+ ifeq ($(GSPICEUI_DBG),0)
+ # Options for release (not using -Wall since it's GCC specific)
+- CXXFLAGS := -O1 -pipe $(shell $(WXCFG) --cxxflags)
++ CXXFLAGS += $(shell $(WXCFG) --cxxflags)
+ else
+ # Options for development
+ CXXFLAGS := -g -Og -Wall -Wextra -pipe $(shell $(WXCFG) --cxxflags)
+@@ -83,7 +82,7 @@ ifeq ($(GSPICEUI_WXLIB),2.8)
+ endif
+
+ # Includes
+-INCLUDES = -I/usr/include -I/usr/X11R6/include -I.
++INCLUDES = -I.
+
+ # Libraries
+ # (The pkg-config stuff was requested by a user, somehow pangox was missing)
diff --git a/cad/gspiceui/files/patch-src_TypeDefs.hpp b/cad/gspiceui/files/patch-src_TypeDefs.hpp
new file mode 100644
index 000000000000..b71877da8461
--- /dev/null
+++ b/cad/gspiceui/files/patch-src_TypeDefs.hpp
@@ -0,0 +1,25 @@
+--- src/TypeDefs.hpp.orig 2015-04-06 10:28:07 UTC
++++ src/TypeDefs.hpp
+@@ -57,16 +57,18 @@ extern bool g_bDebug; // Declared in
+ //**************************************************************************************************
+ // Type definitions
+
+-//typedef unsigned long ulong;
+-//typedef unsigned int uint;
+-//typedef unsigned char uchar;
++#ifdef __BSD__
++typedef unsigned long ulong;
++typedef unsigned int uint;
++typedef unsigned char uchar;
++#endif
+
+ typedef wxStaticText wxLabel;
+
+ //**************************************************************************************************
+ // Operating System specific macro declarations
+
+-#ifdef __WXOSX__
++#if defined(__WXOSX__) || defined(__BSD__)
+ #define EXP10(X) pow(10.0,X)
+ #define EXP10F(X) powf(10.0,X)
+ #else
diff --git a/cad/gspiceui/pkg-descr b/cad/gspiceui/pkg-descr
index 55cc3b8f4022..75e935c6b2a0 100644
--- a/cad/gspiceui/pkg-descr
+++ b/cad/gspiceui/pkg-descr
@@ -1,6 +1,6 @@
-GSpiceUI (GNU Spice GUI) is intended to provide a graphical frontend to freely
-available circuit simulators, including gnucap and ngspice. It can use
-gnetlist to import schematics or net list files and gwave to display
-simulation results.
+gSpiceUI is intended to provide a GUI for freely available electronic
+circuit simulation engines ie. NG-Spice and GNU-Cap. The utility gnetlist is
+used to convert schematic files to netlist files, Gwave or Gaw to display
+simulation results and gschem is the preferred schematic capture tool.
-WWW: http://sourceforge.net/projects/gspiceui/
+WWW: http://users.tpg.com.au/micksw012/gspiceui.html