aboutsummaryrefslogtreecommitdiff
path: root/cad/ifcopenshell
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2020-05-25 22:35:04 +0000
committerMark Linimon <linimon@FreeBSD.org>2020-05-25 22:35:04 +0000
commit7bfccf5be4d662f3ce327df638f6af109661dc64 (patch)
tree9c86e671950516ce208983583ef6b33739c10a09 /cad/ifcopenshell
parent4af4de6821806351266830cef8aac37d91154d9e (diff)
downloadports-7bfccf5be4d662f3ce327df638f6af109661dc64.tar.gz
ports-7bfccf5be4d662f3ce327df638f6af109661dc64.zip
Add compiler:c++11-lang to USES to fix build on GCC-based systems:
Target "IfcGeom_ifc2x3" requires the language dialect "CXX11" (with compiler extensions), but CMake does not know the compile flags to use to enable it. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=536535
Diffstat (limited to 'cad/ifcopenshell')
-rw-r--r--cad/ifcopenshell/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/cad/ifcopenshell/Makefile b/cad/ifcopenshell/Makefile
index 45bd62c711e9..214d73f67061 100644
--- a/cad/ifcopenshell/Makefile
+++ b/cad/ifcopenshell/Makefile
@@ -17,7 +17,7 @@ BUILD_DEPENDS= nlohmann-json>0:devel/nlohmann-json
LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libTKernel.so:cad/opencascade
-USES= cmake eigen:3 gnome
+USES= cmake compiler:c++11-lang eigen:3 gnome
USE_GNOME= libxml2
USE_LDCONFIG= yes
USE_GITHUB= yes