aboutsummaryrefslogtreecommitdiff
path: root/cad/jspice3
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-07-20 20:26:59 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-07-20 20:26:59 +0000
commit989d81567e9f9457b9b890581f0f10657c0210d8 (patch)
treee1f2d65d3f9fceb2be8ca1ae831070935c4e8c10 /cad/jspice3
parentded11d2b824814468cca14879d57b51970c87c53 (diff)
downloadports-989d81567e9f9457b9b890581f0f10657c0210d8.tar.gz
ports-989d81567e9f9457b9b890581f0f10657c0210d8.zip
- Fix build on 4.x (pre-C99)
PR: ports/100633 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=168332
Diffstat (limited to 'cad/jspice3')
-rw-r--r--cad/jspice3/Makefile2
-rw-r--r--cad/jspice3/files/patch-src+lib+dev+ltra+ltramisc.c31
2 files changed, 32 insertions, 1 deletions
diff --git a/cad/jspice3/Makefile b/cad/jspice3/Makefile
index f2e99e0db33a..d474b0794965 100644
--- a/cad/jspice3/Makefile
+++ b/cad/jspice3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= jspice3
PORTVERSION= 2.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= cad
MASTER_SITES= http://www.wrcad.com/ftp/pub/ \
ftp://ftp.srware.com/pub/
diff --git a/cad/jspice3/files/patch-src+lib+dev+ltra+ltramisc.c b/cad/jspice3/files/patch-src+lib+dev+ltra+ltramisc.c
new file mode 100644
index 000000000000..c34055c7b520
--- /dev/null
+++ b/cad/jspice3/files/patch-src+lib+dev+ltra+ltramisc.c
@@ -0,0 +1,31 @@
+--- src/lib/dev/ltra/ltramisc.c.orig Wed Jan 5 03:25:41 2005
++++ src/lib/dev/ltra/ltramisc.c Thu Jul 20 23:59:44 2006
+@@ -965,10 +965,12 @@
+ double ax = fabs(x);
+ if (ax < 3.75) {
+ double y = x/3.75;
++ double ans1;
++ double ans2;
+ y *= y;
+- double ans1 = 1.0+y*(3.5156229+y*(3.0899424+y*(1.2067492
++ ans1 = 1.0+y*(3.5156229+y*(3.0899424+y*(1.2067492
+ +y*(0.2659732+y*(0.360768e-1+y*0.45813e-2)))));
+- double ans2 = ax*(0.5+y*(0.87890594+y*(0.51498869+y*(0.15084934
++ ans2 = ax*(0.5+y*(0.87890594+y*(0.51498869+y*(0.15084934
+ +y*(0.2658733e-1+y*(0.301532e-2+y*0.32411e-3))))));
+ if (x > 0)
+ ans1 += ans2;
+@@ -978,11 +980,12 @@
+ }
+ else {
+ double y = 3.75/ax;
++ double ans2;
+ double ans1 = (0.39894228+y*(0.1328592e-1
+ +y*(0.225319e-2+y*(-0.157565e-2+y*(0.916281e-2
+ +y*(-0.2057706e-1+y*(0.2635537e-1+y*(-0.1647633e-1
+ +y*0.392377e-2))))))));
+- double ans2 = 0.2282967e-1+y*(-0.2895312e-1+y*(0.1787654e-1
++ ans2 = 0.2282967e-1+y*(-0.2895312e-1+y*(0.1787654e-1
+ -y*0.420059e-2));
+ ans2 = 0.39894228+y*(-0.3988024e-1+y*(-0.362018e-2
+ +y*(0.163801e-2+y*(-0.1031555e-1+y*ans2))));