aboutsummaryrefslogtreecommitdiff
path: root/cad/kicad-doc/Makefile
diff options
context:
space:
mode:
authorChristoph Moench-Tegeder <cmt@FreeBSD.org>2020-03-01 18:04:31 +0000
committerChristoph Moench-Tegeder <cmt@FreeBSD.org>2020-03-01 18:04:31 +0000
commitdd0c846e250919a4e7537720fec43cf03c95e6c6 (patch)
treed6fb76eda17c258732036dbf86706a11ee5be903 /cad/kicad-doc/Makefile
parenta49e740db5c5e87c288dc4f5fa615e42d2e7606d (diff)
downloadports-dd0c846e250919a4e7537720fec43cf03c95e6c6.tar.gz
ports-dd0c846e250919a4e7537720fec43cf03c95e6c6.zip
switch kicad-doc from source to pre-built docs
The build process is rather unstable on our asciidoc toolchain, but then the doc files are completely independent of OS and machine architecture, so there's nothing which stops us from just taking the ready-built files from upstream. At the same time this enables two additional documentation languages (polnish and chinese) - their build process was even more unstable than the rest in my environment. PR: 241183 MFH: 2020Q1
Notes
Notes: svn path=/head/; revision=527565
Diffstat (limited to 'cad/kicad-doc/Makefile')
-rw-r--r--cad/kicad-doc/Makefile25
1 files changed, 7 insertions, 18 deletions
diff --git a/cad/kicad-doc/Makefile b/cad/kicad-doc/Makefile
index 9649b5de788c..28b0b91e5fb3 100644
--- a/cad/kicad-doc/Makefile
+++ b/cad/kicad-doc/Makefile
@@ -3,37 +3,26 @@
PORTNAME= kicad
PORTVERSION= 5.1.5
+PORTREVISION= 1
CATEGORIES= cad
+MASTER_SITES= https://kicad-downloads.s3.cern.ch/docs/
PKGNAMESUFFIX= -doc
+DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${DISTVERSION}
MAINTAINER= cmt@FreeBSD.org
COMMENT= KiCad Documentation and Help Files
LICENSE= GPLv3+ CC-BY-3.0
LICENSE_COMB= dual
-LICENSE_FILE= ${WRKSRC}/LICENSE.adoc
-
-BUILD_DEPENDS= ja-font-vlgothic>0:japanese/font-vlgothic \
- tex-xetex>0:print/tex-xetex \
- asciidoc:textproc/asciidoc \
- dblatex:textproc/dblatex \
- po4a:textproc/po4a \
- source-highlight:textproc/source-highlight \
- freefont-ttf>0:x11-fonts/freefont-ttf
-RUN_DEPENDS= kicad:cad/kicad
-
-USES= cmake gettext-tools
-USE_GITHUB= yes
-GH_ACCOUNT= KiCad
-GH_PROJECT= kicad-doc
+RUN_DEPENDS= kicad:cad/kicad
CONFLICTS= kicad-devel-r2*
NO_ARCH= yes
+NO_BUILD= yes
-CMAKE_ARGS= -DLOCALBASE="${LOCALBASE}" \
- -DLANGUAGES="ca;de;en;es;fr;id;it;ja;nl;ru"
-INSTALL_TARGET= install
+do-install:
+ cd ${WRKSRC}/share/doc/kicad && ${COPYTREE_SHARE} . ${STAGEDIR}/${DOCSDIR}
.include <bsd.port.mk>