aboutsummaryrefslogtreecommitdiff
path: root/cad/opencascade
diff options
context:
space:
mode:
authorCraig Leres <leres@FreeBSD.org>2021-11-12 17:39:30 +0000
committerThierry Thomas <thierry@FreeBSD.org>2021-11-12 17:51:09 +0000
commit4e0ab0ccde840334aaf7ac9a9b8250d9809ad7dc (patch)
treea0f00de3b6f762d705e2b3f82c8c4100242fe49d /cad/opencascade
parente2b9720c1e57f533c7df35f78c01d6bdddc7e1c8 (diff)
downloadports-4e0ab0ccde840334aaf7ac9a9b8250d9809ad7dc.tar.gz
ports-4e0ab0ccde840334aaf7ac9a9b8250d9809ad7dc.zip
cad/opencascade: fix the build without VIS
Always depend on print/freetype2 in order to fix the build without VIS. Reported by: leres@freebsd.org
Diffstat (limited to 'cad/opencascade')
-rw-r--r--cad/opencascade/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/cad/opencascade/Makefile b/cad/opencascade/Makefile
index 6724e6206366..6dff3738c641 100644
--- a/cad/opencascade/Makefile
+++ b/cad/opencascade/Makefile
@@ -58,6 +58,7 @@ CMAKE_ARGS+= -DINSTALL_DIR=${OCCROOT} \
-DINSTALL_DIR_SAMPLES=${OCCROOT}/samples \
-DINSTALL_DIR_TESTS=${OCCROOT}/tests \
-DINSTALL_TEST_CASES:BOOL=ON \
+ -DUSE_FREETYPE:BOOL=ON \
-DUSE_TBB:BOOL=OFF \
-DUSE_RAPIDJSON:BOOL=ON \
-DUSE_VTK:BOOL=ON \
@@ -102,11 +103,9 @@ FFMPEG_LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg \
libgmp.so:math/gmp
VIS_CMAKE_ON= -DUSE_FREEIMAGE:BOOL=ON \
- -DUSE_FREETYPE:BOOL=ON \
-DUSE_GLES2:BOOL=ON \
-D3RDPARTY_FREETYPE_DIR=${LOCALBASE}
VIS_CMAKE_OFF= -DUSE_FREEIMAGE:BOOL=OFF \
- -DUSE_FREETYPE:BOOL=OFF \
-DUSE_GLES2:BOOL=OFF
VIS_LIB_DEPENDS= libftgl.so:graphics/ftgl \
libfreeimageplus.so:graphics/freeimage