aboutsummaryrefslogtreecommitdiff
path: root/cad/opentimer/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-09-12 23:28:37 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-09-12 23:29:32 +0000
commit2983be6402754cf2961965041848ae25730caeca (patch)
tree1adbfd553856fd0cf9cc2a0bf748050ca7fd9355 /cad/opentimer/Makefile
parent69f89bbd1baf191e067ba28107903b20545ac872 (diff)
downloadports-2983be6402754cf2961965041848ae25730caeca.tar.gz
ports-2983be6402754cf2961965041848ae25730caeca.zip
cad/opentimer: New port: High-performance timing analysis tool for VLSI systems
Diffstat (limited to 'cad/opentimer/Makefile')
-rw-r--r--cad/opentimer/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/cad/opentimer/Makefile b/cad/opentimer/Makefile
new file mode 100644
index 000000000000..00abe79cf029
--- /dev/null
+++ b/cad/opentimer/Makefile
@@ -0,0 +1,33 @@
+PORTNAME= opentimer
+PORTVERSION= g20210726
+CATEGORIES= cad
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= High-performance timing analysis tool for VLSI systems
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= cmake compiler:c++17-lang tcl
+USE_GCC= yes # fails to build with clang-11: https://github.com/OpenTimer/OpenTimer/issues/48
+
+USE_GITHUB= yes
+GH_ACCOUNT= OpenTimer
+GH_PROJECT= OpenTimer
+GH_TAGNAME= 18d28ff
+
+PLIST_FILES= bin/ot-shell \
+ bin/ot-tau15 \
+ bin/ot-tau18 \
+ bin/ot-utility
+
+do-install: # see https://github.com/OpenTimer/OpenTimer/issues/47
+.for e in ot-shell ot-tau15 ot-tau18 ot-utility
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/${e} ${STAGEDIR}${PREFIX}/bin
+.endfor
+
+do-test: # runs the script suggested in https://github.com/OpenTimer/OpenTimer
+ @cd ${WRKSRC} && \
+ bin/ot-shell < ${FILESDIR}/test.txt
+
+.include <bsd.port.mk>