aboutsummaryrefslogtreecommitdiff
path: root/cad/opentimer
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-09-13 00:24:01 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-09-13 00:24:01 +0000
commit05e7ba99b237570336dd7a49f5ce98b00bb22e97 (patch)
tree49192c2056d7970e13cc2a405c002288fd6d3235 /cad/opentimer
parent2983be6402754cf2961965041848ae25730caeca (diff)
downloadports-05e7ba99b237570336dd7a49f5ce98b00bb22e97.tar.gz
ports-05e7ba99b237570336dd7a49f5ce98b00bb22e97.zip
cad/opentimer: Change the 'test' target to run official tests, move the previous tests to 'quick-test'
Diffstat (limited to 'cad/opentimer')
-rw-r--r--cad/opentimer/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/cad/opentimer/Makefile b/cad/opentimer/Makefile
index 00abe79cf029..c18a4399f4b0 100644
--- a/cad/opentimer/Makefile
+++ b/cad/opentimer/Makefile
@@ -8,14 +8,18 @@ COMMENT= High-performance timing analysis tool for VLSI systems
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= cmake compiler:c++17-lang tcl
+USES= cmake compiler:c++17-lang python:test shebangfix tcl
USE_GCC= yes # fails to build with clang-11: https://github.com/OpenTimer/OpenTimer/issues/48
+SHEBANG_FILES= inttest/*.py
+
USE_GITHUB= yes
GH_ACCOUNT= OpenTimer
GH_PROJECT= OpenTimer
GH_TAGNAME= 18d28ff
+TEST_TARGET= test
+
PLIST_FILES= bin/ot-shell \
bin/ot-tau15 \
bin/ot-tau18 \
@@ -26,7 +30,7 @@ do-install: # see https://github.com/OpenTimer/OpenTimer/issues/47
${INSTALL_PROGRAM} ${WRKSRC}/bin/${e} ${STAGEDIR}${PREFIX}/bin
.endfor
-do-test: # runs the script suggested in https://github.com/OpenTimer/OpenTimer
+quick-test: # runs the script suggested in https://github.com/OpenTimer/OpenTimer
@cd ${WRKSRC} && \
bin/ot-shell < ${FILESDIR}/test.txt