aboutsummaryrefslogtreecommitdiff
path: root/cad/pcb
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2006-07-10 06:38:55 +0000
committerHiroki Sato <hrs@FreeBSD.org>2006-07-10 06:38:55 +0000
commit6b14db7984c1b91cbfb2621673ca3e7d11cb4a1b (patch)
tree3e56722491a62413ffe864d09040de2904c6a2d5 /cad/pcb
parent4f978e6349d4e8aeb85d166db8c396ca43b8f602 (diff)
downloadports-6b14db7984c1b91cbfb2621673ca3e7d11cb4a1b.tar.gz
ports-6b14db7984c1b91cbfb2621673ca3e7d11cb4a1b.zip
Update to 20060414. Changes include:
** 20060414 - This is the first snapshot of the new HID version of PCB. HID, which stands for Human Interface Device is the abstraction created by DJ Delorie which seperates the core PCB code from the graphical user interface. In this release, two GUI HID's are supported, gtk and lesstif. In addition, there are HID exporters for postscript and encapsulated postscript, RS-274-X (gerber), bill of materials, centroid file, and png/gif/jpeg. This represents a major restructuring of the code and many months of work. - PCB's actions (the commands which drive the core of the program and may be directly accessed by the user) now have the documentation in-line in the code and the actions reference section of the manual is extracted from the in-line documentation. The goal it to provide more complete and accurate documentation. As always the manual is still a work in progress but it is getting more complete and up to date. - Fixed a long standing segfault when saving connection data - Fixed a DRC bug - Fix some rounding issues when setting sizes. Hopefully this will address the issue with 23.99 mil drills and related problems. - The html manual is now in one file instead of many files - The lesstif HID now supports loading of background images to help recover a layout which may exist in hardcopy form only. ** 20060321 - Add internal support for more than 8 layers. By default PCB is still compiled for 8 copper layers. - Fixed several minor bugs in the GTK user interface including fixing scrolling of the log window, fixed up some of the DRC reporting and mm/mil units. - Fixed several key bindings. - Updated refcard.tex to reflect the current set of key bindings. - Fixed some minor bugs which caused compilation problems on some systems. - Converted the QFN footprints to hi-res. - Added documentation to the manual for the centroid file format and the algorithm used for finding the centroid and rotation. - Fixed a bug so that the initial layer named 'component' is actually on the component side of the board and 'solder' is actually on the solder side of the board. - Fixed the pin order in the bourns trim pots (~bourns library) - Added actions and a script to allow command line printing. - Added IPC-7351 recommended footprints for 0201, 0402, etc passives. - Fixed SME5 package. - Fixed a bug which prevented disabling nets from the ratsnest - Fixed a bug where clearances could be set 1 below the spacing - Fixed clearline flag so that arcs also have this property. - Speed up rtree searches and other autorouter speedups. - Fixed a bug in computation of the closest polygon point. - Use rtrees for polygon handling for speed improvements. - Add a ChangePinName() action. - Fix a bug which caused duplicate rats names when manually adding rats lines. - Added DRC checks for minimum drill diameter and minimum annular ring. - Add a minimal glossary to the manual - Fix the author name in the fab drawing - Cause the crosshair to snap to pad ends instead of center for rat drawing. - Add "join" to SetFlag, ClrFlag and ChangeFlag. - Added inline documentation for the pcb file syntax. The manual now is up to date and correctly documents the file format. In addition the inline documentation will make it much easier to maintain the documentation. - Remove some broken m4lib footprints - Put the correct setting for the gschem footprint= attribute in [] in the library window for the m4 libraries. Submitted by: Stanislav Sedov (ssedov at mbsd dot msk dot ru) PR: ports/99942
Notes
Notes: svn path=/head/; revision=167338
Diffstat (limited to 'cad/pcb')
-rw-r--r--cad/pcb/Makefile23
-rw-r--r--cad/pcb/distinfo6
-rw-r--r--cad/pcb/files/patch-Makefile.in11
-rw-r--r--cad/pcb/files/patch-configure16
-rw-r--r--cad/pcb/files/patch-nodoc22
-rw-r--r--cad/pcb/files/patch-src-gui-netlist-window.c11
-rw-r--r--cad/pcb/files/patch-src-netlist.c11
-rw-r--r--cad/pcb/files/patch-src-vendor.c11
-rw-r--r--cad/pcb/pkg-plist24
9 files changed, 57 insertions, 78 deletions
diff --git a/cad/pcb/Makefile b/cad/pcb/Makefile
index bdd165b0be7e..effee58ee28a 100644
--- a/cad/pcb/Makefile
+++ b/cad/pcb/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= pcb
-PORTVERSION= 20050609
-PORTREVISION= 1
+PORTVERSION= 20060414
CATEGORIES= cad
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,18 +14,26 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= hrs@FreeBSD.org
COMMENT= X11 interactive printed circuit board layout system
+LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
-RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
+RUN_DEPENDS= ${BUILD_DEPENDS}
+.if defined(WITH_MOTIF_GUI)
+USE_MOTIF= yes
+CONFIGURE_ARGS+= --with-gui=lesstif
+.else
USE_GNOME= gtk20
+.endif
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-rpath
-
-INFO= pcb
+USE_GMAKE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
.if !defined(NOPORTDOCS)
-pre-install:
- ${INSTALL_DATA} ${WRKSRC}/doc/pcb.info ${PREFIX}/info
+INFO= pcb
+MAN1= pcb.1
+.else
+CONFIGURE_ARGS+= --disable-doc
.endif
.include <bsd.port.mk>
diff --git a/cad/pcb/distinfo b/cad/pcb/distinfo
index 4e1f831a55e9..43a2f19746e6 100644
--- a/cad/pcb/distinfo
+++ b/cad/pcb/distinfo
@@ -1,3 +1,3 @@
-MD5 (pcb-20050609.tar.gz) = a09473705c80eaf4f796617263d9f8fe
-SHA256 (pcb-20050609.tar.gz) = 42e1d985b6737b5a6f4fda0c2233997126f5d673cf718bd9266bd39a0f3252ff
-SIZE (pcb-20050609.tar.gz) = 2371793
+MD5 (pcb-20060414.tar.gz) = 5e471a7b80f1b5ebf21be22c9b7a2e8e
+SHA256 (pcb-20060414.tar.gz) = 2077019a0b78514b57b9aeda778396b43dd8d9400c47ca8138b8bbf651b37819
+SIZE (pcb-20060414.tar.gz) = 3097668
diff --git a/cad/pcb/files/patch-Makefile.in b/cad/pcb/files/patch-Makefile.in
new file mode 100644
index 000000000000..2d383d0cd75c
--- /dev/null
+++ b/cad/pcb/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Sat Jul 8 23:14:41 2006
++++ Makefile.in Sat Jul 8 23:14:48 2006
+@@ -209,7 +209,7 @@
+ sharedstatedir = @sharedstatedir@
+ sysconfdir = @sysconfdir@
+ target_alias = @target_alias@
+-DIRS = win32 src lib newlib example tools tutorial README_FILES
++DIRS = src lib newlib example tools tutorial README_FILES
+ SUBDIRS = ${DIRS} @DOC@
+ DIST_SUBDIRS = ${DIRS} doc
+ EXTRA_DIST = autogen.sh globalconst.h README.cvs README.win32
diff --git a/cad/pcb/files/patch-configure b/cad/pcb/files/patch-configure
deleted file mode 100644
index 37688bb3f38d..000000000000
--- a/cad/pcb/files/patch-configure
+++ /dev/null
@@ -1,16 +0,0 @@
---- configure.orig Tue Jun 14 02:38:35 2005
-+++ configure Tue Jun 14 02:41:54 2005
-@@ -3612,13 +3612,6 @@
- done
- test -n "$WISH" || WISH="none"
-
--if test "X$WISH" = "Xnone" ; then
-- { { echo "$as_me:$LINENO: error: Did not find the wish executible. You need to make sure
-- that tcl is installed on your system and that wish is in your path" >&5
--echo "$as_me: error: Did not find the wish executible. You need to make sure
-- that tcl is installed on your system and that wish is in your path" >&2;}
-- { (exit 1); exit 1; }; }
--fi
-
-
- cat >>confdefs.h <<_ACEOF
diff --git a/cad/pcb/files/patch-nodoc b/cad/pcb/files/patch-nodoc
deleted file mode 100644
index ca2858daa2f8..000000000000
--- a/cad/pcb/files/patch-nodoc
+++ /dev/null
@@ -1,22 +0,0 @@
---- Makefile.am.orig Sat Jun 11 14:45:54 2005
-+++ Makefile.am Sat Jun 11 14:46:08 2005
-@@ -2,7 +2,7 @@
- ##
- ## Top level automake file for PCB
-
--SUBDIRS= src lib newlib doc example tools tutorial README_FILES
-+SUBDIRS= src lib newlib example tools tutorial README_FILES
-
- EXTRA_DIST= autogen.sh globalconst.h README.cvs
-
---- Makefile.in.orig Sat Jun 11 14:46:00 2005
-+++ Makefile.in Sat Jun 11 14:46:06 2005
-@@ -169,7 +169,7 @@
- sharedstatedir = @sharedstatedir@
- sysconfdir = @sysconfdir@
- target_alias = @target_alias@
--SUBDIRS = src lib newlib doc example tools tutorial README_FILES
-+SUBDIRS = src lib newlib example tools tutorial README_FILES
- EXTRA_DIST = autogen.sh globalconst.h README.cvs
- DISTCLEANFILES = configure.lineno
- all: config.h
diff --git a/cad/pcb/files/patch-src-gui-netlist-window.c b/cad/pcb/files/patch-src-gui-netlist-window.c
deleted file mode 100644
index 682bf1a59fc5..000000000000
--- a/cad/pcb/files/patch-src-gui-netlist-window.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/gui-netlist-window.c.orig Tue Mar 1 14:33:01 2005
-+++ src/gui-netlist-window.c Mon Jun 13 09:04:32 2005
-@@ -692,7 +692,7 @@
- {
- GtkTreePath *path;
- GtkTreeIter iter;
-- LibraryMenuType *net;;
-+ LibraryMenuType *net;
- gchar *name;
-
- if (!node_name)
diff --git a/cad/pcb/files/patch-src-netlist.c b/cad/pcb/files/patch-src-netlist.c
new file mode 100644
index 000000000000..808e7e541bd4
--- /dev/null
+++ b/cad/pcb/files/patch-src-netlist.c
@@ -0,0 +1,11 @@
+--- src/netlist.c.orig Mon Jul 10 11:19:14 2006
++++ src/netlist.c Mon Jul 10 11:19:23 2006
+@@ -29,6 +29,8 @@
+ /* generic netlist operations
+ */
+
++#include <sys/types.h>
++
+ #ifdef HAVE_CONFIG_H
+ #include "config.h"
+ #endif
diff --git a/cad/pcb/files/patch-src-vendor.c b/cad/pcb/files/patch-src-vendor.c
deleted file mode 100644
index b2a6677273ba..000000000000
--- a/cad/pcb/files/patch-src-vendor.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/vendor.c.orig Mon Jun 13 09:05:39 2005
-+++ src/vendor.c Mon Jun 13 09:05:55 2005
-@@ -26,6 +26,8 @@
- #include "config.h"
- #endif
-
-+#include <sys/types.h>
-+
- #include <ctype.h>
- #include <math.h>
- #include <stdio.h>
diff --git a/cad/pcb/pkg-plist b/cad/pcb/pkg-plist
index 96e2775ba69a..4729eaebaa3c 100644
--- a/cad/pcb/pkg-plist
+++ b/cad/pcb/pkg-plist
@@ -1,4 +1,8 @@
@comment $FreeBSD$
+bin/MergePCBPS
+bin/Merge_dimPCBPS
+bin/pcb
+bin/pcb-bin
%%DATADIR%%/CreateLibrary.sh
%%DATADIR%%/CreateLibraryContents.sh
%%DATADIR%%/ListLibraryContents.sh
@@ -38,9 +42,6 @@
%%DATADIR%%/m4/geda.m4
%%DATADIR%%/m4/generic.list
%%DATADIR%%/m4/generic.m4
-%%DATADIR%%/m4/genericsmt.inc
-%%DATADIR%%/m4/genericsmt.list
-%%DATADIR%%/m4/genericsmt.m4
%%DATADIR%%/m4/gtag.list
%%DATADIR%%/m4/gtag.m4
%%DATADIR%%/m4/jerry.list
@@ -144,11 +145,24 @@
%%DATADIR%%/newlib/tests/TO99fromLED
%%DATADIR%%/newlib/tests/UART
%%DATADIR%%/newlib/tests/monoblock_small
+%%PORTDOCS%%%%DATADIR%%/pad.eps
+%%PORTDOCS%%%%DATADIR%%/pad.gif
+%%PORTDOCS%%%%DATADIR%%/pad.pdf
+%%PORTDOCS%%%%DATADIR%%/pad.png
%%DATADIR%%/pcb-menu.res
+%%PORTDOCS%%%%DATADIR%%/pcb.html
+%%PORTDOCS%%%%DATADIR%%/pcb.pdf
+%%PORTDOCS%%%%DATADIR%%/pcb.ps
%%DATADIR%%/pcblib
%%DATADIR%%/pcblib.contents
%%DATADIR%%/qfp-ui
%%DATADIR%%/qfp.dat
+%%PORTDOCS%%%%DATADIR%%/refcard.pdf
+%%PORTDOCS%%%%DATADIR%%/refcard.ps
+%%PORTDOCS%%%%DATADIR%%/thermal.eps
+%%PORTDOCS%%%%DATADIR%%/thermal.gif
+%%PORTDOCS%%%%DATADIR%%/thermal.pdf
+%%PORTDOCS%%%%DATADIR%%/thermal.png
%%DATADIR%%/tools/MergePCBPS
%%DATADIR%%/tools/Merge_dimPCBPS
%%DATADIR%%/tools/PCB2HPGL
@@ -157,10 +171,6 @@
%%DATADIR%%/tools/pcb2ncap.tgz
%%DATADIR%%/tools/tgo2pcb.tcl
%%DATADIR%%/tutorial/tut1.pcb
-bin/MergePCBPS
-bin/Merge_dimPCBPS
-bin/pcb
-bin/pcb-bin
@exec /bin/mkdir -p %D/%%DATADIR%%/newlib/toko
@exec /bin/mkdir -p %D/%%DATADIR%%/newlib/sockets
@exec /bin/mkdir -p %D/%%DATADIR%%/newlib/cypress