aboutsummaryrefslogtreecommitdiff
path: root/cad/verilog-mode.el
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2009-01-12 09:44:37 +0000
committerStanislav Sedov <stas@FreeBSD.org>2009-01-12 09:44:37 +0000
commit08a7bacf70a5d5cb1d347b59656f36e2389941bd (patch)
tree5ce9d90c6c3d7cf539c37c7e35e624d964c2dedc /cad/verilog-mode.el
parent8d65a7b91dfebc56ccec8b30ab025f354e0c286d (diff)
downloadports-08a7bacf70a5d5cb1d347b59656f36e2389941bd.tar.gz
ports-08a7bacf70a5d5cb1d347b59656f36e2389941bd.zip
- Add port for verilog-mode.el, Emacs Verilog editing mode.
Notes
Notes: svn path=/head/; revision=225826
Diffstat (limited to 'cad/verilog-mode.el')
-rw-r--r--cad/verilog-mode.el/Makefile33
-rw-r--r--cad/verilog-mode.el/distinfo3
-rw-r--r--cad/verilog-mode.el/pkg-descr10
-rw-r--r--cad/verilog-mode.el/pkg-message7
-rw-r--r--cad/verilog-mode.el/pkg-plist5
5 files changed, 58 insertions, 0 deletions
diff --git a/cad/verilog-mode.el/Makefile b/cad/verilog-mode.el/Makefile
new file mode 100644
index 000000000000..c3881fae6e3b
--- /dev/null
+++ b/cad/verilog-mode.el/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: verilog-mode.el
+# Date created: 12 January 2009
+# Whom: stas
+#
+# $FreeBSD$
+#
+
+PORTNAME= verilog-mode.el
+PORTVERSION= 465
+CATEGORIES= cad elisp
+MASTER_SITES= http://www.veripool.org/ftp/
+DISTNAME= verilog-mode-${PORTVERSION}.el
+EXTRACT_SUFX= .gz
+
+MAINTAINER= stas@FreeBSD.org
+COMMENT= Emacs lisp modules for the Verilog language
+
+NO_BUILD= yes
+EXTRACT_AFTER_ARGS= > ${ELFILE}
+
+ELFILE= verilog-mode.el
+EMACSLISPDIR= ${PREFIX}/share/emacs/site-lisp
+XEMACSLISPDIR= ${PREFIX}/lib/xemacs/site-lisp
+
+do-install:
+ ${MKDIR} ${DATADIR}/
+ ${INSTALL_DATA} ${WRKDIR}/${ELFILE} ${DATADIR}/
+ ${MKDIR} ${XEMACSLISPDIR}
+ ${LN} -sf ${DATADIR}/${ELFILE} ${EMACSLISPDIR}/
+ ${LN} -sf ${DATADIR}/${ELFILE} ${XEMACSLISPDIR}/
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/cad/verilog-mode.el/distinfo b/cad/verilog-mode.el/distinfo
new file mode 100644
index 000000000000..53b0e32d3175
--- /dev/null
+++ b/cad/verilog-mode.el/distinfo
@@ -0,0 +1,3 @@
+MD5 (verilog-mode-465.el.gz) = 0fc282f30f3b9d3b5c7687a8db3b9cd8
+SHA256 (verilog-mode-465.el.gz) = 5800e9e451753a1e253f094fb2f778948d298a6da4b07c2e30d4f8efe78c7765
+SIZE (verilog-mode-465.el.gz) = 91867
diff --git a/cad/verilog-mode.el/pkg-descr b/cad/verilog-mode.el/pkg-descr
new file mode 100644
index 000000000000..49316f00dda8
--- /dev/null
+++ b/cad/verilog-mode.el/pkg-descr
@@ -0,0 +1,10 @@
+Verilog-mode.el is a Verilog mode for Emacs which provides context-sensitive
+highlighting, auto indenting, and provides macro expansion capabilities to
+greatly reduce Verilog coding time.
+
+Recent versions allow you to insert AUTOS in non-AUTO designs, so IP interconnect
+can be easily modified. You can also expand Verilog-2001 ".*" instantiations, to
+see what ports will be connected by simulators.
+
+Author: Michael McNamara <mac@verilog.com>, Wilson Snyder <wsnyder@wsnyder.org>
+WWW: http://www.veripool.org/wiki/verilog-mode
diff --git a/cad/verilog-mode.el/pkg-message b/cad/verilog-mode.el/pkg-message
new file mode 100644
index 000000000000..15b41e4469ee
--- /dev/null
+++ b/cad/verilog-mode.el/pkg-message
@@ -0,0 +1,7 @@
+====
+To use verilog-mode features in Emacs/XEmacs, add the
+following lines to your Emacs configuration file (usually ~/.emacs):
+
+(autoload 'verilog-mode "verilog-mode" "Verilog mode" t )
+(add-to-list 'auto-mode-alist '("\\.[ds]?v\\'" . verilog-mode))
+====
diff --git a/cad/verilog-mode.el/pkg-plist b/cad/verilog-mode.el/pkg-plist
new file mode 100644
index 000000000000..fad1b7387aee
--- /dev/null
+++ b/cad/verilog-mode.el/pkg-plist
@@ -0,0 +1,5 @@
+share/emacs/site-lisp/verilog-mode.el
+lib/xemacs/site-lisp/verilog-mode.el
+%%DATADIR%%/verilog-mode.el
+@dirrmtry lib/xemacs/site-lisp
+@dirrmtry lib/xemacs