aboutsummaryrefslogtreecommitdiff
path: root/cad/xcircuit
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2015-08-22 17:48:35 +0000
committerHiroki Sato <hrs@FreeBSD.org>2015-08-22 17:48:35 +0000
commit27470e1676e69455acf06ae25ebd42ebd5bdecdb (patch)
tree445c3e315f03aa972de87391f921c655e4634f60 /cad/xcircuit
parentcb9ed09fda5119f533f6a0b50796a275dfe64587 (diff)
downloadports-27470e1676e69455acf06ae25ebd42ebd5bdecdb.tar.gz
ports-27470e1676e69455acf06ae25ebd42ebd5bdecdb.zip
- Split ghostscript into X11-independent and -dependent parts:
* print/ghostscript{7,8,9,9-agpl}-base Installs Ghostscript binary, libgs, and related files. These ports do not depend on X11 libraries (i.e. x11* devices are not available). USES=ghostscript will set dependency on one of them depending on GHOSTSCRIPT_DEFAULT. The default device is set to "display" or "bbox". * print/ghostscript{7,8,9,9-agpl}-x11 Installs a shared library which provides X11 support to the installed Ghostscript binaries. x11* devices will be enabled when the library is available. This depends on *-base (RUN_DEPENDS). USES=ghostscript:x11 will set dependency on one of them. - Fix integer overflow reported as CVE-2015-3228. - Update Uses/ghostscript.mk: * Add x11 keyword. nox11 keyword is now obsolete. * Use packagename in *_DEPENDS line to prevent relationship between -base and -x11 packages from being broken. - Fix x11/nox11 keyword and bump PORTREVISION in ports using USES=ghostscript to update dependency of pre-compiled packages.
Notes
Notes: svn path=/head/; revision=395047
Diffstat (limited to 'cad/xcircuit')
-rw-r--r--cad/xcircuit/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/cad/xcircuit/Makefile b/cad/xcircuit/Makefile
index be61e7cf80c0..c8663c929276 100644
--- a/cad/xcircuit/Makefile
+++ b/cad/xcircuit/Makefile
@@ -3,6 +3,7 @@
PORTNAME= xcircuit
PORTVERSION= 3.8.78
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= cad
MASTER_SITES= http://opencircuitdesign.com/xcircuit/archive/ \
@@ -16,7 +17,7 @@ LICENSE= GPLv2
OPTIONS_DEFINE= EXAMPLES
USE_XORG= xpm xscrnsaver xt
-USES= tk ghostscript:run gmake tar:tgz
+USES= tk ghostscript:x11,run gmake tar:tgz
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-tcl=${TCL_LIBDIR} \
--with-tk=${TK_LIBDIR}