aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2019-01-16 11:13:44 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2019-01-16 11:13:44 +0000
commit1bf487d3e73d83700f5a4aeb3a9ffbfc6e87856b (patch)
tree127ae6686665fd0ff97a7bd5f27449299929734e /cad
parentd20d8aa75e51f61da14ac206199a1ebc244f940a (diff)
downloadports-1bf487d3e73d83700f5a4aeb3a9ffbfc6e87856b.tar.gz
ports-1bf487d3e73d83700f5a4aeb3a9ffbfc6e87856b.zip
Fix Qt5 symbol version scripts to put the catch-all clause first. When
a symbol matches multiple clauses the last one takes precedence. If the catch-all is last it captures everything. In the case of Qt5 libraries this caused all symbols to have a Qt_5 label while some should have Qt_5_PRIVATE_API. This only affects lld because GNU ld always gives the catch-all lowest priority. Older versions of Qt5Webengine exported some memory allocation symbols from the bundled Chromium. Version 5.9 stopped exporting these [1] but the symbols were kept as weak wrappers for the standard allocation functions to maintain binary compatibility. [2][3] The problem is that the call to the standard function in these weak wrappers is only resolved to the standard function if there's a call to this standard function in other parts of Qt5Webengine, because only then is there a non-weak symbol that takes precedence over the weak one. If there's no such non-weak symbol the call in the weak wrapper resolves to the weak wrapper itself creating an infinite call loop that overflows the stack and causes a crash. Some of the allocation functions are variants of C++ new and delete and it probably depends on the compiler whether these variants are used in other parts of Qt5Webengine. Remove the weak wrappers (make them Linux specific). This isn't binary compatible but we are already breaking that with the changes to the symbol versions. [1] https://github.com/qt/qtwebengine/commit/5c2cbfccf9aafb547b0b30914c4056abd25942a4 [2] https://github.com/qt/qtwebengine/commit/2ed5054e3a800fa97c2c9e920ba1e6ea4b6ef2a5 [3] https://github.com/qt/qtwebengine/commit/009f5ebb4bd6e50188671e0815a5dae6afe39db5 Bump all ports that depend on Qt5. PR: 234070 Exp-run by: antoine Approved by: kde (adridg)
Notes
Notes: svn path=/head/; revision=490472
Diffstat (limited to 'cad')
-rw-r--r--cad/freecad/Makefile2
-rw-r--r--cad/fritzing/Makefile2
-rw-r--r--cad/librecad/Makefile2
-rw-r--r--cad/openscad-devel/Makefile2
-rw-r--r--cad/py-pyfda/Makefile2
-rw-r--r--cad/qcad/Makefile1
-rw-r--r--cad/qelectrotech/Makefile2
7 files changed, 7 insertions, 6 deletions
diff --git a/cad/freecad/Makefile b/cad/freecad/Makefile
index df1fc0dd0ec5..23d078cfff83 100644
--- a/cad/freecad/Makefile
+++ b/cad/freecad/Makefile
@@ -3,7 +3,7 @@
PORTNAME= FreeCAD
DISTVERSION= 0.17-13541 # git rev-list --count
DISTVERSIONSUFFIX= -g9948ee4f1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= cad
MAINTAINER= ports@FreeBSD.org
diff --git a/cad/fritzing/Makefile b/cad/fritzing/Makefile
index 99b336fa2af4..c6bec30647df 100644
--- a/cad/fritzing/Makefile
+++ b/cad/fritzing/Makefile
@@ -4,7 +4,7 @@
PORTNAME= fritzing
PORTVERSION= 0.9.2
DISTVERSIONSUFFIX= b
-PORTREVISION= 13
+PORTREVISION= 14
CATEGORIES= cad
MAINTAINER= lenzi.sergio@gmail.com
diff --git a/cad/librecad/Makefile b/cad/librecad/Makefile
index b75100b67c77..c566ec1334a7 100644
--- a/cad/librecad/Makefile
+++ b/cad/librecad/Makefile
@@ -2,7 +2,7 @@
PORTNAME= librecad
DISTVERSION= 2.2.0-rc1
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= cad
MAINTAINER= jhale@FreeBSD.org
diff --git a/cad/openscad-devel/Makefile b/cad/openscad-devel/Makefile
index 415cc41f1d09..f0c02cef4303 100644
--- a/cad/openscad-devel/Makefile
+++ b/cad/openscad-devel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= openscad
PORTVERSION= 2018.10.22
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= cad
PKGNAMESUFFIX= -devel
diff --git a/cad/py-pyfda/Makefile b/cad/py-pyfda/Makefile
index a81672de7c64..3dfbff824f04 100644
--- a/cad/py-pyfda/Makefile
+++ b/cad/py-pyfda/Makefile
@@ -2,7 +2,7 @@
PORTNAME= pyfda
PORTVERSION= 0.1
-PORTREVISION= 3
+PORTREVISION= 4
DISTVERSIONSUFFIX= rc6
CATEGORIES= cad python devel
MASTER_SITES= CHEESESHOP
diff --git a/cad/qcad/Makefile b/cad/qcad/Makefile
index acd1cea75cb2..69ae8b9c9b3a 100644
--- a/cad/qcad/Makefile
+++ b/cad/qcad/Makefile
@@ -4,6 +4,7 @@
PORTNAME= qcad
PORTVERSION= 3.21.3.11
DISTVERSIONPREFIX= v
+PORTREVISION= 1
#PORTREVISION= 1
CATEGORIES= cad
DIST_SUBDIR= ${PORTNAME}
diff --git a/cad/qelectrotech/Makefile b/cad/qelectrotech/Makefile
index a8b6c69080fd..47bddff53fa9 100644
--- a/cad/qelectrotech/Makefile
+++ b/cad/qelectrotech/Makefile
@@ -3,7 +3,7 @@
PORTNAME= qelectrotech
PORTVERSION= 0.5
-PORTREVISION= 5
+PORTREVISION= 6
PORTEPOCH= 1
CATEGORIES= cad
MASTER_SITES= http://download.tuxfamily.org/qet/tags/20151127/