aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1999-02-03 11:12:01 +0000
committerSatoshi Asami <asami@FreeBSD.org>1999-02-03 11:12:01 +0000
commit5114e2637e2224ea9b0e0ea4b315bc38370ccf04 (patch)
tree414dd9b31f0192eb7d0054b2463c2eed8afd25b4 /cad
parentfd5131ad95770d2ae6bee7059204950dfa6402d1 (diff)
downloadports-5114e2637e2224ea9b0e0ea4b315bc38370ccf04.tar.gz
ports-5114e2637e2224ea9b0e0ea4b315bc38370ccf04.zip
Adjust port Makefiles to new EXTRACT_* variable defaults. See log of
bsd.port.mk rev. 1.304 for details on the change. The fix here is one of the following. (1) Define USE_BZIP2 instead of BUILD_DEPENDS on bzip2 and redefining EXTRACT_* commands. (2) Change ${EXTRACT_CMD} to ${TAR} when the command is obviously calling the "tar" command (i.e., arguments like "-xzf" are spelled out). (3) If ${EXTRACT_CMD} is called directly with ${EXTRACT_BEFORE_ARGS}, add ${EXTRACT_AFTER_ARGS} to the command line as well. (4) If any of EXTRACT_CMD, EXTRACT_BEFORE_ARGS or EXTRACT_AFTER_ARGS is set, define the other two too.
Notes
Notes: svn path=/head/; revision=16518
Diffstat (limited to 'cad')
-rw-r--r--cad/mars/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/cad/mars/Makefile b/cad/mars/Makefile
index 0995c3ebe438..b6605bb2b53b 100644
--- a/cad/mars/Makefile
+++ b/cad/mars/Makefile
@@ -4,7 +4,7 @@
# Date created: Mon Nov 18, 1996
# Whom: David O'Brien (obrien@cs.ucdavis.edu)
#
-# $Id: Makefile,v 1.6 1997/10/10 06:53:30 obrien Exp $
+# $Id: Makefile,v 1.7 1998/11/28 00:44:31 asami Exp $
#
DISTNAME= MaRS-2.1
@@ -37,7 +37,7 @@ do-install:
@${MKDIR} ${PREFIX}/share/doc/mars
@chmod a+rx ${PREFIX}/share/doc/mars
@(cd ${PREFIX}/share/doc ; \
- ${EXTRACT_CMD} xfpz /${DISTDIR}/MaRS-2-doc.tar.gz ; \
+ ${TAR} xfpz /${DISTDIR}/MaRS-2-doc.tar.gz ; \
[ -d mars ] && ${RM} -rf mars; \
/bin/mv doc mars )
.endif