aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-26 17:39:31 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-26 17:47:06 +0000
commit6cac88af1bcebeeed8774b6a169064c9949122a5 (patch)
tree56643b0dc04216b8da473080979daa794a4424d7 /cad
parent8fc01595659cec5a6e015ec9021f1c5ac2057e40 (diff)
downloadports-6cac88af1bcebeeed8774b6a169064c9949122a5.tar.gz
ports-6cac88af1bcebeeed8774b6a169064c9949122a5.zip
cad/z88: Fix build with llvm16
Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
Diffstat (limited to 'cad')
-rw-r--r--cad/z88/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/cad/z88/Makefile b/cad/z88/Makefile
index 4cd6f43af8a4..7dde7deb3d09 100644
--- a/cad/z88/Makefile
+++ b/cad/z88/Makefile
@@ -35,6 +35,12 @@ Z88_DATA= 51.txt z88.dyn z88.fcd z88elp.txt z88i1.txt z88i2.txt z88i5.txt z88int
OPTIONS_DEFINE= DOCS EXAMPLES
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
+CFLAGS+= -Wno-error=incompatible-function-pointer-types
+.endif
+
post-patch:
for x in ${BUILD_WRKSRC}/*; do ${REINPLACE_CMD} 's,z88v15os,Z88OS-15, ; s,gcc,${CC}, ; s,CFLAGS =,CFLAGS+=, ; s,-O2,, ; s,LDLIBSOX,LDFLAGS, ; s,LDFLAGS =,LDFLAGS+=, ; s,--copy-dt-needed-entries,,' $$x; done