aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2008-08-21 06:18:49 +0000
committerRong-En Fan <rafan@FreeBSD.org>2008-08-21 06:18:49 +0000
commit741aa714833b9bb1e9afaaf5124d3f5c60b5e49c (patch)
treee9b79b363f2fc4a63535a25c71491fa49a79b556 /cad
parente6b2e4b3537ce43e377d2f4fe0ac46b6ab8c4395 (diff)
downloadports-741aa714833b9bb1e9afaaf5124d3f5c60b5e49c.tar.gz
ports-741aa714833b9bb1e9afaaf5124d3f5c60b5e49c.zip
Update CONFIGURE_ARGS for how we pass CONFIGURE_TARGET to configure script.
Specifically, newer autoconf (> 2.13) has different semantic of the configure target. In short, one should use --build=CONFIGURE_TARGET instead of CONFIGURE_TARGET directly. Otherwise, you will get a warning and the old semantic may be removed in later autoconf releases. To workaround this issue, many ports hack the CONFIGURE_TARGET variable so that it contains the ``--build='' prefix. To solve this issue, under the fact that some ports still have configure script generated by the old autoconf, we use runtime detection in the do-configure target so that the proper argument can be used. Changes to Mk/*: - Add runtime detection magic in bsd.port.mk - Remove CONFIGURE_TARGET hack in various bsd.*.mk - USE_GNOME=gnometarget is now an no-op Changes to individual ports, other than removing the CONFIGURE_TARGET hack: = pkg-plist changed (due to the ugly CONFIGURE_TARGET prefix in * executables) - comms/gnuradio - science/abinit - science/elmer-fem - science/elmer-matc - science/elmer-meshgen2d - science/elmerfront - science/elmerpost = use x86_64 as ARCH - devel/g-wrap = other changes - print/magicfilter GNU_CONFIGURE -> HAS_CONFIGURE since it's not generated by autoconf Total # of ports modified: 1,027 Total # of ports affected: ~7,000 (set GNU_CONFIGURE to yes) PR: 126524 (obsoletes 52917) Submitted by: rafan Tested on: two pointyhat 7-amd64 exp runs (by pav) Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=218938
Diffstat (limited to 'cad')
-rw-r--r--cad/freecad/Makefile1
-rw-r--r--cad/gmsh/Makefile1
-rw-r--r--cad/gtkwave/Makefile1
-rw-r--r--cad/opencascade/Makefile1
-rw-r--r--cad/qucs/Makefile1
-rw-r--r--cad/scv/Makefile1
-rw-r--r--cad/systemc/Makefile1
-rw-r--r--cad/xcircuit/Makefile1
8 files changed, 0 insertions, 8 deletions
diff --git a/cad/freecad/Makefile b/cad/freecad/Makefile
index e3dd0790b420..c3fc22893140 100644
--- a/cad/freecad/Makefile
+++ b/cad/freecad/Makefile
@@ -33,7 +33,6 @@ CONFIGURE_ARGS= --with-wildmagic-includes=${LOCALBASE}/include/Wm4 \
--with-xercesc-libs=${LOCALBASE}/lib \
--with-OCC-includes=${LOCALBASE}/OpenCAS/ros/inc \
--with-OCC-libs=${LOCALBASE}/lib
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
QTDIR= ${QT_PREFIX}
QMAKESPEC= ${LOCALBASE}/share/qt/mkspecs/freebsd-g++
MAKE_ENV= QMAKESPEC="${QMAKESPEC}" QTDIR="${QTDIR}"
diff --git a/cad/gmsh/Makefile b/cad/gmsh/Makefile
index 1747d5b79f2e..af65fccaad7f 100644
--- a/cad/gmsh/Makefile
+++ b/cad/gmsh/Makefile
@@ -27,7 +27,6 @@ TETGEN_SRC= predicates.cxx tetgen.cxx tetgen.h
USE_FORTRAN= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-fltk-prefix=${LOCALBASE} \
--with-gsl-prefix=${LOCALBASE} \
--with-med-prefix=${LOCALBASE} \
diff --git a/cad/gtkwave/Makefile b/cad/gtkwave/Makefile
index 87bcff5a2d8e..703f97e29376 100644
--- a/cad/gtkwave/Makefile
+++ b/cad/gtkwave/Makefile
@@ -22,7 +22,6 @@ LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
USE_AUTOTOOLS= libtool:15
USE_GNOME= gtk12
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_LDCONFIG= yes
LDCONFIG_DIRS= ${PREFIX}/lib/gtkwave
diff --git a/cad/opencascade/Makefile b/cad/opencascade/Makefile
index 56bf7700e00a..c56537ee1141 100644
--- a/cad/opencascade/Makefile
+++ b/cad/opencascade/Makefile
@@ -52,7 +52,6 @@ PATCH_WRKSRC= ${WRKDIR}/${DISTNAME}
WRKSRC= ${WRKDIR}/${DISTNAME}/ros
REINPLACE_ARGS= -i ""
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-tcl=${TCL_LIBDIR} \
--with-tk=${TK_LIBDIR} \
--with-java-include=${JAVA_HOME}/include \
diff --git a/cad/qucs/Makefile b/cad/qucs/Makefile
index 67b851999704..dda6344da9c1 100644
--- a/cad/qucs/Makefile
+++ b/cad/qucs/Makefile
@@ -17,7 +17,6 @@ COMMENT= Graphical circuit design and simulation tool
USE_QT_VER= 3
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= ps2sp.1 qucs.1 qucsator.1 qucsattenuator.1 qucsconv.1 \
qucsdigi.1 qucsedit.1 qucsfilter.1 qucshelp.1 qucslib.1 \
diff --git a/cad/scv/Makefile b/cad/scv/Makefile
index 5cbc0dc436c5..8ef3c44de716 100644
--- a/cad/scv/Makefile
+++ b/cad/scv/Makefile
@@ -24,7 +24,6 @@ HAS_CONFIGURE= yes
WRKSRC= ${WRKDIR}/scv-1.0p2-sysc2.2
CONFIGURE_SCRIPT= ../configure
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-systemc=${LOCALBASE}/systemc ${CONFIGURE_TARGET}
CONFIGURE_WRKSRC= ${WRKSRC}/objdir
BUILD_WRKSRC= ${WRKSRC}/objdir
diff --git a/cad/systemc/Makefile b/cad/systemc/Makefile
index a05f0c033174..ee9771f315fc 100644
--- a/cad/systemc/Makefile
+++ b/cad/systemc/Makefile
@@ -20,7 +20,6 @@ USE_GMAKE= yes
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= ../configure
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --prefix=${PREFIX}/systemc ${CONFIGURE_TARGET}
CONFIGURE_WRKSRC= ${WRKSRC}/objdir
BUILD_WRKSRC= ${WRKSRC}/objdir
diff --git a/cad/xcircuit/Makefile b/cad/xcircuit/Makefile
index 57be45138eab..b28258c95683 100644
--- a/cad/xcircuit/Makefile
+++ b/cad/xcircuit/Makefile
@@ -25,7 +25,6 @@ USE_TK_BUILD= 84
USE_GHOSTSCRIPT_RUN= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-tcl=${TCL_LIBDIR} \
--with-tk=${TK_LIBDIR}