aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorAlex Kozlov <ak@FreeBSD.org>2013-04-26 10:44:28 +0000
committerAlex Kozlov <ak@FreeBSD.org>2013-04-26 10:44:28 +0000
commit83f02b963c2b22c85235bf19b4f10a20bea921b5 (patch)
treee5e83d3ba0442c1c2f0b99c843428b36a8eb003d /cad
parent152f30ef73f9cf1c87d1eb78186693682bed0c43 (diff)
downloadports-83f02b963c2b22c85235bf19b4f10a20bea921b5.tar.gz
ports-83f02b963c2b22c85235bf19b4f10a20bea921b5.zip
- Convert USE_GETTEXT to USES (part 4)
Approved by: portmgr (bapt)
Notes
Notes: svn path=/head/; revision=316596
Diffstat (limited to 'cad')
-rw-r--r--cad/geda/Makefile3
-rw-r--r--cad/kicad-devel/Makefile3
-rw-r--r--cad/kicad/Makefile2
-rw-r--r--cad/libgeda/Makefile2
-rw-r--r--cad/pdnmesh/Makefile3
-rw-r--r--cad/repsnapper/Makefile2
6 files changed, 6 insertions, 9 deletions
diff --git a/cad/geda/Makefile b/cad/geda/Makefile
index 656f77d17c50..13be739e5732 100644
--- a/cad/geda/Makefile
+++ b/cad/geda/Makefile
@@ -20,11 +20,10 @@ RUN_DEPENDS= gawk:${PORTSDIR}/lang/gawk
OPTIONS_DEFINE= DOCS
-USES= pathfix
+USES= pathfix gettext
USE_GNOME= desktopfileutils gtk20
USE_PERL5_RUN= yes
USE_PYTHON= run
-USE_GETTEXT= yes
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
CONFIGURE_ARGS= --with-libstroke=${LOCALBASE}
diff --git a/cad/kicad-devel/Makefile b/cad/kicad-devel/Makefile
index d123ceef4cd6..f5ae13981ee3 100644
--- a/cad/kicad-devel/Makefile
+++ b/cad/kicad-devel/Makefile
@@ -22,7 +22,6 @@ DOCVERSION= 1.1
LIBVERSION= 1.0
USE_BZIP2= yes
-USE_GETTEXT= yes
#USE_GMAKE= yes
USE_GL= yes
USE_WX= 2.8
@@ -38,7 +37,7 @@ PLIST_SUB= OPSYS=${OPSYS} \
BINS= cvpcb eeschema gerbview kicad pcbnew
EXTRAS2RM= linux-non_unicode linux wings3d LINUX.README \
contrib_makefiles.txt running_kicad_under_W98.txt
-USES= cmake
+USES= cmake gettext
CMAKE_ARGS= -DLOCALBASE="${LOCALBASE}" \
-DKICAD_TESTING_VERSION=ON \
-DCMAKE_INCLUDE_PATH="${LOCALBASE}/include" \
diff --git a/cad/kicad/Makefile b/cad/kicad/Makefile
index 6789efdee068..aec7adb6bfb3 100644
--- a/cad/kicad/Makefile
+++ b/cad/kicad/Makefile
@@ -41,7 +41,7 @@ PLIST_SUB= DESKTOPDIR=${DESKTOPDIR:S|^${PREFIX}/||}
.if defined(WITHOUT_NLS)
PLIST_SUB+= NLS="@comment "
.else
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.endif
diff --git a/cad/libgeda/Makefile b/cad/libgeda/Makefile
index fddd0db1feef..eb597f48c8e8 100644
--- a/cad/libgeda/Makefile
+++ b/cad/libgeda/Makefile
@@ -26,7 +26,7 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
.if !defined(WITHOUT_NLS)
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+= --disable-nls
diff --git a/cad/pdnmesh/Makefile b/cad/pdnmesh/Makefile
index e0e13eab8346..2f4e5462c936 100644
--- a/cad/pdnmesh/Makefile
+++ b/cad/pdnmesh/Makefile
@@ -26,10 +26,9 @@ LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
OPTIONS_DEFINE= ATLAS DOCS EXAMPLES
ATLAS_DESC= Enable ATLAS support
-USES= pkgconfig
+USES= pkgconfig gettext
USE_FORTRAN= yes
USE_GL= glu
-USE_GETTEXT= yes
USE_ICONV= yes
USE_GNOME= gdkpixbuf2 gtk20
USE_XORG= ice pixman sm x11 xau xcomposite xcursor xdamage xdmcp xext \
diff --git a/cad/repsnapper/Makefile b/cad/repsnapper/Makefile
index da940485785a..7e4c4f125478 100644
--- a/cad/repsnapper/Makefile
+++ b/cad/repsnapper/Makefile
@@ -47,7 +47,7 @@ USE_XORG= ice pixman sm x11 xau xcomposite xcursor xdamage xdmcp xext \
xfixes xi xinerama xmu xrandr xrender xt xxf86vm
.if !defined(WITHOUT_NLS)
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+= --disable-nls