aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2009-02-21 11:43:23 +0000
committerStanislav Sedov <stas@FreeBSD.org>2009-02-21 11:43:23 +0000
commit98130c3c16717c3337634ac1e924b9dd4e3df27f (patch)
tree16a2733a669c0bbe164aa8b881df9d60a67de753 /cad
parent5f6ba2a345062d46d2e16bd1d6c5854e528a096e (diff)
downloadports-98130c3c16717c3337634ac1e924b9dd4e3df27f.tar.gz
ports-98130c3c16717c3337634ac1e924b9dd4e3df27f.zip
- Bump PORTEPOCH, this was missed in previous update [1].
- Use proper shebang line in perl and python scripts [1]. - Define INSTALLS_ICONS and USE_GETTEXT where appropriate. - Implement WITHOUT_NLS knob. Reported by: Nick Withers <nick@nickwithers.com> [1]
Notes
Notes: svn path=/head/; revision=228772
Diffstat (limited to 'cad')
-rw-r--r--cad/geda-docs/Makefile1
-rw-r--r--cad/geda-examples/Makefile1
-rw-r--r--cad/geda-gattrib/Makefile10
-rw-r--r--cad/geda-gattrib/pkg-plist20
-rw-r--r--cad/geda-gschem/Makefile1
-rw-r--r--cad/geda-netlist/Makefile1
-rw-r--r--cad/geda-symbols/Makefile1
-rw-r--r--cad/geda-symcheck/Makefile1
-rw-r--r--cad/geda-utils/Makefile7
-rw-r--r--cad/geda/Makefile1
-rw-r--r--cad/libgeda/Makefile9
-rw-r--r--cad/libgeda/pkg-plist16
12 files changed, 51 insertions, 18 deletions
diff --git a/cad/geda-docs/Makefile b/cad/geda-docs/Makefile
index bf1b71b01a40..4e7509ec9566 100644
--- a/cad/geda-docs/Makefile
+++ b/cad/geda-docs/Makefile
@@ -7,6 +7,7 @@
PORTNAME= docs
PORTVERSION= 1.4.3
+PORTEPOCH= 1
CATEGORIES= cad
MASTER_SITES= ftp://ftp.geda.seul.org/pub/geda/release/v1.4/${PORTVERSION}/ \
http://geda.seul.org/release/v1.4/${PORTVERSION}/
diff --git a/cad/geda-examples/Makefile b/cad/geda-examples/Makefile
index add9b2634e21..8f80b397e8ef 100644
--- a/cad/geda-examples/Makefile
+++ b/cad/geda-examples/Makefile
@@ -7,6 +7,7 @@
PORTNAME= examples
PORTVERSION= 1.4.3
+PORTEPOCH= 1
CATEGORIES= cad
MASTER_SITES= ftp://ftp.geda.seul.org/pub/geda/release/v1.4/${PORTVERSION}/ \
http://geda.seul.org/release/v1.4/${PORTVERSION}/
diff --git a/cad/geda-gattrib/Makefile b/cad/geda-gattrib/Makefile
index 9fd1bc0782b0..47c9c85c411f 100644
--- a/cad/geda-gattrib/Makefile
+++ b/cad/geda-gattrib/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gattrib
PORTVERSION= 1.4.3
+PORTEPOCH= 1
CATEGORIES= cad
MASTER_SITES= ftp://ftp.geda.seul.org/pub/geda/release/v1.4/${PORTVERSION}/ \
http://geda.seul.org/release/v1.4/${PORTVERSION}/
@@ -25,11 +26,20 @@ DOCSDIR= ${PREFIX}/share/doc/geda
GNU_CONFIGURE= yes
USE_GNOME= gtk20 glib20
USE_GMAKE= yes
+INSTALLS_ICONS= yes
CONFIGURE_ARGS= --with-docdir="${DOCSDIR}" --disable-update-mime-database \
--disable-update-desktop-database
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
post-patch:
@${REINPLACE_CMD} -E \
-e "s,^(DATADIR[[:space:]]*=[[:space:]]*)gEDA,\1geda," \
diff --git a/cad/geda-gattrib/pkg-plist b/cad/geda-gattrib/pkg-plist
index 0381a97e2da6..2ed3b3caffdd 100644
--- a/cad/geda-gattrib/pkg-plist
+++ b/cad/geda-gattrib/pkg-plist
@@ -1,7 +1,7 @@
bin/gattrib
-lib/locale/de_DE/LC_MESSAGES/geda-gattrib.mo
-lib/locale/es_ES/LC_MESSAGES/geda-gattrib.mo
-lib/locale/nl_NL/LC_MESSAGES/geda-gattrib.mo
+%%NLS%%lib/locale/de_DE/LC_MESSAGES/geda-gattrib.mo
+%%NLS%%lib/locale/es_ES/LC_MESSAGES/geda-gattrib.mo
+%%NLS%%lib/locale/nl_NL/LC_MESSAGES/geda-gattrib.mo
share/applications/geda-gattrib.desktop
%%DATADIR%%/gattrib-menus.xml
%%DATADIR%%/system-gattribrc
@@ -15,10 +15,10 @@ share/icons/hicolor/scalable/apps/geda-gattrib.svg
@dirrmtry share/icons
@dirrmtry %%DATADIR%%
@dirrmtry share/applications
-@dirrmtry lib/locale/nl_NL/LC_MESSAGES
-@dirrmtry lib/locale/nl_NL
-@dirrmtry lib/locale/es_ES/LC_MESSAGES
-@dirrmtry lib/locale/es_ES
-@dirrmtry lib/locale/de_DE/LC_MESSAGES
-@dirrmtry lib/locale/de_DE
-@dirrmtry lib/locale
+%%NLS%%@dirrmtry lib/locale/nl_NL/LC_MESSAGES
+%%NLS%%@dirrmtry lib/locale/nl_NL
+%%NLS%%@dirrmtry lib/locale/es_ES/LC_MESSAGES
+%%NLS%%@dirrmtry lib/locale/es_ES
+%%NLS%%@dirrmtry lib/locale/de_DE/LC_MESSAGES
+%%NLS%%@dirrmtry lib/locale/de_DE
+%%NLS%%@dirrmtry lib/locale
diff --git a/cad/geda-gschem/Makefile b/cad/geda-gschem/Makefile
index d9863f6461d6..fc52fc79aeb9 100644
--- a/cad/geda-gschem/Makefile
+++ b/cad/geda-gschem/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gschem
PORTVERSION= 1.4.3
+PORTEPOCH= 1
CATEGORIES= cad
MASTER_SITES= ftp://ftp.geda.seul.org/pub/geda/release/v1.4/${PORTVERSION}/ \
http://geda.seul.org/release/v1.4/${PORTVERSION}/
diff --git a/cad/geda-netlist/Makefile b/cad/geda-netlist/Makefile
index 4fd28225aeab..8bfdac5ad51a 100644
--- a/cad/geda-netlist/Makefile
+++ b/cad/geda-netlist/Makefile
@@ -7,6 +7,7 @@
PORTNAME= netlist
PORTVERSION= 1.4.3
+PORTEPOCH= 1
CATEGORIES= cad
MASTER_SITES= ftp://ftp.geda.seul.org/pub/geda/release/v1.4/${PORTVERSION}/ \
http://geda.seul.org/release/v1.4/${PORTVERSION}/
diff --git a/cad/geda-symbols/Makefile b/cad/geda-symbols/Makefile
index 0a559abf2f55..8c2e9cbb0830 100644
--- a/cad/geda-symbols/Makefile
+++ b/cad/geda-symbols/Makefile
@@ -7,6 +7,7 @@
PORTNAME= symbols
PORTVERSION= 1.4.3
+PORTEPOCH= 1
CATEGORIES= cad
MASTER_SITES= ftp://ftp.geda.seul.org/pub/geda/release/v1.4/${PORTVERSION}/ \
http://geda.seul.org/release/v1.4/${PORTVERSION}/
diff --git a/cad/geda-symcheck/Makefile b/cad/geda-symcheck/Makefile
index ace4365de012..e5a2f7b5de75 100644
--- a/cad/geda-symcheck/Makefile
+++ b/cad/geda-symcheck/Makefile
@@ -7,6 +7,7 @@
PORTNAME= symcheck
PORTVERSION= 1.4.3
+PORTEPOCH= 1
CATEGORIES= cad
MASTER_SITES= ftp://ftp.geda.seul.org/pub/geda/release/v1.4/${PORTVERSION}/ \
http://geda.seul.org/release/v1.4/${PORTVERSION}/
diff --git a/cad/geda-utils/Makefile b/cad/geda-utils/Makefile
index 338d1bd75c18..743e8f49b9f5 100644
--- a/cad/geda-utils/Makefile
+++ b/cad/geda-utils/Makefile
@@ -7,6 +7,7 @@
PORTNAME= utils
PORTVERSION= 1.4.3
+PORTEPOCH= 1
CATEGORIES= cad
MASTER_SITES= ftp://ftp.geda.seul.org/pub/geda/release/v1.4/${PORTVERSION}/ \
http://geda.seul.org/release/v1.4/${PORTVERSION}/
@@ -25,6 +26,8 @@ DATADIR= ${PREFIX}/share/geda
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GNOME= gtk20
+USE_PERL5_RUN= yes
+USE_PYTHON_RUN= yes
CONFIGURE_ARGS= --with-docdir=${DOCSDIR}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -35,5 +38,9 @@ post-patch:
@${REINPLACE_CMD} -E \
-e "s,^(DATADIR[[:space:]]*=[[:space:]]*)gEDA,\1geda," \
${WRKSRC}/configure
+ @${REINPLACE_CMD} -E \
+ -e "s,^(#!)/usr/bin/perl,\1${PERL}," \
+ -e "s,^(#!)/usr/bin/python,\1${PYTHON_CMD}," \
+ ${WRKSRC}/scripts/*
.include <bsd.port.mk>
diff --git a/cad/geda/Makefile b/cad/geda/Makefile
index a133598ebe2b..94b44f01f863 100644
--- a/cad/geda/Makefile
+++ b/cad/geda/Makefile
@@ -7,6 +7,7 @@
PORTNAME= geda
PORTVERSION= 1.4.3
+PORTEPOCH= 1
CATEGORIES= cad
MASTER_SITES= # empty
DISTFILES= # none
diff --git a/cad/libgeda/Makefile b/cad/libgeda/Makefile
index ad59ce51d350..4a85ef4e85b4 100644
--- a/cad/libgeda/Makefile
+++ b/cad/libgeda/Makefile
@@ -8,6 +8,7 @@
PORTNAME= libgeda
PORTVERSION= 1.4.3
PORTREVISION= 0
+PORTEPOCH= 1
CATEGORIES= cad
MASTER_SITES= ftp://ftp.geda.seul.org/pub/geda/release/v1.4/${PORTVERSION}/ \
http://geda.seul.org/release/v1.4/${PORTVERSION}/
@@ -27,6 +28,14 @@ CONFIGURE_ARGS= --disable-update-mime-database \
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
post-patch:
@${REINPLACE_CMD} -E \
-e "s,^(DATADIR[[:space:]]*=[[:space:]]*)gEDA,\1geda," \
diff --git a/cad/libgeda/pkg-plist b/cad/libgeda/pkg-plist
index dabbfa9136d3..d369eae3c50c 100644
--- a/cad/libgeda/pkg-plist
+++ b/cad/libgeda/pkg-plist
@@ -35,10 +35,10 @@ share/icons/hicolor/48x48/mimetypes/application-x-geda-symbol-48.png
share/icons/hicolor/scalable/mimetypes/application-x-geda-gsch2pcb-project.svg
share/icons/hicolor/scalable/mimetypes/application-x-geda-schematic.svg
share/icons/hicolor/scalable/mimetypes/application-x-geda-symbol.svg
-share/locale/de_DE/LC_MESSAGES/libgeda33.mo
-share/locale/en_GB/LC_MESSAGES/libgeda33.mo
-share/locale/es_ES/LC_MESSAGES/libgeda33.mo
-share/locale/nl_NL/LC_MESSAGES/libgeda33.mo
+%%NLS%%share/locale/de_DE/LC_MESSAGES/libgeda33.mo
+%%NLS%%share/locale/en_GB/LC_MESSAGES/libgeda33.mo
+%%NLS%%share/locale/es_ES/LC_MESSAGES/libgeda33.mo
+%%NLS%%share/locale/nl_NL/LC_MESSAGES/libgeda33.mo
share/mime/packages/libgeda.xml
share/mimelnk/application/x-geda-gsch2pcb-project.desktop
share/mimelnk/application/x-geda-schematic.desktop
@@ -47,10 +47,10 @@ share/mimelnk/application/x-geda-symbol.desktop
@dirrmtry share/mimelnk
@dirrmtry share/mime/packages
@dirrmtry share/mime
-@dirrmtry share/locale/nl_NL/LC_MESSAGES
-@dirrmtry share/locale/nl_NL
-@dirrmtry share/locale/de_DE/LC_MESSAGES
-@dirrmtry share/locale/de_DE
+%%NLS%%@dirrmtry share/locale/nl_NL/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/nl_NL
+%%NLS%%@dirrmtry share/locale/de_DE/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/de_DE
@dirrmtry share/icons/hicolor/scalable/mimetypes
@dirrmtry share/icons/hicolor/scalable
@dirrmtry share/icons/hicolor/48x48/mimetypes