aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorMichael Reifenberger <mr@FreeBSD.org>2022-09-06 17:39:13 +0000
committerMichael Reifenberger <mr@FreeBSD.org>2022-09-06 17:44:05 +0000
commita025e9ce23e0b36a27d3675a5ce3158e07ab181d (patch)
tree2112a57cbb94a93d75ddf2bb8e7d544b0f9b5238 /cad
parent8a046dc0984bc9dae98cbc74d85eeabb649d30d6 (diff)
downloadports-a025e9ce23e0b36a27d3675a5ce3158e07ab181d.tar.gz
ports-a025e9ce23e0b36a27d3675a5ce3158e07ab181d.zip
cad/openscad-devel: Fix build
Remove qmake from USES. Remove buildtools, add qmake_build to USE_QT. Add two patches which got missed previously. This should satisfy the build.
Diffstat (limited to 'cad')
-rw-r--r--cad/openscad-devel/Makefile6
-rw-r--r--cad/openscad-devel/files/patch-cmake_Modules_FindQt5QScintilla.cmake10
-rw-r--r--cad/openscad-devel/files/patch-src_handle__dep.cc8
3 files changed, 21 insertions, 3 deletions
diff --git a/cad/openscad-devel/Makefile b/cad/openscad-devel/Makefile
index 790240f858bf..0ee27c803d9c 100644
--- a/cad/openscad-devel/Makefile
+++ b/cad/openscad-devel/Makefile
@@ -1,6 +1,6 @@
PORTNAME= openscad
PORTVERSION= 2022.09.03
-#PORTREVISION= 1
+PORTREVISION= 1
CATEGORIES= cad
PKGNAMESUFFIX= -devel
@@ -30,11 +30,11 @@ LIB_DEPENDS= libzip.so:archivers/libzip \
CONFLICTS= openscad
USES= bison cmake compiler:c++14-lang cpe desktop-file-utils eigen:3 gettext \
- gl gnome pkgconfig qmake qt:5 shared-mime-info xorg
+ gl gnome pkgconfig qt:5 shared-mime-info xorg
USE_GITHUB= yes
USE_GL= gl glu glew
USE_GNOME= cairo glib20 libxml2
-USE_QT= buildtools buildtools_build core concurrent_build dbus gui multimedia svg widgets
+USE_QT= buildtools_build core concurrent_build dbus gui multimedia qmake_build svg widgets
USE_XORG= x11
GH_ACCOUNT= microsoft:mimalloc
GH_PROJECT= MCAD:mcad mimalloc:mimalloc
diff --git a/cad/openscad-devel/files/patch-cmake_Modules_FindQt5QScintilla.cmake b/cad/openscad-devel/files/patch-cmake_Modules_FindQt5QScintilla.cmake
new file mode 100644
index 000000000000..e9b1a9fac601
--- /dev/null
+++ b/cad/openscad-devel/files/patch-cmake_Modules_FindQt5QScintilla.cmake
@@ -0,0 +1,10 @@
+--- cmake/Modules/FindQt5QScintilla.cmake.orig 2021-10-23 02:33:13 UTC
++++ cmake/Modules/FindQt5QScintilla.cmake
+@@ -50,6 +50,7 @@ find_path ( QT5QSCINTILLA_INCLUDE_DIR
+ )
+
+ set ( QT5QSCINTILLA_INCLUDE_DIRS ${QT5QSCINTILLA_INCLUDE_DIR} )
++set (Qt5Widgets_LIBRARIES /usr/local/lib/qt5 /usr/local/lib /usr/lib )
+
+ # version
+ set ( _VERSION_FILE ${QT5QSCINTILLA_INCLUDE_DIR}/qsciglobal.h )
diff --git a/cad/openscad-devel/files/patch-src_handle__dep.cc b/cad/openscad-devel/files/patch-src_handle__dep.cc
new file mode 100644
index 000000000000..6c23311f11e6
--- /dev/null
+++ b/cad/openscad-devel/files/patch-src_handle__dep.cc
@@ -0,0 +1,8 @@
+--- src/handle_dep.cc.orig 2021-10-23 10:18:49 UTC
++++ src/handle_dep.cc
+@@ -1,3 +1,5 @@
++#include <sys/types.h>
++#include <sys/wait.h>
+ #include "handle_dep.h"
+ #include "printutils.h"
+ #include <string>