aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2021-03-02 21:16:59 +0000
committerThierry Thomas <thierry@FreeBSD.org>2021-03-02 21:16:59 +0000
commita7074ba30efdbcccc1df582a5d320e2ba0f70a36 (patch)
tree590216fc5d3b2c7f4099f88bc9c44f9e7d4a1d8a /cad
parentb23553bac890c3d5846329c00fd8bf70dfe0f4f7 (diff)
downloadports-a7074ba30efdbcccc1df582a5d320e2ba0f70a36.tar.gz
ports-a7074ba30efdbcccc1df582a5d320e2ba0f70a36.zip
Optionize and set USES=mpi.
Notes
Notes: svn path=/head/; revision=566984
Diffstat (limited to 'cad')
-rw-r--r--cad/scotch/Makefile26
-rw-r--r--cad/scotch/pkg-plist36
2 files changed, 28 insertions, 34 deletions
diff --git a/cad/scotch/Makefile b/cad/scotch/Makefile
index 721cf331bf61..f1097c67d6e9 100644
--- a/cad/scotch/Makefile
+++ b/cad/scotch/Makefile
@@ -14,13 +14,15 @@ LICENSE_NAME= CeCILL-C
LICENSE_FILE= ${WRKSRC}/doc/CeCILL-C_V1-en.txt
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-CONFLICTS= gbase-0.* gmap-2015.*
-
USES= bison:alias gmake localbase
+CONFLICTS= gbase-0.* gmap-2015.*
+
MAKE_JOBS_UNSAFE=yes
-OPTIONS_DEFINE= DOCS EXAMPLES
+OPTIONS_DEFINE= DOCS EXAMPLES MPICH
+OPTIONS_DEFAULT=MPICH
+OPTIONS_SUB= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}
BUILD_WRKSRC= ${WRKSRC}/src
@@ -36,18 +38,10 @@ DOCVER= ${PORTVERSION:R:R}
PORTDOCS= ptscotch_user${DOCVER}.pdf scotch_user${DOCVER}.pdf scotch_example.f
LIBS= esmumps scotch scotcherr scotcherrexit scotchmetis
-.if !defined(WITHOUT_MPI)
-LIB_DEPENDS+= libmpi.so:net/mpich
-
-ALL_TARGET+= ptesmumps
-TEST_TARGET+= ptcheck
-
-LIBS+= ptesmumps ptscotch ptscotcherr ptscotcherrexit ptscotchparmetis
-
-PLIST_SUB+= MPI=""
-.else
-PLIST_SUB+= MPI="@comment "
-.endif
+MPICH_USES= mpi:mpich
+MPICH_ALL_TARGET= ptesmumps
+MPICH_TEST_TARGET= ptcheck
+MPICH_LIBS+= ptesmumps ptscotch ptscotcherr ptscotcherrexit ptscotchparmetis
.include <bsd.port.options.mk>
@@ -58,7 +52,7 @@ MF= x86-64
.endif
pre-everything::
-.if !defined(WITHOUT_MPI)
+.if !defined(WITHOUT_MPICH)
@${ECHO_MSG}
@${ECHO_MSG} "Define WITHOUT_MPI if PT-Scotch is not wanted."
@${ECHO_MSG}
diff --git a/cad/scotch/pkg-plist b/cad/scotch/pkg-plist
index e813b4b49d63..3aa73ad1fb13 100644
--- a/cad/scotch/pkg-plist
+++ b/cad/scotch/pkg-plist
@@ -6,12 +6,12 @@ bin/amk_hy
bin/amk_m2
bin/amk_p2
bin/atst
-%%MPI%%bin/dggath
-%%MPI%%bin/dgmap
-%%MPI%%bin/dgord
-%%MPI%%bin/dgpart
-%%MPI%%bin/dgscat
-%%MPI%%bin/dgtst
+%%MPICH%%bin/dggath
+%%MPICH%%bin/dgmap
+%%MPICH%%bin/dgord
+%%MPICH%%bin/dgpart
+%%MPICH%%bin/dgscat
+%%MPICH%%bin/dgtst
bin/gbase
bin/gcv
bin/gmap
@@ -32,22 +32,22 @@ bin/mmk_m2
bin/mmk_m3
bin/mord
bin/mtst
-include/ptscotch.h
-include/ptscotchf.h
+%%MPICH%%include/ptscotch.h
+%%MPICH%%include/ptscotchf.h
include/scotch.h
include/scotchf.h
lib/libesmumps.so
lib/libesmumps.so.0
-%%MPI%%lib/libptesmumps.so
-%%MPI%%lib/libptesmumps.so.0
-%%MPI%%lib/libptscotch.so
-%%MPI%%lib/libptscotch.so.0
-%%MPI%%lib/libptscotcherr.so
-%%MPI%%lib/libptscotcherr.so.0
-%%MPI%%lib/libptscotcherrexit.so
-%%MPI%%lib/libptscotcherrexit.so.0
-%%MPI%%lib/libptscotchparmetis.so
-%%MPI%%lib/libptscotchparmetis.so.0
+%%MPICH%%lib/libptesmumps.so
+%%MPICH%%lib/libptesmumps.so.0
+%%MPICH%%lib/libptscotch.so
+%%MPICH%%lib/libptscotch.so.0
+%%MPICH%%lib/libptscotcherr.so
+%%MPICH%%lib/libptscotcherr.so.0
+%%MPICH%%lib/libptscotcherrexit.so
+%%MPICH%%lib/libptscotcherrexit.so.0
+%%MPICH%%lib/libptscotchparmetis.so
+%%MPICH%%lib/libptscotchparmetis.so.0
lib/libscotch.so
lib/libscotch.so.0
lib/libscotcherr.so