aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2009-02-24 19:32:17 +0000
committerThierry Thomas <thierry@FreeBSD.org>2009-02-24 19:32:17 +0000
commitbcf7ceab4d810aed04a0a64bb20176af0f44d0a4 (patch)
treee6f83e638ec55cd61c3f0a30a1cbf1e9fa307e22 /cad
parente384901cb1b3253b5cad441e67c089c50454e38c (diff)
downloadports-bcf7ceab4d810aed04a0a64bb20176af0f44d0a4.tar.gz
ports-bcf7ceab4d810aed04a0a64bb20176af0f44d0a4.zip
Fix the previous patch.
PR: ports/131600 Submitted by: Cristiano Rolim Pereira <cristianorolim (at) hotmail.com>
Notes
Notes: svn path=/head/; revision=229010
Diffstat (limited to 'cad')
-rw-r--r--cad/opencascade/Makefile2
-rw-r--r--cad/opencascade/files/patch-ros_src_STEPConstruct_STEPConstruct_AP203Context.cxx15
2 files changed, 11 insertions, 6 deletions
diff --git a/cad/opencascade/Makefile b/cad/opencascade/Makefile
index b3ca84fef124..2c31a65ee53d 100644
--- a/cad/opencascade/Makefile
+++ b/cad/opencascade/Makefile
@@ -7,7 +7,7 @@
PORTNAME= opencascade
PORTVERSION= 6.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= cad science
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= thierry
diff --git a/cad/opencascade/files/patch-ros_src_STEPConstruct_STEPConstruct_AP203Context.cxx b/cad/opencascade/files/patch-ros_src_STEPConstruct_STEPConstruct_AP203Context.cxx
index 245322f6345c..15ae3f1def48 100644
--- a/cad/opencascade/files/patch-ros_src_STEPConstruct_STEPConstruct_AP203Context.cxx
+++ b/cad/opencascade/files/patch-ros_src_STEPConstruct_STEPConstruct_AP203Context.cxx
@@ -1,11 +1,16 @@
--- ./ros/src/STEPConstruct/STEPConstruct_AP203Context.cxx.orig 2001-09-21 10:00:28.000000000 +0200
-+++ ./ros/src/STEPConstruct/STEPConstruct_AP203Context.cxx 2009-01-24 11:45:15.000000000 +0100
-@@ -103,7 +103,7 @@
++++ ./ros/src/STEPConstruct/STEPConstruct_AP203Context.cxx 2009-02-24 18:59:57.000000000 +0100
+@@ -103,6 +103,13 @@
Handle(StepBasic_CoordinatedUniversalTimeOffset) zone =
new StepBasic_CoordinatedUniversalTimeOffset;
-- Standard_Integer shift = Standard_Integer(timezone);
-+ Standard_Integer shift = Standard_Integer((long long) timezone);
++
++ struct tm newtime;
++ time_t ltime;
++ ltime=time(&ltime);
++ localtime_r(&ltime, &newtime);
++ int timezone=newtime.tm_gmtoff;
++
+ Standard_Integer shift = Standard_Integer(timezone);
Standard_Integer shifth = abs ( shift ) / 3600;
Standard_Integer shiftm = ( abs ( shift ) - shifth * 3600 ) / 60;
- StepBasic_AheadOrBehind sense = ( shift >0 ? StepBasic_aobBehind :